Debian Testing, I cant upgrade Kodi :(

Everything about X, Gnome, KDE, ... and everything running on it

Debian Testing, I cant upgrade Kodi :(

Postby kerem » 2017-11-05 05:14

Hi

I have 3rd party repos enabled and I installed Kodi but I cant seem to be able to upgrade Kodi anymore. I am sure I messed up something here so please be gentle towards this gentle soul :)

Code: Select all

apt install kodi-bin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kodi-bin : Depends: libegl1 but it is not installable
            Depends: libmariadbclient18 (>= 10.1.28) but 10.1.26-0+deb9u1 is to be installed
E: Unable to correct problems, you have held broken packages.




Code: Select all
buster/sid
Linux lydia-4c 4.3.0-1-amd64 #1 SMP Debian 4.3.5-1 (2016-02-06) x86_64 GNU/Linux



Code: Select all

deb http://ftp.us.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.us.debian.org/debian/ testing main contrib non-free

deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free


deb http://http.debian.net/debian/ testing main contrib non-free


deb http://ftp.us.debian.org/debian/ testing-proposed-updates contrib non-free main


deb http://ftp.debian.org/debian experimental main



deb http://www.deb-multimedia.org testing main non-free





deb http://opensource.wandisco.com/debian wheezy svn18


deb http://http.debian.net/debian jessie-backports main
deb http://deb.nodesource.com/node_6.x stretch main


kerem
 
Posts: 192
Joined: 2010-06-16 16:29

Re: Debian Testing, I cant upgrade Kodi :(

Postby RU55EL » 2017-11-05 05:34

You need to do some reading at Debian Wiki. Then you probably need to reinstall your operating system.
User avatar
RU55EL
 
Posts: 309
Joined: 2014-04-07 03:42
Location: /home/russel

Re: Debian Testing, I cant upgrade Kodi :(

Postby dilberts_left_nut » 2017-11-05 05:57

You are mixing repo's for four different releases (well, 3 and development).
Expect breakage and legwork (yours, not someone else's).

apt is telling you exactly what is wrong:
kerem wrote:
Code: Select all
kodi-bin : Depends: libegl1 but it is not installable
            Depends: libmariadbclient18 (>= 10.1.28) but 10.1.26-0+deb9u1 is to be installed


To start you off:
https://packages.debian.org/buster/libegl1
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4687
Joined: 2009-10-05 07:54
Location: enzed

Re: Debian Testing, I cant upgrade Kodi :(

Postby kerem » 2017-11-05 06:36

Hi

Can you please tell me which repos that I should disable ?
kerem
 
Posts: 192
Joined: 2010-06-16 16:29

Re: Debian Testing, I cant upgrade Kodi :(

Postby Head_on_a_Stick » 2017-11-05 08:44

For goodness sake, just reinstall with Debian stable (stretch), Kodi works fine in that and it is unlikely to break any time soon.
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6666
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable