[SOLVED] Brightness Control missing on Debian 8

Everything about X, Gnome, KDE, ... and everything running on it

[SOLVED] Brightness Control missing on Debian 8

Postby bored_and_tired » 2017-11-22 13:38

Hi,
I've been using debian 8 from some time, with version 8.9 on dell inspiron 5000 series. Brightness control is missing from the beginning.
I installed xbacklight, but of no use.

ls /sys/class/backlight returns empty.

Also: /etc/default/grub reads like this:
GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="initrd=/install/gtk/initrd.gz"

My lspci output is as follows:
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast Ethernet controller (rev 07)

Any pointers will be greatly appreciated.
Last edited by bored_and_tired on 2017-11-27 13:03, edited 2 times in total.
bored_and_tired
 
Posts: 3
Joined: 2017-11-22 13:24

Re: Brightness Control missing on Debian 8

Postby bigrigdriver » 2017-11-25 20:31

This article at the ArchLinux Wiki might help: https://wiki.archlinux.org/index.php/ba ... _backlight

Scroll down to Backlight utilities, and try the xbacklight command listed there.
Registered GNU/Linux user #170078

Go as google before you ask on these boards.

It it isn't broken, Tweak It !!!
bigrigdriver
 
Posts: 134
Joined: 2014-09-01 17:04
Location: East Central Illinois, USA

Re: Brightness Control missing on Debian 8

Postby Head_on_a_Stick » 2017-11-25 22:11

bored_and_tired wrote:00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)

Skylake won't work with Debian jessie unless (selected) jessie-backports are employed, see this guide:

https://forums.bunsenlabs.org/viewtopic.php?id=1185

Your video hardware does support Debian stretch (9.2) however so you should probably use that instead.
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6792
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Brightness Control missing on Debian 8

Postby bored_and_tired » 2017-11-27 07:20

Thank you Both!
@Head_on_a_stick, I followed the article at bunsenlabs, installed backports and I can actually now see brightness control. Brightness control is now working fine!
(my only complaint is my wifi is missing.. I will try to fix it, and if it doesn't work I'll create a new post.

Thanks so much! This is my first post at Debian forum and happy that I got solution and is working!! :D :D :D
bored_and_tired
 
Posts: 3
Joined: 2017-11-22 13:24

Re: Brightness Control missing on Debian 8

Postby bored_and_tired » 2017-11-27 08:00

I did this -
Code: Select all
 
apt-get -t jessie-backports install firmware-iwlwifi
modprobe iwlwifi


As mentioned in https://unix.stackexchange.com/question ... -on#354908

Wifi working! Everything resolved. Problem Solved! :D :D
bored_and_tired
 
Posts: 3
Joined: 2017-11-22 13:24


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable