[help] MATE: authentication breakage after Jessie upgrade

Everything about X, Gnome, KDE, ... and everything running on it

[help] MATE: authentication breakage after Jessie upgrade

Postby TomRoche » 2018-01-10 19:20

summary: 9 Jan 2018 I upgraded kernel on a box that has been running LMDE2/Jessie with desktop=MATE. After the upgrade, the desktop

  • is demanding authentication (via `gksudo`-style dialogs) in situations where I've never seen them before: e.g., auto- and dismounting USB drives, sleep/suspend
  • sleep/suspend via `Fn-F4` is broken (though C-A-D still works, with dialog=`Authenticate`)
  • Network Manager disconnect is fully broken, with a message that suggests an authentication problem. (Fortunately it can be restarted from commandline.)

I did the same `full-upgrade` with another box running LMDE2 with Xfce; after reboot, it runs normally, with none of the above problems.

How to fix the MATE problems?

details:

I'm running LMDE2 (~= Jessie) on several workstations. When I got the notification for the recent kernel upgrade (8 or 9 Jan 2018), I first upgraded my "backup box" (i.e., older than my main workstation, not as old as my "last-ditch box"). The backup box had been running kernel version=3.16.0-4/3.16.51-3 (2017-12-13) and now runs (post-upgrade)

Code: Select all
$ date
Tue Jan  9 21:30:34 MST 2018
$ uname -rsv
Linux 3.16.0-5-amd64 #1 SMP Debian 3.16.51-3+deb8u1 (2018-01-08)
$ lsb_release -ds
LMDE 2 Betsy
$ cat /etc/debian_version
8.10
$ gcc --version | head -n 1
gcc (Debian 4.9.2-10) 4.9.2
$ ~/bin/get_NVIDIA_version.sh
nvidia-settings:  version 340.104  (buildmeister@swio-display-x64-rhel04-19)  Thu Sep 14 17:27:48 PDT 2017
$ X -version 2>&1 | grep -ve '^$\|^[[:space:]]\|Current Operating System:'
X.Org X Server 1.16.4
Release Date: 2014-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.0-4-amd64 x86_64 Debian
Kernel command line: BOOT_IMAGE=/vmlinuz-3.16.0-5-amd64 root=/dev/mapper/LUKS_plus_LVM2-root ro quiet splash nomodeset nouveau.modeset=0
Build Date: 14 October 2017  10:41:31AM
xorg-server 2:1.16.4-1+deb8u2 (http://www.debian.org/support)
Current version of pixman: 0.32.6
$ x-window-manager --version | head -1
metacity 3.14.3
$ ~/bin/get_GNOME_version.sh
GNOME version=3.14.1 date=2014-10-19
$ ~/bin/get_wm_version.sh
MATE 1.18.0


The full-upgrade appeared to go smoothly, but I'm noticing 3 problems afterward. I guessed the behavior change was not MATE-driven, since no MATE packages upgraded. However I repeated the full-upgrade on my oldest box, a 32-bit running Xfce: it now has the same version kernel (though 686-pae) but none of the following problems. My newest main workstation runs Cinnamon: I'd test on that, but I very much don't want to encounter the following problems on it.

The problems are, in order of increasing severity:

1. When I automount a non-encrypted external (USB) drive, I get a `sudo`-style GUI dialog with title=`Authenticate` and headline=`Authentication is required to mount [drive description] (/dev/sdb1)`. I did not formerly observe this behavior. More annoyingly, I get the same dialog when I dismount the drive, which seems quite excessive.

Any suggestions for how to disable this? I'm not seeing any affordances in MATE Control Center regarding removable drives (though I could be missing something).

2. Suspend to RAM, aka sleep:

2.1. I can no longer sleep this box with the `Fn-F4` keychord. Formerly that just went to sleep; now I get the screenlock dialog. Authenticating that gets just gets me back where I was (i.e., an unslept desktop).

2.2. If instead I do C-A-D, and click button=Suspend on the subsequent dialog, I get ... the GUI dialog again! with same title=`Authenticate`, but with headline=`Authentication is required for suspending the system.` After I authenticate as demanded, the box usually sleeps, but on one case it instead logged me out.

This is even more annoying--suggestions for how to restore the previous behavior (i.e., just go to @#$%^&! sleep when I tell you !-) will be greatly appreciated.

3. Network Manager:

For several years I've noticed that this box will fail to reconnect to wireless on waking: the Network Manager tray icon will appear normal, but attempts to use wireless will fail. (Unlike my newer main workstation, which does not have this problem.) In the past, this has not been a problem, I just used the Network Manager GUI to dis/reconnect the desired SSID. However, post-upgrade, when I use the Network Manager GUI to disconnect, I get a dialog with title=`Disconnect failure`, subtitle=`Device disconnect failed`, and body=

Code: Select all
(32) No session found for uid 1000 (unknown)


Fortunately I can (at least, for now) workaround this problem from the commandline with

Code: Select all
$ sudo service network-manager restart
> [ ok ] Stopping network connection manager: NetworkManager.
> [ ok ] Starting network connection manager: NetworkManager.


but this is yet more annoying still. Hence ...

... your assistance with any of the above will be greatly appreciated.
TomRoche
 
Posts: 26
Joined: 2012-07-08 23:43

Re: [help] MATE: authentication breakage after Jessie upgrad

Postby None1975 » 2018-01-11 13:46

LMDE 2 Betsy is not Debian 8. Ask your question in Linux Mint forums.
OS: Debian 9.3 / WM: Ratpoison
Debian Wiki | DontBreakDebian, Ratpoison
User avatar
None1975
 
Posts: 306
Joined: 2015-11-29 18:23
Location: Lithuania


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable