No sound when connected via XRDP *SOLVED*

Everything about X, Gnome, KDE, ... and everything running on it

No sound when connected via XRDP *SOLVED*

Postby Derpbian » 2018-02-21 21:36

Hi,

Is there any way to get sound from my debian machine when I use XRDP to connect to it? Im connection to my Debian 9 machine using RDP and it works fine, except the that the audio is missing. I was told by a friend to follow this guide, https://scarygliders.net/2012/04/06/get-audio-with-your-xrdpx11rdp-connections-lan-or-remote/

It was written in 2012 so it might be outdated, Or should I simply follow the instructions and take backups of any files I modify?

Cheers.
Last edited by Derpbian on 2018-02-23 05:26, edited 1 time in total.
su
User avatar
Derpbian
 
Posts: 27
Joined: 2018-02-11 02:46

Re: No sound when connected via XRDP

Postby Derpbian » 2018-02-22 13:12

su
User avatar
Derpbian
 
Posts: 27
Joined: 2018-02-11 02:46

Re: No sound when connected via XRDP

Postby Derpbian » 2018-02-22 13:12

Derpbian wrote:Does anybody know if this might be a valid solution? https://github.com/neutrinolabs/xrdp/wiki/Audio-Output-Virtual-Channel-support-in-xrdp


I have pulse audio 10.0 so I might try it...
su
User avatar
Derpbian
 
Posts: 27
Joined: 2018-02-11 02:46

Re: No sound when connected via XRDP *Solved*

Postby Derpbian » 2018-02-23 05:26

I just resorted to install plex server and use it to watch movies etc on my debian machine. And do other tasks via SSH / RDP from my Windows machine
su
User avatar
Derpbian
 
Posts: 27
Joined: 2018-02-11 02:46


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable