Keyboard shortcut keeps reverting in GNOME 3.22.3

Everything about X, Gnome, KDE, ... and everything running on it

Keyboard shortcut keeps reverting in GNOME 3.22.3

Postby deepee » 2018-02-28 15:18

After installing Debian Stretch with GNOME 3.22.3, I went into Settings --> Keyboard and assigned Alt+Tab to "switch windows". That worked, except that the shortcut can randomly change to "switch application" (like Super+Tab) and can also randomly switch back. Hunting around on the web, I followed a suggestion to set org/gnome/settings-daemon/plugins/keyboard/active to false in dconf, but this didn't help.

The only thing that helps is restarting the desktop (Alt+F2, r), sometimes twice, to get back the desired keybinding. Any ideas?

Thanks,
Deepee
deepee
 
Posts: 4
Joined: 2014-11-28 18:27

Re: Keyboard shortcut keeps reverting in GNOME 3.22.3

Postby deepee » 2018-03-06 16:31

I think I've figured this out. The problem was that "switch application" is by default mapped to both Super+Tab and Alt+Tab. So assigning something else to Alt+Tab in the Keyboard settings will have the bizarre effect of making Alt+Tab randomly switch between the two bindings.

The solution is to change the settings directly. In dconf, I changed /org/gnome/desktop/wm/keybindings/switch-applications to just Super+Tab and /org/gnome/desktop/wm/keybindings/switch-windows to Alt+Tab and the same for the "backwards" versions.
deepee
 
Posts: 4
Joined: 2014-11-28 18:27


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable