Telegram-desktop instillation issue - Debian Stretch

Everything about X, Gnome, KDE, ... and everything running on it

Telegram-desktop instillation issue - Debian Stretch

Postby redfirefly » 2018-03-01 05:43

Having a problem installing Telegram-desktop in Debian Mate Stretch.

Code: Select all
telegram-desktop:
 Depends: qt5-image-formats-plugins but it is not going to be installed
  Depends: libavcodec57 (>=7:3.4.1) but 7:3.2.10-1~deb9u1 is to be installed or
    libavcodec-extra57 but it is not going to be installed
  Depends: libavformat57 (>=7:3.4.1) but 7:3.2.10-1~deb9u1 is to be installed
  Depends: libavutil55 (>=7:3.4.1) but 7:3.2.10-1~deb9u1 is to be installed
 Depends: libminizip1 but it is not going to be installed
  Depends: libqt5core5a (>=5.9.0~beta) but 5.7.1+dfsg-3+b1 is to be installed
  Depends: libswresample2 (>=7:3.4.1) but 7:3.2.10-1~deb9u1 is to be installed
  Depends: libswscale4 (>=7:3.4.1) but 7:3.2.10-1~deb9u1 is to be installed
 Depends: libtgvoip1.0 but it is not going to be installed
 Depends: qtbase-abi-5-9-2
 Recommends: libappindicator3-1 but it is not going to be installed



In terminal I ran:
dpkg --get-selections | grep hold
Which did not display any results which implied no packages were held.

Already did a
apt-get update
apt-get upgrade

Pl. help.
Last edited by redfirefly on 2018-03-01 06:51, edited 1 time in total.
redfirefly
 
Posts: 2
Joined: 2018-03-01 05:29

Re: Telegram-desktop instillation issue - Debian Stretch

Postby dilberts_left_nut » 2018-03-01 05:54

You appear to be trying to install the testing version, while you are running stretch.

It's available in stretch-backports - use that (and immediately remove testing from your sources before you break everything!).

edit: and quit with the huge-arse screenshots... text is fine.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4867
Joined: 2009-10-05 07:54
Location: enzed

Re: Telegram-desktop instillation issue - Debian Stretch

Postby redfirefly » 2018-03-01 06:54

dilberts_left_nut wrote:You appear to be trying to install the testing version, while you are running stretch.

It's available in stretch-backports - use that (and immediately remove testing from your sources before you break everything!).

edit: and quit with the huge-arse screenshots... text is fine.



Thanks for your time and your quick reply.
Had used instructions mentioned here: https://linuxconfig.org/how-to-install- ... etch-linux
to get the latest Firefox Quantum

Figured out how to use backports from https://backports.debian.org/Instructions/
, thanks

deb http://ftp.debian.org/debian stretch-backports main

Regards,
Red
redfirefly
 
Posts: 2
Joined: 2018-03-01 05:29

Re: Telegram-desktop instillation issue - Debian Stretch

Postby dilberts_left_nut » 2018-03-01 07:27

:roll:

Don't take advice from anywhere that starts with "add sid repo's".

Use the Debian wiki for info, at least until you can tell the difference between good and piss poor advice.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4867
Joined: 2009-10-05 07:54
Location: enzed

Re: Telegram-desktop instillation issue - Debian Stretch

Postby stevepusser » 2018-03-02 04:39

64-bit Stretch users can also install the latest version with a flatpak, if you don't mind it being 300 MB.

Code: Select all
# apt install flatpak

$ flatpak remote-add --if-not-exists flathub https://dl.flathub.org/repo/flathub.flatpakrepo

$ flatpak install --from https://flathub.org/repo/appstream/org.telegram.desktop.flatpakref


I was trying to backport the Buster version this morning per a request, but apparently it needs to compile using gcc-7. I tried to use clang 5.0 as the compiler, but that failed with different errors.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.6, Pale Moon 28.1.0, wine-staging 3.16, qBittorrent 4.1.3, Linux kernel 4.18.8, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9901
Joined: 2009-10-06 05:53

Re: Telegram-desktop instillation issue - Debian Stretch

Postby sunrat » 2018-03-02 08:24

I've used both the installer from https://desktop.telegram.org/ and using the Debian unstable repo (in an unstable installation) and they both work fine.
In Stretch the preferred method would be the backports repo of course.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2426
Joined: 2006-08-29 09:12
Location: Melbourne, Australia


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable