Openshot and Blender

Everything about X, Gnome, KDE, ... and everything running on it

Openshot and Blender

Postby akuankkis » 2018-03-18 06:58

I can't make animated text in Openshot. Error message below.
Blender is installed. What is missing?

Code: Select all
Blender, the free open source 3D content creation suite is required for this action (http://www.blender.org).

Please check the preferences in OpenShot and be sure the Blender executable is correct.  This setting should be the path of the 'blender' executable on your computer.  Also, please be sure that it is pointing to Blender version 2.62 or greater.

Blender Path:
blender

Virhetuloste
No frame was found in the output from Blender
Last edited by akuankkis on 2018-03-21 05:37, edited 2 times in total.
akuankkis
 
Posts: 71
Joined: 2011-10-09 09:29

Re: Openshot and Blender

Postby debiman » 2018-03-18 07:27

output of
Code: Select all
which blender
please.
User avatar
debiman
 
Posts: 2127
Joined: 2013-03-12 07:18

Re: Openshot and Blender

Postby akuankkis » 2018-03-18 10:18

debiman wrote:output of which blender please.

/usr/bin/blender
akuankkis
 
Posts: 71
Joined: 2011-10-09 09:29

Re: Openshot and Blender

Postby debiman » 2018-03-18 16:54

so maybe
Code: Select all
Blender Path:
blender

needs to be
Code: Select all
Blender Path:
/usr/bin/blender
???
idk, just guessing.
does blender work by itself?

or maybe /usr/bin/blender is just a wrapper script, and you need to point openshot to the actual executable?
User avatar
debiman
 
Posts: 2127
Joined: 2013-03-12 07:18

Re: Openshot and Blender

Postby ruffwoof » 2018-03-18 17:19

Works in Jessie, not so sure about Stretch (I still run Jessie and when I last tried Stretch Openshot and Blender didn't work together).

For full operation Openshot requires inkscape and blender also to be installed and in particular blender has to be the right version.
Debian oldstable
Acer Aspire M3201 (2GB), Radeon HD3200, AMD Phenom X4
ruffwoof
 
Posts: 234
Joined: 2016-08-20 21:00

Re: Openshot and Blender

Postby stevepusser » 2018-03-18 18:30

So what version of Blender have you installed?

Code: Select all
apt policy blender
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Notepadqq 1.2.0, Pale Moon 27.8.3, KeePassXC 2.3.1, Calligra 3.1, VLC 3.0.1, Firefox 59.0.2, Shotwell 28.2
User avatar
stevepusser
 
Posts: 9440
Joined: 2009-10-06 05:53

Re: Openshot and Blender

Postby akuankkis » 2018-03-19 05:05

I tried versions.
openshot 1.4.3-1.2
openshot 1.4.3-dmo4
blender 2.78.a+dfsg0-4

They all work fine separetly but not together.

Then I downloaded from Openshot homepage https://www.openshot.org appimage package.
It works!

But Ican't save the movie
Last edited by akuankkis on 2018-03-21 05:41, edited 1 time in total.
akuankkis
 
Posts: 71
Joined: 2011-10-09 09:29

Re: Openshot and Blender

Postby stevepusser » 2018-03-19 19:05

akuankkis wrote:I tried versions.
openshot 1.4.3-1.2
openshot 1.4.3-dmo4
blender 2.78.a+dfsg0-4

They all work fine separetly but not together.

Then I downloaded from Openshot homepage https://www.openshot.org appimage package.
It works!


That is because it's the 2.X Qt 5 version of Openshot. The 1.X series development was halted years ago, and is no longer compatible with the newer Blender releases.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Notepadqq 1.2.0, Pale Moon 27.8.3, KeePassXC 2.3.1, Calligra 3.1, VLC 3.0.1, Firefox 59.0.2, Shotwell 28.2
User avatar
stevepusser
 
Posts: 9440
Joined: 2009-10-06 05:53

Re: Openshot and Blender

Postby debiman » 2018-03-20 07:02

akuankkis wrote:I tried versions.
openshot 1.4.3-1.2
openshot 1.4.3-dmo4
blender 2.78.a+dfsg0-4

how did you install all these?
the openshot versions look like on my jessie system!
and blender?
it seems they are not compatible.
maybe output of
Code: Select all
apt update
apt-cache policy openshot blender
please?

i think you should rather try to fix this than circumvent it by using an appimage.
User avatar
debiman
 
Posts: 2127
Joined: 2013-03-12 07:18

Re: [WORKAROUND] Openshot and Blender

Postby akuankkis » 2018-03-20 07:34

how did you install all these?
the openshot versions look like on my jessie system!

Openshot 1.4.3-1.2 and blender 2.78.a+dfsg0-4 are official Stretch packages.
Openshot 1.4.3-dmo4 is Stretch package from deb-multimedia.
akuankkis
 
Posts: 71
Joined: 2011-10-09 09:29

Re: Openshot and Blender

Postby akuankkis » 2018-03-21 05:44

i think you should rather try to fix this than circumvent it by using an appimage.


Appimage works fine until I want to save my movie. Red button do nothing.
akuankkis
 
Posts: 71
Joined: 2011-10-09 09:29


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable