No sound after upgrade from Jessie to Stretch

Everything about X, Gnome, KDE, ... and everything running on it

No sound after upgrade from Jessie to Stretch

Postby boycottsystemd » 2018-03-31 10:39

Code: Select all
mplayer:
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   0.0 (unknown) of 1485.0 (24:45.0) ??,?%
Audio device got stuck!
A:   0.0 (unknown) of 1485.0 (24:45.0) ??,?%
Audio device got stuck!
A:  17.8 (17.7) of 1485.0 (24:45.0)  0.8%


Code: Select all
lspci -v
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
   Subsystem: Intel Corporation NM10/ICH7 Family High Definition Audio Controller
   Flags: bus master, fast devsel, latency 0, IRQ 28
   Memory at 902c0000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: [50] Power Management version 2
   Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
   Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
   Capabilities: [100] Virtual Channel
   Capabilities: [130] Root Complex Link
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd_hda_intel


Any idea please how to fix it ?
boycottsystemd
 
Posts: 7
Joined: 2018-03-31 10:24

Re: No sound after upgrade from Jessie to Stretch

Postby Wheelerof4te » 2018-03-31 11:07

Code: Select all
apt install pulseaudio gstreamer1.0-libav


You haven't written which DE you use. Did you try something other than mplayer?
User avatar
Wheelerof4te
 
Posts: 1134
Joined: 2015-08-30 20:14

Re: No sound after upgrade from Jessie to Stretch

Postby boycottsystemd » 2018-03-31 11:18

Wheelerof4te wrote:
Code: Select all
apt install pulseaudio gstreamer1.0-libav


You haven't written which DE you use. Did you try something other than mplayer?


Thank you.

These packages are already installed.
LXDE
I also tried Adobe flash player and vlc:

Code: Select all
mpgatofixed32 audio converter error: libmad error: bad main_data_begin pointer
boycottsystemd
 
Posts: 7
Joined: 2018-03-31 10:24

Re: No sound after upgrade from Jessie to Stretch

Postby Head_on_a_Stick » 2018-03-31 11:32

Can we please see the output of
Code: Select all
loginctl list-sessions
aplay -l

Did you follow the instructions when upgrading?

https://www.debian.org/releases/stable/ ... ng.en.html
User avatar
Head_on_a_Stick
 
Posts: 8009
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: No sound after upgrade from Jessie to Stretch

Postby boycottsystemd » 2018-03-31 15:16

Head_on_a_Stick wrote:Can we please see the output of
Code: Select all
loginctl list-sessions
aplay -l

Did you follow the instructions when upgrading?

https://www.debian.org/releases/stable/ ... ng.en.html


Code: Select all
loginctl list-sessions
   SESSION        UID USER             SEAT             TTY             
         2       1000 some_user_name               seat0   


Code: Select all
aplay -l
**** List of PLAYBACK Hardware Devices ****
cad 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


I did follow https://linuxconfig.org/how-to-upgrade-debian-8-jessie-to-debian-9-stretch only when upgrading.
Check commands from that web page were ok.
boycottsystemd
 
Posts: 7
Joined: 2018-03-31 10:24

Re: No sound after upgrade from Jessie to Stretch

Postby Head_on_a_Stick » 2018-03-31 15:17

Can we also see
Code: Select all
amixer

Thanks!
User avatar
Head_on_a_Stick
 
Posts: 8009
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: No sound after upgrade from Jessie to Stretch

Postby boycottsystemd » 2018-03-31 15:22

Head_on_a_Stick wrote:Can we also see
Code: Select all
amixer

Thanks!


You are welcomed, I thank you.
Code: Select all
$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 36672 [56%] [on]
  Front Right: Playback 36016 [55%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 65536 [100%] [on]
  Front Right: Capture 65536 [100%] [on]
boycottsystemd
 
Posts: 7
Joined: 2018-03-31 10:24

Re: No sound after upgrade from Jessie to Stretch

Postby Head_on_a_Stick » 2018-03-31 15:30

^ That looks like that should work, do you get any sound if you run
Code: Select all
speaker-test
User avatar
Head_on_a_Stick
 
Posts: 8009
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: No sound after upgrade from Jessie to Stretch

Postby boycottsystemd » 2018-03-31 15:38

Head_on_a_Stick wrote:^ That looks like that should work, do you get any sound if you run
Code: Select all
speaker-test

no sound
boycottsystemd
 
Posts: 7
Joined: 2018-03-31 10:24


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable