{SOLVED} Cannot open html file from mtp device

Everything about X, Gnome, KDE, ... and everything running on it

{SOLVED} Cannot open html file from mtp device

Postby babcat » 2018-04-19 19:47

Hello, the device is an android phone, I can mount / unmount from thunar file manager, browse folders, read, write, but cannot open any *.html, neither with geany nor with firefox. Message from Firefox (Iceweasel):
The address wasn't understood. Iceweasel doesn't know how to open this address, because one of the following protocols (mtp) isn't associated with any program or is not allowed in this context.You might need to install other software to open this address.

Geany opens an untitled document and returns nothing.

Code: Select all
baba@debian:~$ mtp-detect
Unable to open ~/.mtpz-data for reading, MTPZ disabled.
libmtp version: 1.1.8

Listing raw device(s)
Device 0 (VID=17ef and PID=2008) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
   Found 1 device(s):
   17ef:2008 @ bus 5, dev 5
Attempting to connect device(s)
Android device detected, assigning default bug flags
Last edited by babcat on 2018-05-24 07:43, edited 1 time in total.
Posts: 26
Joined: 2018-04-11 09:22

Re: Cannot open html file from mtp device

Postby debiman » 2018-04-20 02:25

It's because you're using gvfs, and firefox indeed cannot understand the path gvfs offers.
you can always try to tell firefox to treat gvfs paths as normal local files, but i'm not sure if that's even possible.

MTP is not intended to be an extension to your local filesystem, it's really designed to transfer files to/from your device, no more.

you might want to look into using mtpfs or jmtpfs instead.
User avatar
Posts: 3064
Joined: 2013-03-12 07:18

Re: Cannot open html file from mtp device

Postby babcat » 2018-05-24 07:42

Issue was solved by upgrading jmtpfs. I mount with jmtpfs -device=<busnum>,<devnum> /mount/point
unmount with fusermount -u /mount/point

And the html files open fine.
Posts: 26
Joined: 2018-04-11 09:22

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 9 guests