[SOLVED] possible to use cups from both 32 and 64 bit prog.?

Everything about X, Gnome, KDE, ... and everything running on it

[SOLVED] possible to use cups from both 32 and 64 bit prog.?

Postby gurfle » 2018-05-26 00:56

It does not appear to be possible on my Debian stretch (9.2.0).

I have amd64 cups installed by default, as my system architecture is 64-bit.
I would like to print from 32-bit win98 programs running under wine which requires installation of i386 cups.

First I try:
apt-get install cups:i386
Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cups:i386 : Depends: cups-filters:i386 (>= 1.0.24-3~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

So then I try:
apt-get install cups-filters:i386
Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cups-filters:i386 : Depends: cups-filters-core-drivers:i386 (>= 1.11.6-3) but it is not going to be installed
                     Conflicts: foomatic-filters
E: Unable to correct problems, you have held broken packages.

And finally:
apt-get install cups-filters-core-drivers:i386
Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  cups-browsed cups-daemon cups-ppdc cups-server-common dc foomatic-db-compressed-ppds foomatic-db-engine foomatic-filters hp-ppd hplip-data libcupscgi1
  libcupsmime1 libcupsppdc1 libfontembed1 libgutenprint2 libhpmud0 libmate-sensors-applet-plugin0 libqpdf17 libsane-hpaio libsnmp-base libsnmp30 libtcl8.6
  libtk8.6 libwebpdemux2 linux-image-4.9.0-3-amd64 mscompress openprinting-ppds printer-driver-all printer-driver-brlaser printer-driver-c2050
  printer-driver-c2esp printer-driver-cjet printer-driver-dymo printer-driver-escpr printer-driver-foo2zjs printer-driver-foo2zjs-common printer-driver-hpijs
  printer-driver-min12xxw printer-driver-pnm2ppa printer-driver-ptouch printer-driver-pxljr printer-driver-sag-gdi python3-pexpect python3-pil
  python3-ptyprocess python3-reportlab python3-reportlab-accel qpdf ssl-cert tcl tcl8.6 tk tk8.6
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  foomatic-filters libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libcomerr2:i386 libcups2:i386 libcupsfilters1:i386 libcupsimage2:i386
  libgssapi-krb5-2:i386 libjbig0:i386 libjpeg62-turbo:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 libnspr4:i386 libnss3:i386
  libopenjp2-7:i386 libpoppler64:i386 libqpdf17:i386 libsqlite3-0:i386 libtiff5:i386
Suggested packages:
  krb5-doc:i386 krb5-user:i386
Recommended packages:
  paps | cups | enscript | a2ps | mpage qpdf:i386
The following packages will be REMOVED:
  cups cups-core-drivers cups-filters cups-filters-core-drivers hplip printer-driver-gutenprint printer-driver-hpcups printer-driver-m2300w
  printer-driver-postscript-hp printer-driver-splix task-print-server
The following NEW packages will be installed:
  cups-filters-core-drivers:i386 foomatic-filters libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libcomerr2:i386 libcups2:i386
  libcupsfilters1:i386 libcupsimage2:i386 libgssapi-krb5-2:i386 libjbig0:i386 libjpeg62-turbo:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386
  libkrb5support0:i386 libnspr4:i386 libnss3:i386 libopenjp2-7:i386 libpoppler64:i386 libqpdf17:i386 libsqlite3-0:i386 libtiff5:i386
0 upgraded, 23 newly installed, 11 to remove and 0 not upgraded.
Need to get 0 B/6,105 kB of archives.
After this operation, 7,221 kB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.
Where I would end up with amd64 cups gone.

Is this how it's supposed to be?
Last edited by gurfle on 2018-05-30 17:30, edited 1 time in total.
User avatar
gurfle
 
Posts: 341
Joined: 2009-06-04 02:08
Location: Seattle, Washington, US

Re: Is it possible to use cups from both 32 and 64 bit progr

Postby shep » 2018-05-26 05:34

I suspect that Windows Apps do not provide a cups gui for direct printing via the cups spooler. If that is the case, why not just print to a file from the windows app, either *.ps or *.pdf, and then print the file directly from cups. A *.pdf or *ps file generated by a 32 bit Windows app is no different than one generated by 64 bit linux apps. This would avoid the need to install the extra lib32.
shep
 
Posts: 228
Joined: 2011-03-15 15:22

Re: Is it possible to use cups from both 32 and 64 bit progr

Postby gurfle » 2018-05-26 18:11

wine32 provides all aspects of printing service via cups:i386 to the windows binaries it runs. (That's how wine can be as simple, fast and unbloated as it is - as opposed to a VM). Thus, there are absolutely no printing facility binaries running in wine32 that it can communicate to (including "print to pdf file" options), until cups:i386 is running on the (amd64) machine that wine32 is running on. At least that is what I gather from this wine forum post.

Without cups:i386, I cannot print from windows 32-bit executables running in wine32. But since I need to print from amd64 linux as well, I also need cupds:amd64 installed.

Maybe this is asking too much, but it would be useful if anyone here can say whether or not it is, and if it is possible, help me understand how to make it happen. The problems encountered using apt I show above, make me suspect not, but perhaps one can get around them by forcing some part of the installation process? Of course I won't attempt anything like that without a much clearer understanding of the issues.

Thanks, Nick
User avatar
gurfle
 
Posts: 341
Joined: 2009-06-04 02:08
Location: Seattle, Washington, US

[SOLVED] possible to use cups from both 32 and 64 bit prog.?

Postby gurfle » 2018-05-30 17:28

Since none of the cups interface is needed for wine32 (which of course has to provide its own win95-type UI), it turned out to only be necessary to install libcups2:i386, for which no conflicts arise. This was pointed out to me in the thread of this post.
User avatar
gurfle
 
Posts: 341
Joined: 2009-06-04 02:08
Location: Seattle, Washington, US


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable