[SOLVED] XFCE failing to load after update

Everything about X, Gnome, KDE, ... and everything running on it

[SOLVED] XFCE failing to load after update

Postby scary-rob » 2018-07-14 17:21

In the last hour, I've run an update. Kernel has upgraded from 4.9.0-6 to 4.9.0-7. I also recall a swathe of nvidia updates that began with the removal of old nvidia packages.

After rebooting, XFCE is not loading - I'm just getting a terminal login prompt.

I've tried starting XFCE manually, but the result is:

Code: Select all
/usr/bin/startxfce4: Starting X server

/etc/X11/xinit/xserverrc: 3: exec: /usr/bin/X: not found
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error


Given that no-one else seems to have reported this problem (or at least, my googling hasn't turned up other examples of this), I assume I've done something silly. But I'm damned if I know what I've done to make an update remove a vital X component.

As an experiment, I tried installing xfce manually (without uninstalling it first). apt-get gave me a message that a slew of packages were no longer needed, including things like x11-session-utils.

I've never had to manipulate text files from terminal before, so I'm still working on how to go about putting /var/log/apt/history.log on a usb stick so I can copy and paste what aptitude did exactly on here from my laptop.

Incidentally, I have tried booting from the previous kernel, but I'm still getting no desktop.
Last edited by scary-rob on 2018-07-16 16:44, edited 1 time in total.
scary-rob
 
Posts: 16
Joined: 2018-06-22 15:57

Re: XFCE failing to load after update

Postby GarryRicketson » 2018-07-14 18:55

I'm still working on how to go about putting /var/log/apt/history.log on a usb stick so I can copy and paste what aptitude did exactly on here from my laptop.

That is pretty simple, easy.
First you need to make sure the usb stick is mounted:
If you need details on mounting it:
Code: Select all
man mount

or https://www.tutorialspoint.com/articles/how-to-mount-usb-drive-in-a-linux-system (there are other tutorials if you don't like that one)
Any way assuming it is mounted, 'lsblk' will show it, so for example
If it is mounted in /mnt/ and the directory "notes" exists,
Code: Select all
cp /var/log/apt/history.log  /mnt/notes/

copies the file to the /mnt/notes/ ,the file name will still be "history.log".
Or
Code: Select all
cat /var/log/apt/history.log > /mnt/notes/history.log

the > puts the output of the 'cat' command to a file in the directory "notes"
There are other various ways,also note, if you use the cp command, do not use the > . You can use a new file name for destination if you wish.
============== additional notes===
You must use "sudo" or be root "su", to mount the device.
I find it more convenient to make a directory, in my home dir, as me, a normal user:
Code: Select all
$pwd (to be sure where I am)
/home/me
$mkdir usb

There is now a dir named usb in
Code: Select all
/home/me/usb

So when I mount the device,as root:
Code: Select all
#mount /dev/sdb /home/me/usb

after it is mounted,
Code: Select all
#exit
$ (I am now back to being a normal user

This way I can read,write,copy files to the device as a normal user, with out needing to be root or useing "sudo".
The $ and # symbols are not part of the actual command, they only indicate that a normal user, or root is running the command.
Some people also use the /media dir, for this, as well,..there are many ways to do this, depends on what you are comfortable with.
Apology, I can not help with the XFCE problem, but someone else maybe can.
User avatar
GarryRicketson
 
Posts: 4957
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: XFCE failing to load after update

Postby shep » 2018-07-15 01:27

One possibility is that your upgrade is incomplete. Perhaps your server had only partially sync'd when you updated.

You can pass a boot parameter that does not start Xorg.

http://www.debianadmin.com/how-to-disab ... ebian.html
From the command line
Code: Select all
# less /var/log/Xorg.log
will provide you with the cause of the error and also allow you to run the update command again.

There are two video drivers; the Nouveau drivers and the nVidia proprietary drivers. If you are running the proprietary driver I would run the config commands again.
https://linuxconfig.org/how-to-install- ... etch-linux.

Nouveau should not need any reconfiguration.
shep
 
Posts: 212
Joined: 2011-03-15 15:22

Re: XFCE failing to load after update

Postby Head_on_a_Stick » 2018-07-15 15:41

scary-rob wrote:As an experiment, I tried installing xfce manually (without uninstalling it first). apt-get gave me a message that a slew of packages were no longer needed, including things like x11-session-utils.

Post the output, please (in full, using code tags).

shep wrote:You can pass a boot parameter that does not start Xorg.

http://www.debianadmin.com/how-to-disab ... ebian.html

That guide is outdated and seems to refer to LILO and sysvinit.

For GRUB & systemd the OP should press "e" with the Debian boot menu entry highlighted and add systemd.unit=multi-user.target to the end of the line that starts with "linux" and then press <Ctrl>+x (at the same time) to boot the modified entry.

In the unlikely event that the OP is using something other than systemd as PID1 (init) then the word text can be added instead.
E Pluribus Unix
User avatar
Head_on_a_Stick
 
Posts: 7785
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: XFCE failing to load after update

Postby scary-rob » 2018-07-15 18:26

UPDATE

Thank you all for your input on this so far. I've managed a "brute force" solution temporarily, which was to uninstall and reinstall XFCE in the hope that it pulled the missing part of the X server back in as a dependency (it worked). My settings were still in place, but my nvidia driver/firmware isn't doing what it should - just like when I first installed Stretch and hadn't installed/configured the nvidia packages, it's detecting my screen as 1024 x 768 (in reality it's a 1920 HD widescreen).

I will now get those outputs sorted out as best I can.

My apologies in advance to Head_on_a_stick, because although there is still a mess of "no longer required" packages, it's not quite the same now I've reinstalled XFCE. Logs etc to follow.
scary-rob
 
Posts: 16
Joined: 2018-06-22 15:57

Re: XFCE failing to load after update

Postby scary-rob » 2018-07-15 18:35

Thank you, Garry, for the mounting from terminal 101. I should have learned that years ago.

The contents of /var/log/apt/history.log are as follows:

Code: Select all
Start-Date: 2018-07-01  13:17:52
Commandline: apt-get install nautilus-dropbox
Requested-By: rob (1000)
Install: libindicator7:amd64 (0.5.0-3+b1, automatic), nautilus-dropbox:amd64 (2015.10.28-1), libdbusmenu-gtk4:amd64 (12.10.2-2, automatic), libappindicator1:amd64 (0.4.92-4, automatic), python-gpgme:amd64 (0.3-1.2, automatic)
End-Date: 2018-07-01  13:18:01

Start-Date: 2018-07-02  11:58:11
Commandline: apt-get dist-upgrade
Requested-By: rob (1000)
Upgrade: firefox-esr-l10n-nn-no:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), chromium:amd64 (66.0.3359.117-1~deb9u1, 67.0.3396.87-1~deb9u1), firefox-esr-l10n-sv-se:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-bn-bd:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-es-ar:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-bn-in:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-es-cl:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-es-es:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-es-mx:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-pt-br:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-pt-pt:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), libxenstore3.0:amd64 (4.8.3+xsa267+shim4.10.1+xsa267-1+deb9u8, 4.8.3+xsa267+shim4.10.1+xsa267-1+deb9u9), firefox-esr-l10n-ga-ie:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), libxen-4.8:amd64 (4.8.3+xsa267+shim4.10.1+xsa267-1+deb9u8, 4.8.3+xsa267+shim4.10.1+xsa267-1+deb9u9), firefox-esr-l10n-nb-no:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-zh-cn:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-zh-tw:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-ar:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-bg:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-bs:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-ca:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-cs:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-cy:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-da:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-de:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-el:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-eo:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-et:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-eu:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-fa:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-fi:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-fr:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-gl:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-he:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-hr:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-hu:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-id:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-is:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-it:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-ja:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-kk:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-km:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-kn:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-ko:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-lt:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-lv:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-mk:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-ml:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-mr:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-nl:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-pl:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-ro:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-ru:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-si:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-sk:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-sl:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-sq:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-sr:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-ta:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-te:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-th:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-tr:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-hi-in:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-uk:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-vi:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-ast:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-gu-in:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-en-gb:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-en-za:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1), firefox-esr-l10n-pa-in:amd64 (52.8.1esr-1~deb9u1, 52.9.0esr-1~deb9u1)
End-Date: 2018-07-02  11:59:30

Start-Date: 2018-07-02  12:01:08
Commandline: apt-get -f install
Requested-By: rob (1000)
Remove: viber:amd64 (7.0.0.1035)
End-Date: 2018-07-02  12:01:10

Start-Date: 2018-07-02  12:07:11
Commandline: apt-get -f install
Requested-By: rob (1000)
Remove: viber:amd64 (7.0.0.1035)
End-Date: 2018-07-02  12:07:13

Start-Date: 2018-07-04  01:50:59
Commandline: apt-get dist-upgrade
Requested-By: rob (1000)
Upgrade: libexiv2-14:amd64 (0.25-3.1, 0.25-3.1+deb9u1)
End-Date: 2018-07-04  01:51:03

Start-Date: 2018-07-08  21:59:04
Commandline: apt-get dist-upgrade
Requested-By: rob (1000)
Upgrade: libsoup-gnome2.4-1:amd64 (2.56.0-2+deb9u1, 2.56.0-2+deb9u2), gir1.2-soup-2.4:amd64 (2.56.0-2+deb9u1, 2.56.0-2+deb9u2), libsoup2.4-1:amd64 (2.56.0-2+deb9u1, 2.56.0-2+deb9u2)
End-Date: 2018-07-08  21:59:09

Start-Date: 2018-07-14  17:30:51
Commandline: apt-get dist-upgrade
Requested-By: rob (1000)
Install: irqbalance:amd64 (1.1.0-2.3, automatic), libgl1:amd64 (1.0.0+git20180308-2~bpo9+1, automatic), linux-headers-4.9.0-7-common:amd64 (4.9.110-1, automatic), linux-headers-4.9.0-7-amd64:amd64 (4.9.110-1, automatic), libgles2:amd64 (1.0.0+git20180308-2~bpo9+1, automatic), libglx0:amd64 (1.0.0+git20180308-2~bpo9+1, automatic), linux-image-4.9.0-7-amd64:amd64 (4.9.110-1, automatic), libglvnd0:amd64 (1.0.0+git20180308-2~bpo9+1, automatic)
Upgrade: libcups2:amd64 (2.2.1-8+deb9u1, 2.2.1-8+deb9u2), intel-microcode:amd64 (3.20170707.1~deb9u1, 3.20180425.1~deb9u1), libgles-nvidia1:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), linux-libc-dev:amd64 (4.9.88-1+deb9u1, 4.9.110-1), libldap-2.4-2:amd64 (2.4.44+dfsg-5+deb9u1, 2.4.44+dfsg-5+deb9u2), libnvidia-ml1:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), libxapian30:amd64 (1.4.3-2, 1.4.3-2+deb9u1), libsystemd0:amd64 (232-25+deb9u3, 232-25+deb9u4), update-glx:amd64 (0.8.3~bpo9+1, 0.8.3~deb9u1), libgs9:amd64 (9.20~dfsg-3.2+deb9u1, 9.20~dfsg-3.2+deb9u2), liblouis12:amd64 (3.0.0-3+deb9u1, 3.0.0-3+deb9u4), python3-louis:amd64 (3.0.0-3+deb9u1, 3.0.0-3+deb9u4), nvidia-vdpau-driver:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), udev:amd64 (232-25+deb9u3, 232-25+deb9u4), libglx-nvidia0:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), glx-alternative-nvidia:amd64 (0.8.3~bpo9+1, 0.8.3~deb9u1), linux-compiler-gcc-6-x86:amd64 (4.9.88-1+deb9u1, 4.9.110-1), cups-common:amd64 (2.2.1-8+deb9u1, 2.2.1-8+deb9u2), libmagic1:amd64 (1:5.30-1+deb9u1, 1:5.30-1+deb9u2), libnvidia-egl-wayland1:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), libpq5:amd64 (9.6.7-0+deb9u1, 9.6.9-0+deb9u1), nvidia-detect:amd64 (375.82-1~deb9u1, 384.130-1), libudev1:amd64 (232-25+deb9u3, 232-25+deb9u4), nvidia-kernel-dkms:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), libegl-nvidia0:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), nvidia-egl-common:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), dpkg:amd64 (1.18.24, 1.18.25), libnvidia-cfg1:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), nvidia-legacy-check:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), libmagic-mgc:amd64 (1:5.30-1+deb9u1, 1:5.30-1+deb9u2), nvidia-egl-wayland-icd:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), libnss-myhostname:amd64 (232-25+deb9u3, 232-25+deb9u4), linux-image-amd64:amd64 (4.9+80+deb9u4, 4.9+80+deb9u5), systemd-sysv:amd64 (232-25+deb9u3, 232-25+deb9u4), libldap-common:amd64 (2.4.44+dfsg-5+deb9u1, 2.4.44+dfsg-5+deb9u2), nvidia-kernel-support:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), glx-diversions:amd64 (0.8.3~bpo9+1, 0.8.3~deb9u1), libpam-systemd:amd64 (232-25+deb9u3, 232-25+deb9u4), linux-headers-amd64:amd64 (4.9+80+deb9u4, 4.9+80+deb9u5), linux-kbuild-4.9:amd64 (4.9.88-1+deb9u1, 4.9.110-1), ghostscript:amd64 (9.20~dfsg-3.2+deb9u1, 9.20~dfsg-3.2+deb9u2), shared-mime-info:amd64 (1.8-1, 1.8-1+deb9u1), systemd:amd64 (232-25+deb9u3, 232-25+deb9u4), nvidia-driver-bin:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), libgs9-common:amd64 (9.20~dfsg-3.2+deb9u1, 9.20~dfsg-3.2+deb9u2), file:amd64 (1:5.30-1+deb9u1, 1:5.30-1+deb9u2), ca-certificates:amd64 (20161130+nmu1, 20161130+nmu1+deb9u1), liblouis-data:amd64 (3.0.0-3+deb9u1, 3.0.0-3+deb9u4), cups-bsd:amd64 (2.2.1-8+deb9u1, 2.2.1-8+deb9u2), glx-alternative-mesa:amd64 (0.8.3~bpo9+1, 0.8.3~deb9u1), nvidia-egl-wayland-common:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), libcupsimage2:amd64 (2.2.1-8+deb9u1, 2.2.1-8+deb9u2), cups-client:amd64 (2.2.1-8+deb9u1, 2.2.1-8+deb9u2), patch:amd64 (2.7.5-1+b2, 2.7.5-1+deb9u1), libnvidia-glcore:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), libfaad2:amd64 (2.8.0~cvs20161113-1, 2.8.0~cvs20161113-1+deb9u1), libnvidia-eglcore:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1), base-files:amd64 (9.9+deb9u4, 9.9+deb9u5), nvidia-alternative:amd64 (390.48-2~bpo9+3, 390.67-2~bpo9+1)
Remove: xserver-xorg-input-all:amd64 (1:7.7+19), xserver-xorg:amd64 (1:7.7+19), xserver-xorg-video-qxl:amd64 (0.1.4+20161126git4d7160c-1), xserver-xorg-video-vesa:amd64 (1:2.3.4-1+b2), libgles2-mesa:amd64 (13.0.6-1+b2), libglx0-glvnd-nvidia:amd64 (390.48-2~bpo9+3), xserver-xorg-video-nouveau:amd64 (1:1.0.13-3), xserver-xorg-video-amdgpu:amd64 (1.2.0-1+b1), libgles-nvidia2:amd64 (390.48-2~bpo9+3), nvidia-vulkan-icd:amd64 (390.48-2~bpo9+3), xserver-xorg-core:amd64 (2:1.19.2-1+deb9u2), nvidia-egl-icd:amd64 (390.48-2~bpo9+3), task-desktop:amd64 (3.39), libglvnd0-nvidia:amd64 (390.48-2~bpo9+3), nvidia-driver:amd64 (390.48-2~bpo9+3), xserver-xorg-video-fbdev:amd64 (1:0.4.4-1+b5), nvidia-vulkan-common:amd64 (390.48-2~bpo9+3), xserver-xorg-input-libinput:amd64 (0.23.0-2), libgl1-nvidia-glvnd-glx:amd64 (390.48-2~bpo9+3), xserver-xorg-input-wacom:amd64 (0.34.0-1), task-xfce-desktop:amd64 (3.39), libgles1-glvnd-nvidia:amd64 (390.48-2~bpo9+3), xserver-xorg-video-intel:amd64 (2:2.99.917+git20161206-1), xserver-xorg-video-vmware:amd64 (1:13.2.1-1+b1), nvidia-driver-libs:amd64 (390.48-2~bpo9+3), xserver-xorg-video-all:amd64 (1:7.7+19), xserver-xorg-video-ati:amd64 (1:7.8.0-1+b1), xorg:amd64 (1:7.7+19), libgl1-mesa-glx:amd64 (13.0.6-1+b2), xserver-xorg-video-radeon:amd64 (1:7.8.0-1+b1), xserver-xorg-video-nvidia:amd64 (390.48-2~bpo9+3), libgl1-glvnd-nvidia-glx:amd64 (390.48-2~bpo9+3), libegl1-glvnd-nvidia:amd64 (390.48-2~bpo9+3), libgles2-glvnd-nvidia:amd64 (390.48-2~bpo9+3)
End-Date: 2018-07-14  17:35:14

Start-Date: 2018-07-14  17:40:42
Commandline: apt-get install firmware-b43-installer
Requested-By: rob (1000)
Install: b43-fwcutter:amd64 (1:019-3, automatic), firmware-b43-installer:amd64 (1:019-3)
End-Date: 2018-07-14  17:40:53

Start-Date: 2018-07-14  19:14:36
Commandline: apt-get remove xfce4
Requested-By: rob (1000)
Remove: xfce4:amd64 (4.12.3)
End-Date: 2018-07-14  19:14:38

Start-Date: 2018-07-15  19:46:21
Commandline: apt-get install xfce4
Requested-By: rob (1000)
Install: xserver-xorg-input-all:amd64 (1:7.7+19, automatic), xserver-xorg:amd64 (1:7.7+19, automatic), xserver-xorg-video-qxl:amd64 (0.1.4+20161126git4d7160c-1, automatic), xserver-xorg-video-vesa:amd64 (1:2.3.4-1+b2, automatic), xserver-xorg-video-nouveau:amd64 (1:1.0.13-3, automatic), xserver-xorg-video-amdgpu:amd64 (1.2.0-1+b1, automatic), xserver-xorg-core:amd64 (2:1.19.2-1+deb9u2, automatic), xserver-xorg-video-fbdev:amd64 (1:0.4.4-1+b5, automatic), xserver-xorg-input-libinput:amd64 (0.23.0-2, automatic), xserver-xorg-input-wacom:amd64 (0.34.0-1, automatic), xserver-xorg-video-intel:amd64 (2:2.99.917+git20161206-1, automatic), xserver-xorg-video-vmware:amd64 (1:13.2.1-1+b1, automatic), xserver-xorg-video-all:amd64 (1:7.7+19, automatic), xserver-xorg-video-ati:amd64 (1:7.8.0-1+b1, automatic), xorg:amd64 (1:7.7+19, automatic), xserver-xorg-video-radeon:amd64 (1:7.8.0-1+b1, automatic), xfce4:amd64 (4.12.3)
End-Date: 2018-07-15  19:46:38


The mess happened at the 2018-07-14 17:30:51 dist-upgrade.

Just to explain the oddity of my uninstalling and reinstalling XFCE being 24 hours apart: my desktop tower is upstairs and my wifi router-modem hub is downstairs. I wasn't sure how to connect to wifi from terminal (it wasn't doing it automatically) so I had to lug my computer downstairs at the next opportunity and it's been a busy weekend.
scary-rob
 
Posts: 16
Joined: 2018-06-22 15:57

Re: XFCE failing to load after update

Postby stevepusser » 2018-07-15 18:47

Since it's a video driver problem, any information you can provide about your video hardware and previously working driver setup would be critical. (install inxi and then run "inxi -G") It looks like from the packages you had the Nvidia proprietary driver, so what's the output when you try force rebuild it for the new kernel? It may not have done an automatic DKMS rebuild:

as sysadmin:

Code: Select all
dpkg-reconfigure nvidia-kernel-dkms
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: mvp 0.29.0, Pale Moon 28.0.0, wine-staging 3.13, qBittorrent 4.1.2, Linux kernel 4.17.14, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9802
Joined: 2009-10-06 05:53

Re: XFCE failing to load after update

Postby scary-rob » 2018-07-15 18:54

As per Head_on_a_stick's request:

What I did was

Code: Select all
sudo apt-get install XFCE4


Now that all the Xorg packages have been reinstated, I apologise that I've lost some potentially useful information. But there are still a load of orphaned packages, so I'll run that command again just to pull up what it's showing now.

Output:

Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
xfce4 is already the newest version (4.12.3).
The following packages were automatically installed and are no longer required:
  cups-pk-helper espeak-ng-data evince evince-common evince-gtk exfalso
  fonts-font-awesome gimp gimp-data gir1.2-gst-plugins-base-1.0
  gir1.2-gtksource-3.0 gir1.2-keybinder-3.0 gir1.2-packagekitglib-1.0
  gir1.2-wnck-3.0 gnome-desktop3-data gnome-orca libamd2 libatk-adaptor
  libbabl-0.1-0 libcamd2 libccolamd2 libcholmod3 libdotconf0 libegl-nvidia0
  libespeak-ng1 libgegl-0.3-0 libgimp2.0 libglapi-mesa libgles-nvidia1
  libgnome-desktop-3-12 libgtksourceview-3.0-1 libgtksourceview-3.0-common
  libjs-modernizr libjs-sphinxdoc libjs-underscore liblouis-data liblouis12
  libmetis5 libnma0 libnvidia-cfg1 libnvidia-egl-wayland1 libnvidia-eglcore
  libnvidia-ml1 libpcaudio0 libraw15 libreoffice-gtk2 libsonic0 libspeechd2
  libtidy5 libumfpack5 libvulkan1 libwmf0.2-7 libwnck-3-0 libwnck-3-common
  libxnvctrl0 mobile-broadband-provider-info network-manager-gnome
  nvidia-driver-bin nvidia-egl-common nvidia-egl-wayland-common
  nvidia-egl-wayland-icd nvidia-persistenced nvidia-settings nvidia-support
  policykit-1-gnome python-chardet python-feedparser python-libxml2
  python-musicbrainzngs python-mutagen python-pkg-resources python-pyinotify
  python-utidylib python3-brlapi python3-chardet python3-cups
  python3-cupshelpers python3-louis python3-pkg-resources python3-pyatspi
  python3-requests python3-six python3-smbc python3-speechd python3-urllib3
  python3-xdg quodlibet speech-dispatcher speech-dispatcher-audio-plugins
  speech-dispatcher-espeak-ng sphinx-rtd-theme-common system-config-printer
  system-config-printer-common system-config-printer-udev vlc vlc-bin vlc-l10n
  vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2
  vlc-plugin-video-splitter vlc-plugin-visualization xbrlapi xsane
  xsane-common
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


I'm a bit concerned that gimp, ex falso, quod libet, vlc and others are on the redundant list. Especially as that last upgrade doesn't seem to have replaced them. Just to check, I opened up GIMP. It loaded without issue.
scary-rob
 
Posts: 16
Joined: 2018-06-22 15:57

Re: XFCE failing to load after update

Postby scary-rob » 2018-07-15 19:02

To address Steve's questions:

The graphics card is a 2GB NVIDIA GeForce GTX 1050. I usually use the DVI output.

Output of inxi -G:
Code: Select all
Graphics:  Card: NVIDIA GP107 [GeForce GTX 1050]
           Display Server: X.Org 1.19.2 drivers: fbdev,nouveau (unloaded: modesetting,vesa)
           Resolution: 1024x768@76.00hz
           GLX Renderer: N/A GLX Version: N/A


Output of dpkg-reconfigure nvidia-kernel-dkms:
Code: Select all
-------- Uninstall Beginning --------
Module:  nvidia-current
Version: 390.67
Kernel:  4.9.0-6-amd64 (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

nvidia-current.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-6-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-modeset.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-6-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-drm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-6-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-uvm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-6-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod.....

DKMS: uninstall completed.

-------- Uninstall Beginning --------
Module:  nvidia-current
Version: 390.67
Kernel:  4.9.0-7-amd64 (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

nvidia-current.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-7-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-modeset.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-7-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-drm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-7-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-uvm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.9.0-7-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod.....

DKMS: uninstall completed.

------------------------------
Deleting module version: 390.67
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-current-390.67 DKMS files...
Building for 4.9.0-7-amd64
Building initial module for 4.9.0-7-amd64
Done.

nvidia-current:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-7-amd64/updates/dkms/

nvidia-current-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-7-amd64/updates/dkms/

nvidia-current-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-7-amd64/updates/dkms/

nvidia-current-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.9.0-7-amd64/updates/dkms/

depmod...

DKMS: install completed.


After a reboot, it's still running for a 1024x768 monitor. I'll have a poke as per shep's suggestion in a bit.
scary-rob
 
Posts: 16
Joined: 2018-06-22 15:57

Re: XFCE failing to load after update

Postby Head_on_a_Stick » 2018-07-15 19:12

scary-rob wrote:What I did was
Code: Select all
sudo apt-get install XFCE4

There is no package called XFCE4 so I suspect that you actually mean xfce4.

To reinstall the entire desktop run
Code: Select all
# apt install task-xfce-desktop

scary-rob wrote:
Code: Select all
The following packages were automatically installed and are no longer required:

See viewtopic.php?f=16&t=104157

I'll let Steve deal with that dirty, non-free Nvidia stuff :mrgreen:

EDIT: or you could cleanse yourself:

https://wiki.debian.org/NvidiaGraphicsD ... of_failure

What would rms do?
E Pluribus Unix
User avatar
Head_on_a_Stick
 
Posts: 7785
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: XFCE failing to load after update

Postby scary-rob » 2018-07-15 19:59

I suspect that you actually mean xfce4.


You're right. Fortunately, I only made that typo on here, not in my terminal.

you could cleanse yourself


Sadly, this graphics card doesn't seem to like Nouveau very much. It won't wake up from sleep.
scary-rob
 
Posts: 16
Joined: 2018-06-22 15:57

Re: XFCE failing to load after update

Postby scary-rob » 2018-07-15 20:26

So, going back to shep's post:

Code: Select all
sudo less /var/log/Xorg.log
[sudo] password for rob:
/var/log/Xorg.log: No such file or directory


Poking at the folder, there appears to be an Xorg.1.log and an Xorg.0.log, both of which seem to be for this session only (and, of course, I reinstated a lot of the missing stuff when I reinstalled xfce4, so they're not telling me anything about the original problem).

As regards the advice on linuxconfig.org re Nvidia drivers, I'm encountering an interesting problem:

Code: Select all
$ sudo apt install firmware-linux nvidia-driver nvidia-settings nvidia-xconfig
Reading package lists... Done
Building dependency tree       
Reading state information... Done
firmware-linux is already the newest version (20161130-3).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-driver : Depends: nvidia-driver-libs (= 384.130-1) but it is not going to be installed or
                          nvidia-driver-libs-nonglvnd (= 384.130-1) but it is not going to be installed
                 Depends: nvidia-driver-bin (= 384.130-1) but it is not going to be installed
                 Depends: xserver-xorg-video-nvidia (= 384.130-1) but it is not going to be installed
                 Depends: nvidia-vdpau-driver (= 384.130-1) but 390.67-2~bpo9+1 is to be installed
                 Depends: nvidia-alternative (= 384.130-1) but 390.67-2~bpo9+1 is to be installed
                 Depends: nvidia-kernel-dkms (= 384.130-1) but 390.67-2~bpo9+1 is to be installed or
                          nvidia-kernel-384.130
E: Unable to correct problems, you have held broken packages.


So I went back to https://wiki.debian.org/NvidiaGraphicsDrivers#Installation and took instruction from there.

Code: Select all
# apt-get install -t stretch-backports nvidia-driver


Output:
Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libegl-nvidia0 libegl1 libegl1-mesa libgl1-nvidia-glvnd-glx libgles-nvidia2 libnvidia-cfg1
  libnvidia-egl-wayland1 libnvidia-eglcore libnvidia-ml1 libopengl0 libvulkan1
  libwayland-egl1-mesa libxnvctrl0 nvidia-driver-bin nvidia-driver-libs nvidia-egl-common
  nvidia-egl-icd nvidia-egl-wayland-common nvidia-egl-wayland-icd nvidia-persistenced
  nvidia-settings nvidia-support nvidia-vulkan-common nvidia-vulkan-icd
  xserver-xorg-video-nvidia
Suggested packages:
  vulkan-utils
Recommended packages:
  nvidia-driver-libs-i386
The following NEW packages will be installed:
  libegl-nvidia0 libegl1 libgl1-nvidia-glvnd-glx libgles-nvidia2 libnvidia-cfg1
  libnvidia-egl-wayland1 libnvidia-eglcore libnvidia-ml1 libopengl0 libvulkan1 libxnvctrl0
  nvidia-driver nvidia-driver-bin nvidia-driver-libs nvidia-egl-common nvidia-egl-icd
  nvidia-egl-wayland-common nvidia-egl-wayland-icd nvidia-persistenced nvidia-settings
  nvidia-support nvidia-vulkan-common nvidia-vulkan-icd xserver-xorg-video-nvidia
The following packages will be upgraded:
  libegl1-mesa libwayland-egl1-mesa
2 upgraded, 24 newly installed, 0 to remove and 217 not upgraded.
Need to get 4,473 kB/14.6 MB of archives.
After this operation, 61.6 MB of additional disk space will be used.
Do you want to continue? [Y/n]


Having run that, I ran an update, which installed nvidia-persistenced

Also, I ran the autoremove regarding the orphan packages and metapackages. GIMP has now disappeared from the menu. What's baffling me is why that update I did two days ago removed a bunch of vital components.

EDIT: That's sorted out the display issues, at least.
scary-rob
 
Posts: 16
Joined: 2018-06-22 15:57

Re: XFCE failing to load after update

Postby scary-rob » 2018-07-15 21:09

EDITED

In the name of trying to solve the remaining problems, I decided to try reinstalling the packages deleted by the bad update and the orphaned packages I autoremoved. I did them one by one so I can see what was happening more clearly. I started with the autoremoved packages

Code: Select all
sudo apt install
for the following packages:

Autoremoved:
cups-pk-helper, espeak-ng-data, evince, evince-gtk, exfalso, gimp, gir1.2-gst-plugins-base-1.0, gir1.2-gtksource-3.0, gir1.2-keybinder-3.0, gir1.2-packagekitglib-1.0, gir1.2-wnck-3.0, gnome-orca, libglapi-mesa, libnma0, libreoffice-gtk2, libtidy5, libvulkan1, libxnvctrl0, mobile-broadband-provider-info, network-manager-gnome, python-chardet, python-feedparser, python-pyinotify, python3-chardet, python3-cups, python3-cupshelpers, python3-smbc, quodlibet, system-config-printer, vlc, xsane, xsane-common

The following packages were also originally autoremoved, and were brought back in automatically by aptitude as dependencies for other packages as I reinstalled them:
evince-common, fonts-font-awesome, gimp-data, gnome-desktop3-data, libamd2, libatk-adaptor, libbabl-0.1-0, libcamd2, libccolamd2, libcholmod3, libdotconf0, libespeak-ng1, libgegl-0.3-0, libgimp2.0 libgnome-desktop-3-12 , libgtksourceview-3.0-1, libgtksourceview-3.0-common, libjs-modernizr, libjs-sphinxdoc, libjs-underscore, liblouis-data, liblouis12, libmetis5, libpcaudio0, libraw15, libsonic0, libspeechd2, libumfpack5, libwmf0.2-7, libwnck-3-0, libwnck-3-common, policykit-1-gnome, python-libxml2, python-utidylib, python3-brlapi, python3-louis, python3-pkg-resources, python3-pyatspi, python3-requests, python3-six, python-musicbrainzngs, python-mutagen, python-pkg-resources, python3-speechd, python3-urllib3, python3-xdg, speech-dispatcher, speech-dispatcher-audio-plugins, speech-dispatcher-espeak-ng, sphinx-rtd-theme-common, system-config-printer-common, system-config-printer-udev, vlc-bin, vlc-l10n, vlc-plugin-notify, vlc-plugin-qt, vlc-plugin-samba, vlc-plugin-skins2, vlc-plugin-video-splitter, vlc-plugin-visualization, xbrlapi

I skipped these ones because they were obviously nvidia packages and I didn't want to create any conflicts with my reinstallation of the drivers earlier:
libegl-nvidia0, libgles-nvidia1, libnvidia-cfg1, libnvidia-egl-wayland1, libnvidia-eglcore, libnvidia-ml1, nvidia-driver-bin, nvidia-egl-common, nvidia-egl-wayland-common, nvidia-egl-wayland-icd, nvidia-persistenced, nvidia-settings, nvidia-support

After this, I'll run another update and see if this has fixed or helps to replicate the problem.

Edit:
Code: Select all
$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


So far, so good.
scary-rob
 
Posts: 16
Joined: 2018-06-22 15:57

Re: XFCE failing to load after update

Postby scary-rob » 2018-07-15 22:57

I've now rebooted and everything still seems okay.

Weirdly, all those packages that were deleted as orphans or having broken dependencies didn't pull in any new packages when I reinstalled them. So I'm curious as to why they got marked for autoremoval in the first place.

As for the packages that were removed by the cataclysmic dist-upgrade, I sifted through them on a text file and deleted the entries that were reinstated by reinstalling xfce4 and the nvidia drivers.

Of what is left on the list, some are nvidia packages and presumably now redundant:
libglx0-glvnd-nvidia, nvidia-egl-icd, libglvnd0-nvidia, libgles1-glvnd-nvidia, libgl1-glvnd-nvidia-glx, ibegl1-glvnd-nvidia, libgles2-glvnd-nvidia.

I tried to install libgles2-mesa from that list of removed packages and got the following result:
Code: Select all
$ sudo apt-get install libgles2-mesa
[sudo] password for rob:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libglapi-mesa
The following packages will be REMOVED:
  libgles-nvidia2 libgles2
The following NEW packages will be installed:
  libglapi-mesa libgles2-mesa
0 upgraded, 2 newly installed, 2 to remove and 0 not upgraded.
Need to get 110 kB of archives.
After this operation, 81.9 kB disk space will be freed.
Do you want to continue? [Y/n]


I elected to abort that and have also decided not to do anything about reinstating libgl1-mesa-glx because, having googled it, it seems to be some kind of drawing accelerator and GIMP doesn't require it as dependency.

That leaves two packages:
task-desktop and task-xfce-desktop.

I began to install task-desktop and the following happened:
Code: Select all
$ sudo apt-get install task-desktop
[sudo] password for rob:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libgles-nvidia2 libnvidia-cfg1 libnvidia-egl-wayland1 libopengl0
  nvidia-driver-bin nvidia-egl-wayland-common nvidia-egl-wayland-icd
  nvidia-persistenced
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  accountsservice apache2-bin apg appstream argyll argyll-ref baobab
  bogofilter bogofilter-bdb bogofilter-common brasero brasero-cdrkit
  brasero-common caribou cheese cheese-common chrome-gnome-shell colord
  colord-data cracklib-runtime dleyna-server eog evolution evolution-common
  evolution-data-server evolution-data-server-common evolution-plugins fig2dev
  file-roller five-or-more folks-common fonts-cantarell four-in-a-row freepats
  gdm3 gedit gedit-common gedit-plugins geoclue-2.0 gir1.2-accountsservice-1.0
  gir1.2-caribou-1.0 gir1.2-champlain-0.12 gir1.2-clutter-1.0
  gir1.2-clutter-gst-3.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-gck-1
  gir1.2-gcr-3 gir1.2-gdata-0.0 gir1.2-gdesktopenums-3.0 gir1.2-gdm-1.0
  gir1.2-geoclue-2.0 gir1.2-geocodeglib-1.0 gir1.2-gepub-0.4
  gir1.2-gfbgraph-0.2 gir1.2-git2-glib-1.0 gir1.2-gmenu-3.0
  gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0 gir1.2-goa-1.0
  gir1.2-grilo-0.3 gir1.2-gtkchamplain-0.12 gir1.2-gtkclutter-1.0
  gir1.2-gucharmap-2.90 gir1.2-gweather-3.0 gir1.2-json-1.0
  gir1.2-lokdocview-0.1 gir1.2-mediaart-2.0 gir1.2-mutter-3.0
  gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0 gir1.2-polkit-1.0 gir1.2-rb-3.0
  gir1.2-rest-0.7 gir1.2-secret-1 gir1.2-telepathyglib-0.12
  gir1.2-telepathylogger-0.2 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0
  gir1.2-tracker-1.0 gir1.2-upowerglib-1.0 gir1.2-vte-2.91
  gir1.2-zeitgeist-2.0 gir1.2-zpj-0.0 gjs gkbd-capplet gnome gnome-backgrounds
  gnome-bluetooth gnome-calculator gnome-calendar gnome-characters gnome-chess
  gnome-clocks gnome-color-manager gnome-contacts gnome-control-center
  gnome-control-center-data gnome-core gnome-dictionary gnome-disk-utility
  gnome-documents gnome-font-viewer gnome-games gnome-getting-started-docs
  gnome-klotski gnome-logs gnome-mahjongg gnome-maps gnome-menus gnome-mines
  gnome-music gnome-nibbles gnome-online-accounts gnome-online-miners
  gnome-robots gnome-screenshot gnome-session gnome-session-bin
  gnome-session-common gnome-settings-daemon gnome-shell gnome-shell-common
  gnome-shell-extensions gnome-software gnome-software-common
  gnome-sound-recorder gnome-sudoku gnome-sushi gnome-system-monitor
  gnome-taquin gnome-terminal gnome-terminal-data gnome-tetravex
  gnome-tweak-tool gnome-user-guide gnome-user-share gnome-video-effects
  gnome-weather grilo-plugins-0.3 gstreamer1.0-clutter-3.0
  gstreamer1.0-plugins-bad gvfs-bin gvfs-fuse hitori hoichess iagno
  iio-sensor-proxy imagemagick imagemagick-6-common imagemagick-6.q16 inkscape
  libaccountsservice0 libapache2-mod-dnssd libappstream-glib8 libappstream4
  libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
  libavahi-ui-gtk3-0 libboost-thread1.62.0 libbrasero-media3-1 libcamel-1.2-59
  libcaribou-common libcaribou-gtk-module libcaribou-gtk3-module libcaribou0
  libchamplain-0.12-0 libchamplain-gtk-0.12-0 libcheese-gtk25 libcheese8
  libclutter-1.0-0 libclutter-1.0-common libclutter-gst-3.0-0
  libclutter-gtk-1.0-0 libcogl-common libcogl-pango20 libcogl-path20 libcogl20
  libcolord-gtk1 libcolorhug2 libcrack2 libcryptui0a libcue1 libde265-0
  libdee-1.0-4 libdleyna-connector-dbus-1.0-1 libdleyna-core-1.0-3
  libdmapsharing-3.0-2 libebackend-1.2-10 libebook-1.2-16
  libebook-contacts-1.2-2 libecal-1.2-19 libedata-book-1.2-25
  libedata-cal-1.2-28 libedataserver-1.2-22 libedataserverui-1.2-1 libenca0
  libevolution libexempi3 libfluidsynth1 libfolks-eds25 libfolks-telepathy25
  libfolks25 libfwupd1 libgail-3-0 libgc1c2 libgcab-1.0-0 libgdict-1.0-10
  libgdict-common libgdm1 libgee-0.8-2 libgeoclue-2-0 libgeocode-glib0
  libgepub0 libgexiv2-2 libgfbgraph-0.2-0 libgit2-24 libgit2-glib-1.0-0
  libgjs0e libgl1-mesa-glx libgmime-2.6-0 libgnome-autoar-0-0
  libgnome-autoar-common libgnome-autoar-gtk-0-0 libgnome-bluetooth13
  libgnome-games-support-1-2 libgnome-games-support-common libgnome-menu-3-0
  libgnomekbd-common libgnomekbd8 libgoa-backend-1.0-1 libgom-1.0-0
  libgom-1.0-common libgrilo-0.3-0 libgsf-1-114 libgsf-1-common libgsf-bin
  libgsl2 libgsound0 libgspell-1-1 libgspell-1-common libgssdp-1.0-3
  libgtk-vnc-2.0-0 libgtkmm-2.4-1v5 libgtkspell0 libgtkspell3-3-0
  libgtop-2.0-10 libgtop2-common libgucharmap-2-90-7 libgupnp-1.0-4
  libgupnp-av-1.0-2 libgupnp-dlna-2.0-3 libgvnc-1.0-0 libgweather-3-6
  libgweather-common libhttp-parser2.1 libimage-magick-perl
  libimage-magick-q16-perl libiptcdata0 libjxr-tools libjxr0
  liblibreofficekitgtk liblqr-1-0 liblua5.3-0 libmagick++-6.q16-7
  libmagickcore-6.q16-3 libmagickcore-6.q16-3-extra libmagickwand-6.q16-3
  libmediaart-2.0-0 libminiupnpc10 libmjpegutils-2.1-0 libmms0 libmodplug1
  libmozjs-24-0 libmpeg2encpp-2.1-0 libmplex2-2.1-0 libmusicbrainz5-2
  libmutter0i libnatpmp1 libnetpbm10 libnm-gtk0 libosinfo-1.0-0
  libphodav-2.0-0 libphodav-2.0-common libphonenumber7 libpotrace0
  libproxy1-plugin-gsettings libproxy1-plugin-networkmanager libpst4
  libpwquality-common libpwquality1 libqqwing2v5 libquvi-0.9-0.9.3
  libquvi-scripts-0.9 libreoffice-evolution libreoffice-gnome libreoffice-gtk3
  libreofficekit-data librhythmbox-core10 librygel-core-2.6-2
  librygel-db-2.6-2 librygel-renderer-2.6-2 librygel-renderer-gst-2.6-2
  librygel-server-2.6-2 libspandsp2 libspice-client-glib-2.0-8
  libspice-client-gtk-3.0-5 libsrtp0 libstemmer0d libtelepathy-logger3
  libtotem-plparser-common libtotem-plparser18 libtotem0
  libtracker-control-1.0-0 libtracker-miner-1.0-0 libtracker-sparql-1.0-0
  libusbredirhost1 libvo-aacenc0 libvo-amrwbenc0 libwildmidi-config
  libwildmidi2 libwmf-bin libxcb-res0 libxcb-xf86dri0 libyelp0 libytnef0
  libzapojit-0.0-0 libzbar0 libzeitgeist-2.0-0 lightsoff lua-bitop lua-expat
  lua-json lua-lpeg lua-socket minissdpd mousetweaks mutter mutter-common
  nautilus nautilus-data nautilus-sendto netpbm osinfo-db polari
  python-apt-common python-bs4 python-cffi-backend python-cryptography
  python-enum34 python-html5lib python-idna python-ipaddress python-lxml
  python-openssl python-pyasn1 python-requests python-scour python-setuptools
  python-urllib3 python-webencodings python3-apt python3-mako
  python3-markupsafe python3-pycurl python3-software-properties quadrapassel
  realmd rhythmbox rhythmbox-data rhythmbox-plugin-cdrecorder
  rhythmbox-plugins rygel rygel-playbin rygel-tracker seahorse seahorse-daemon
  shotwell shotwell-common software-properties-common software-properties-gtk
  spice-client-glib-usb-acl-helper swell-foop tali task-gnome-desktop
  telepathy-idle telepathy-logger totem totem-common totem-plugins tracker
  tracker-extract tracker-gui tracker-miner-fs transfig transmission-common
  transmission-gtk unattended-upgrades unoconv vinagre vino xdg-user-dirs-gtk
  xserver-xephyr xwayland yelp yelp-xsl zeitgeist-core
Suggested packages:
  apache2-doc apache2-suexec-pristine | apache2-suexec-custom argyll-doc
  gir1.2-colordgtk-1.0 db5.3-util doc-base libdvdcss2 readom
  gnome-video-effects-frei0r firefox colord-sensor-argyll eog-plugins
  evolution-ews evolution-plugins-experimental xfig arj lha lzip lzop
  ncompress rpm2cpio rzip sharutils unace unalz unar zoo zeitgeist-datahub
  alacarte empathy goobox | sound-juicer xul-ext-ublock-origin
  xul-ext-gnome-keyring firefox-esr-l10n-all | firefox-l10n-all bbchess crafty
  fairymax fruit glaurung gnuchess phalanx sjeng stockfish toga2 gnome-hearts
  aisleriot fwupd gnome-software-plugin-flatpak gnome-software-plugin-limba
  imagemagick-doc autotrace curl enscript gnuplot grads graphviz hp2xx html2ps
  mplayer povray radiance texlive-base-bin ufraw-batch dia | dia-gnome
  libsvg-perl libxml-xql-perl pstoedit python-uniconvertor gsl-ref-psdoc
  | gsl-doc-pdf | gsl-doc-info | gsl-ref-html natpmp-utils libosinfo-l10n
  srtp-utils python-cryptography-doc python-cryptography-vectors
  python-enum34-doc python-genshi python-lxml-dbg python-lxml-doc
  python-openssl-doc python-openssl-dbg python-socks python-rsvg
  python-setuptools-doc python-ntlm python3-apt-dbg python-apt-doc
  python3-beaker python-mako-doc libcurl4-gnutls-dev python-pycurl-doc
  python3-pycurl-dbg gnome-codec-install rygel-preferences rygel-ruih gromit
  bsd-mailx mail-transport-agent needrestart
The following packages will be REMOVED:
  libgl1 libgl1-nvidia-glvnd-glx libglx-nvidia0 libglx0 nvidia-driver
  nvidia-driver-libs nvidia-vulkan-common nvidia-vulkan-icd
The following NEW packages will be installed:
  accountsservice apache2-bin apg appstream argyll argyll-ref baobab
  bogofilter bogofilter-bdb bogofilter-common brasero brasero-cdrkit
  brasero-common caribou cheese cheese-common chrome-gnome-shell colord
  colord-data cracklib-runtime dleyna-server eog evolution evolution-common
  evolution-data-server evolution-data-server-common evolution-plugins fig2dev
  file-roller five-or-more folks-common fonts-cantarell four-in-a-row freepats
  gdm3 gedit gedit-common gedit-plugins geoclue-2.0 gir1.2-accountsservice-1.0
  gir1.2-caribou-1.0 gir1.2-champlain-0.12 gir1.2-clutter-1.0
  gir1.2-clutter-gst-3.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-gck-1
  gir1.2-gcr-3 gir1.2-gdata-0.0 gir1.2-gdesktopenums-3.0 gir1.2-gdm-1.0
  gir1.2-geoclue-2.0 gir1.2-geocodeglib-1.0 gir1.2-gepub-0.4
  gir1.2-gfbgraph-0.2 gir1.2-git2-glib-1.0 gir1.2-gmenu-3.0
  gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0 gir1.2-goa-1.0
  gir1.2-grilo-0.3 gir1.2-gtkchamplain-0.12 gir1.2-gtkclutter-1.0
  gir1.2-gucharmap-2.90 gir1.2-gweather-3.0 gir1.2-json-1.0
  gir1.2-lokdocview-0.1 gir1.2-mediaart-2.0 gir1.2-mutter-3.0
  gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0 gir1.2-polkit-1.0 gir1.2-rb-3.0
  gir1.2-rest-0.7 gir1.2-secret-1 gir1.2-telepathyglib-0.12
  gir1.2-telepathylogger-0.2 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0
  gir1.2-tracker-1.0 gir1.2-upowerglib-1.0 gir1.2-vte-2.91
  gir1.2-zeitgeist-2.0 gir1.2-zpj-0.0 gjs gkbd-capplet gnome gnome-backgrounds
  gnome-bluetooth gnome-calculator gnome-calendar gnome-characters gnome-chess
  gnome-clocks gnome-color-manager gnome-contacts gnome-control-center
  gnome-control-center-data gnome-core gnome-dictionary gnome-disk-utility
  gnome-documents gnome-font-viewer gnome-games gnome-getting-started-docs
  gnome-klotski gnome-logs gnome-mahjongg gnome-maps gnome-menus gnome-mines
  gnome-music gnome-nibbles gnome-online-accounts gnome-online-miners
  gnome-robots gnome-screenshot gnome-session gnome-session-bin
  gnome-session-common gnome-settings-daemon gnome-shell gnome-shell-common
  gnome-shell-extensions gnome-software gnome-software-common
  gnome-sound-recorder gnome-sudoku gnome-sushi gnome-system-monitor
  gnome-taquin gnome-terminal gnome-terminal-data gnome-tetravex
  gnome-tweak-tool gnome-user-guide gnome-user-share gnome-video-effects
  gnome-weather grilo-plugins-0.3 gstreamer1.0-clutter-3.0
  gstreamer1.0-plugins-bad gvfs-bin gvfs-fuse hitori hoichess iagno
  iio-sensor-proxy imagemagick imagemagick-6-common imagemagick-6.q16 inkscape
  libaccountsservice0 libapache2-mod-dnssd libappstream-glib8 libappstream4
  libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
  libavahi-ui-gtk3-0 libboost-thread1.62.0 libbrasero-media3-1 libcamel-1.2-59
  libcaribou-common libcaribou-gtk-module libcaribou-gtk3-module libcaribou0
  libchamplain-0.12-0 libchamplain-gtk-0.12-0 libcheese-gtk25 libcheese8
  libclutter-1.0-0 libclutter-1.0-common libclutter-gst-3.0-0
  libclutter-gtk-1.0-0 libcogl-common libcogl-pango20 libcogl-path20 libcogl20
  libcolord-gtk1 libcolorhug2 libcrack2 libcryptui0a libcue1 libde265-0
  libdee-1.0-4 libdleyna-connector-dbus-1.0-1 libdleyna-core-1.0-3
  libdmapsharing-3.0-2 libebackend-1.2-10 libebook-1.2-16
  libebook-contacts-1.2-2 libecal-1.2-19 libedata-book-1.2-25
  libedata-cal-1.2-28 libedataserver-1.2-22 libedataserverui-1.2-1 libenca0
  libevolution libexempi3 libfluidsynth1 libfolks-eds25 libfolks-telepathy25
  libfolks25 libfwupd1 libgail-3-0 libgc1c2 libgcab-1.0-0 libgdict-1.0-10
  libgdict-common libgdm1 libgee-0.8-2 libgeoclue-2-0 libgeocode-glib0
  libgepub0 libgexiv2-2 libgfbgraph-0.2-0 libgit2-24 libgit2-glib-1.0-0
  libgjs0e libgl1-mesa-glx libgmime-2.6-0 libgnome-autoar-0-0
  libgnome-autoar-common libgnome-autoar-gtk-0-0 libgnome-bluetooth13
  libgnome-games-support-1-2 libgnome-games-support-common libgnome-menu-3-0
  libgnomekbd-common libgnomekbd8 libgoa-backend-1.0-1 libgom-1.0-0
  libgom-1.0-common libgrilo-0.3-0 libgsf-1-114 libgsf-1-common libgsf-bin
  libgsl2 libgsound0 libgspell-1-1 libgspell-1-common libgssdp-1.0-3
  libgtk-vnc-2.0-0 libgtkmm-2.4-1v5 libgtkspell0 libgtkspell3-3-0
  libgtop-2.0-10 libgtop2-common libgucharmap-2-90-7 libgupnp-1.0-4
  libgupnp-av-1.0-2 libgupnp-dlna-2.0-3 libgvnc-1.0-0 libgweather-3-6
  libgweather-common libhttp-parser2.1 libimage-magick-perl
  libimage-magick-q16-perl libiptcdata0 libjxr-tools libjxr0
  liblibreofficekitgtk liblqr-1-0 liblua5.3-0 libmagick++-6.q16-7
  libmagickcore-6.q16-3 libmagickcore-6.q16-3-extra libmagickwand-6.q16-3
  libmediaart-2.0-0 libminiupnpc10 libmjpegutils-2.1-0 libmms0 libmodplug1
  libmozjs-24-0 libmpeg2encpp-2.1-0 libmplex2-2.1-0 libmusicbrainz5-2
  libmutter0i libnatpmp1 libnetpbm10 libnm-gtk0 libosinfo-1.0-0
  libphodav-2.0-0 libphodav-2.0-common libphonenumber7 libpotrace0
  libproxy1-plugin-gsettings libproxy1-plugin-networkmanager libpst4
  libpwquality-common libpwquality1 libqqwing2v5 libquvi-0.9-0.9.3
  libquvi-scripts-0.9 libreoffice-evolution libreoffice-gnome libreoffice-gtk3
  libreofficekit-data librhythmbox-core10 librygel-core-2.6-2
  librygel-db-2.6-2 librygel-renderer-2.6-2 librygel-renderer-gst-2.6-2
  librygel-server-2.6-2 libspandsp2 libspice-client-glib-2.0-8
  libspice-client-gtk-3.0-5 libsrtp0 libstemmer0d libtelepathy-logger3
  libtotem-plparser-common libtotem-plparser18 libtotem0
  libtracker-control-1.0-0 libtracker-miner-1.0-0 libtracker-sparql-1.0-0
  libusbredirhost1 libvo-aacenc0 libvo-amrwbenc0 libwildmidi-config
  libwildmidi2 libwmf-bin libxcb-res0 libxcb-xf86dri0 libyelp0 libytnef0
  libzapojit-0.0-0 libzbar0 libzeitgeist-2.0-0 lightsoff lua-bitop lua-expat
  lua-json lua-lpeg lua-socket minissdpd mousetweaks mutter mutter-common
  nautilus nautilus-data nautilus-sendto netpbm osinfo-db polari
  python-apt-common python-bs4 python-cffi-backend python-cryptography
  python-enum34 python-html5lib python-idna python-ipaddress python-lxml
  python-openssl python-pyasn1 python-requests python-scour python-setuptools
  python-urllib3 python-webencodings python3-apt python3-mako
  python3-markupsafe python3-pycurl python3-software-properties quadrapassel
  realmd rhythmbox rhythmbox-data rhythmbox-plugin-cdrecorder
  rhythmbox-plugins rygel rygel-playbin rygel-tracker seahorse seahorse-daemon
  shotwell shotwell-common software-properties-common software-properties-gtk
  spice-client-glib-usb-acl-helper swell-foop tali task-desktop
  task-gnome-desktop telepathy-idle telepathy-logger totem totem-common
  totem-plugins tracker tracker-extract tracker-gui tracker-miner-fs transfig
  transmission-common transmission-gtk unattended-upgrades unoconv vinagre
  vino xdg-user-dirs-gtk xserver-xephyr xwayland yelp yelp-xsl zeitgeist-core
0 upgraded, 410 newly installed, 8 to remove and 0 not upgraded.
Need to get 367 MB of archives.
After this operation, 1,128 MB of additional disk space will be used.
Do you want to continue? [Y/n]


I don't know why it wants to install 410 packages if they weren't installed before the mess was made.

As for task-xfce-desktop:

Code: Select all
sudo apt-get install task-xfce-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  quodlibet task-desktop
Suggested packages:
  gstreamer1.0-plugins-bad
Recommended packages:
  xfce4-mixer
The following NEW packages will be installed:
  quodlibet task-desktop task-xfce-desktop
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 58.1 kB of archives.
After this operation, 119 kB of additional disk space will be used.
Do you want to continue? [Y/n]


I let that one run.

In conclusion: thanks, guys! My system seems to be working again. I'm still not sure what broke it in the first place, but reinstating a bunch of stuff hasn't brought the problem back.

Should I mark this as Solved? Or should it be kept open due to the mystery of what caused the original problem?
scary-rob
 
Posts: 16
Joined: 2018-06-22 15:57

Re: XFCE failing to load after update

Postby Head_on_a_Stick » 2018-07-16 04:59

scary-rob wrote:I'm still not sure what broke it in the first place

I already told you that by way of a link, here it is again:

viewtopic.php?f=16&t=104157

You have experienced the so-called "metapackage problem" and the above guide explains it in great detail ;)
E Pluribus Unix
User avatar
Head_on_a_Stick
 
Posts: 7785
Joined: 2014-06-01 17:46
Location: /dev/chair

Next

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable