Xorg Server not starting after upgrade into stretch

Everything about X, Gnome, KDE, ... and everything running on it

Xorg Server not starting after upgrade into stretch

Postby foranastes » 2018-08-04 07:10

My Xorg Server not starting after upgrade into stretch. Here is my xorg log file.
[ 12201.977]
X.Org X Server 1.19.2
Release Date: 2017-03-02
[ 12201.978] X Protocol Version 11, Revision 0
[ 12201.978] Build Operating System: Linux 4.9.0-4-amd64 x86_64 Debian
[ 12201.978] Current Operating System: Linux irtc-server 4.17.0-0.bpo.1-amd64 #1 SMP Debian 4.17.8-1~bpo9+1 (2018-07-23) x86_64
[ 12201.978] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.17.0-0.bpo.1-amd64 root=UUID=394984f5-172b-4900-abee-5e0a1b02334b ro initrd=/install/initrd.gz quiet
[ 12201.978] Build Date: 16 October 2017 08:19:45AM
[ 12201.978] xorg-server 2:1.19.2-1+deb9u2 (https://www.debian.org/support)
[ 12201.979] Current version of pixman: 0.34.0
[ 12201.979] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 12201.979] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 12201.980] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Aug 4 12:57:56 2018
[ 12201.981] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 12201.981] (==) No Layout section. Using the first Screen section.
[ 12201.981] (==) No screen section available. Using defaults.
[ 12201.981] (**) |-->Screen "Default Screen Section" (0)
[ 12201.981] (**) | |-->Monitor "<default monitor>"
[ 12201.981] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 12201.981] (==) Automatically adding devices
[ 12201.981] (==) Automatically enabling devices
[ 12201.981] (==) Automatically adding GPU devices
[ 12201.981] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 12201.981] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 12201.981] Entry deleted from font path.
[ 12201.981] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[ 12201.981] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 12201.981] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 12201.981] (II) Loader magic: 0x5638a17c5e00
[ 12201.981] (II) Module ABI versions:
[ 12201.981] X.Org ANSI C Emulation: 0.4
[ 12201.981] X.Org Video Driver: 23.0
[ 12201.981] X.Org XInput driver : 24.1
[ 12201.981] X.Org Server Extension : 10.0
[ 12201.983] (++) using VT number 1

[ 12201.988] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_37
[ 12201.990] (--) PCI:*(0:5:3:0) 126f:0712:126f:0712 rev 176, Mem @ 0xb0000000/16777216, BIOS @ 0x????????/131072
[ 12201.990] (II) LoadModule: "glx"
[ 12201.990] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 12201.991] (II) Module glx: vendor="X.Org Foundation"
[ 12201.991] compiled for 1.19.2, module version = 1.0.0
[ 12201.991] ABI class: X.Org Server Extension, version 10.0
[ 12201.991] (==) Matched siliconmotion as autoconfigured driver 0
[ 12201.991] (==) Matched modesetting as autoconfigured driver 1
[ 12201.991] (==) Matched fbdev as autoconfigured driver 2
[ 12201.991] (==) Matched vesa as autoconfigured driver 3
[ 12201.991] (==) Assigned the driver to the xf86ConfigLayout
[ 12201.991] (II) LoadModule: "siliconmotion"
[ 12201.991] (II) Loading /usr/lib/xorg/modules/drivers/siliconmotion_drv.so
[ 12201.991] (II) Module siliconmotion: vendor="X.Org Foundation"
[ 12201.991] compiled for 1.19.2, module version = 1.7.9
[ 12201.991] Module class: X.Org Video Driver
[ 12201.992] ABI class: X.Org Video Driver, version 23.0
[ 12201.992] (II) LoadModule: "modesetting"
[ 12201.992] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 12201.992] (II) Module modesetting: vendor="X.Org Foundation"
[ 12201.992] compiled for 1.19.2, module version = 1.19.2
[ 12201.992] Module class: X.Org Video Driver
[ 12201.992] ABI class: X.Org Video Driver, version 23.0
[ 12201.992] (II) LoadModule: "fbdev"
[ 12201.992] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 12201.992] (II) Module fbdev: vendor="X.Org Foundation"
[ 12201.992] compiled for 1.19.0, module version = 0.4.4
[ 12201.992] Module class: X.Org Video Driver
[ 12201.992] ABI class: X.Org Video Driver, version 23.0
[ 12201.992] (II) LoadModule: "vesa"
[ 12201.992] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 12201.992] (II) Module vesa: vendor="X.Org Foundation"
[ 12201.992] compiled for 1.19.0, module version = 2.3.4
[ 12201.992] Module class: X.Org Video Driver
[ 12201.992] ABI class: X.Org Video Driver, version 23.0
[ 12201.992] (II) SMI: driver (version 1.7.9) for Silicon Motion Lynx chipsets: Lynx,
LynxE, Lynx3D, LynxEM, LynxEM+, Lynx3DM, Cougar3DR, MSOC
[ 12201.993] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 12201.993] (II) FBDEV: driver for framebuffer: fbdev
[ 12201.993] (II) VESA: driver for VESA chipsets: vesa
[ 12201.993] (WW) Falling back to old probe method for siliconmotion
[ 12201.993] (--) Assigning device section with no busID to primary device
[ 12201.993] (--) Chipset LynxEM+ found
[ 12201.993] (WW) Falling back to old probe method for modesetting
[ 12201.993] (EE) open /dev/dri/card0: No such file or directory
[ 12201.993] (WW) Falling back to old probe method for fbdev
[ 12201.993] (II) Loading sub module "fbdevhw"
[ 12201.993] (II) LoadModule: "fbdevhw"
[ 12201.993] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 12201.993] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 12201.993] compiled for 1.19.2, module version = 0.0.2
[ 12201.993] ABI class: X.Org Video Driver, version 23.0
[ 12201.993] (EE) open /dev/fb0: No such file or directory
[ 12201.993] (WW) Falling back to old probe method for vesa
[ 12201.993] (II) Loading sub module "vgahw"
[ 12201.993] (II) LoadModule: "vgahw"
[ 12201.993] (II) Loading /usr/lib/xorg/modules/libvgahw.so
[ 12201.994] (II) Module vgahw: vendor="X.Org Foundation"
[ 12201.994] compiled for 1.19.2, module version = 0.1.0
[ 12201.994] ABI class: X.Org Video Driver, version 23.0
[ 12201.994] (II) SMI(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 12201.994] (==) SMI(0): Depth 24, (--) framebuffer bpp 32
[ 12201.994] (==) SMI(0): RGB weight 888
[ 12201.994] (==) SMI(0): Default visual is TrueColor
[ 12201.994] (==) SMI(0): PCI Burst enabled
[ 12201.994] (==) SMI(0): PCI Retry enabled
[ 12201.994] (==) SMI(0): Using Hardware Cursor
[ 12201.994] (II) Loading sub module "int10"
[ 12201.994] (II) LoadModule: "int10"
[ 12201.994] (II) Loading /usr/lib/xorg/modules/libint10.so
[ 12201.995] (II) Module int10: vendor="X.Org Foundation"
[ 12201.995] compiled for 1.19.2, module version = 1.0.0
[ 12201.995] ABI class: X.Org Video Driver, version 23.0
[ 12201.997] (II) SMI(0): Primary V_BIOS segment is: 0xc000
[ 12201.997] (II) Loading sub module "vbe"
[ 12201.997] (II) LoadModule: "vbe"
[ 12201.997] (II) Loading /usr/lib/xorg/modules/libvbe.so
[ 12201.997] (II) Module vbe: vendor="X.Org Foundation"
[ 12201.997] compiled for 1.19.2, module version = 1.1.0
[ 12201.997] ABI class: X.Org Video Driver, version 23.0
[ 12201.997] (II) SMI(0): VESA BIOS detected
[ 12201.997] (II) SMI(0): VESA VBE Version 2.0
[ 12201.997] (II) SMI(0): VESA VBE Total Mem: 4096 kB
[ 12201.997] (II) SMI(0): VESA VBE OEM: Silicon Motion SM712 VGA BIOS
[ 12201.997] (II) SMI(0): VESA VBE OEM Software Rev: 2.0
[ 12201.997] (II) SMI(0): VESA VBE OEM Vendor: SM712
[ 12201.997] (II) SMI(0): VESA VBE OEM Product: SM712
[ 12201.997] (II) SMI(0): VESA VBE OEM Product Rev: SM712
[ 12201.997] (--) SMI(0): Chipset: "LynxEM+"
[ 12201.997] (==) SMI(0): Dual head disabled
[ 12201.998] (==) SMI(0): Using XAA acceleration architecture
[ 12201.998] (--) SMI(0): videoram: 4096kB
[ 12202.000] (II) SMI(0): Cursor Offset: 003FFC00
[ 12202.000] (II) SMI(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0
[ 12202.001] (II) SMI(0): Reserved: 003FF800
[ 12202.001] (II) SMI(0): OFF Panel Size = 800x600
[ 12202.001] (II) Loading sub module "i2c"
[ 12202.001] (II) LoadModule: "i2c"
[ 12202.001] (II) Module "i2c" already built-in
[ 12202.001] (II) SMI(0): I2C bus "I2C bus" initialized.
[ 12202.001] (II) Loading sub module "ddc"
[ 12202.001] (II) LoadModule: "ddc"
[ 12202.001] (II) Module "ddc" already built-in
[ 12202.001] (==) SMI(0): Using gamma correction (1.0, 1.0, 1.0)
[ 12202.001] (II) SMI(0): MCLK = 157.000
[ 12202.001] (II) SMI(0): Output LVDS has no monitor section
[ 12202.001] (II) SMI(0): Printing probed modes for output LVDS
[ 12202.001] (II) SMI(0): Modeline "800x600"x59.9 38.25 800 832 912 1024 600 603 607 624 -hsync +vsync (37.4 kHz)
[ 12202.001] (II) SMI(0): Output LVDS connected
[ 12202.001] (II) SMI(0): Using exact sizes for initial modes
[ 12202.001] (II) SMI(0): Output LVDS using initial mode 800x600 +0+0
[ 12202.004] (==) SMI(0): DPI set to (96, 96)
[ 12202.004] (II) Loading sub module "fb"
[ 12202.004] (II) LoadModule: "fb"
[ 12202.004] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 12202.004] (II) Module fb: vendor="X.Org Foundation"
[ 12202.004] compiled for 1.19.2, module version = 1.0.0
[ 12202.004] ABI class: X.Org ANSI C Emulation, version 0.4
[ 12202.004] (II) Loading sub module "xaa"
[ 12202.004] (II) LoadModule: "xaa"
[ 12202.004] (WW) Warning, couldn't open module xaa
[ 12202.004] (II) UnloadModule: "xaa"
[ 12202.004] (II) Unloading xaa
[ 12202.004] (EE) SMI: Failed to load module "xaa" (module does not exist, 0)
[ 12202.004] (WW) SMI(0): No acceleration
[ 12202.004] (II) Loading sub module "ramdac"
[ 12202.004] (II) LoadModule: "ramdac"
[ 12202.004] (II) Module "ramdac" already built-in
[ 12202.004] (II) UnloadModule: "modesetting"
[ 12202.004] (II) Unloading modesetting
[ 12202.004] (II) UnloadModule: "fbdev"
[ 12202.004] (II) Unloading fbdev
[ 12202.004] (II) UnloadSubModule: "fbdevhw"
[ 12202.004] (II) Unloading fbdevhw
[ 12202.004] (II) UnloadModule: "vesa"
[ 12202.004] (II) Unloading vesa
[ 12202.004] (--) Depth 24 pixmap format is 32 bpp
[ 12202.004] (EE)
[ 12202.005] (EE) Backtrace:
[ 12202.005] (EE) 0: /usr/lib/xorg/Xorg (xorg_backtrace+0x4a) [0x5638a153865a]
[ 12202.005] (EE) 1: /usr/lib/xorg/Xorg (0x5638a137f000+0x1bd3e9) [0x5638a153c3e9]
[ 12202.005] (EE) 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7fc1657dd000+0x110c0) [0x7fc1657ee0c0]
[ 12202.005] (EE) 3: /usr/lib/xorg/modules/drivers/siliconmotion_drv.so (0x7fc161560000+0x76b9) [0x7fc1615676b9]
[ 12202.005] (EE) 4: /usr/lib/xorg/modules/drivers/siliconmotion_drv.so (0x7fc161560000+0x7f25) [0x7fc161567f25]
[ 12202.005] (EE) 5: /usr/lib/xorg/modules/drivers/siliconmotion_drv.so (0x7fc161560000+0xa196) [0x7fc16156a196]
[ 12202.005] (EE) 6: /usr/lib/xorg/Xorg (AddScreen+0xd7) [0x5638a13d3937]
[ 12202.005] (EE) 7: /usr/lib/xorg/Xorg (InitOutput+0x3e8) [0x5638a14192a8]
[ 12202.005] (EE) 8: /usr/lib/xorg/Xorg (0x5638a137f000+0x58496) [0x5638a13d7496]
[ 12202.005] (EE) 9: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf1) [0x7fc16545e2e1]
[ 12202.005] (EE) 10: /usr/lib/xorg/Xorg (_start+0x2a) [0x5638a13c133a]
[ 12202.005] (EE)
[ 12202.005] (EE) Segmentation fault at address 0x7fc1605163c4
[ 12202.005] (EE)
Fatal server error:
[ 12202.005] (EE) Caught signal 11 (Segmentation fault). Server aborting
[ 12202.005] (EE)
[ 12202.005] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 12202.005] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 12202.005] (EE)
[ 12202.007] (EE) Server terminated with error (1). Closing log file.
foranastes
 
Posts: 1
Joined: 2018-08-04 06:59

Re: Xorg Server not starting after upgrade into stretch

Postby Head_on_a_Stick » 2018-08-04 13:06

You seem to be running a new kernel, do you have this problem with the stock stretch version?

Did you follow the extensive guide provided in the official Debian stretch release notes when upgrading?
User avatar
Head_on_a_Stick
 
Posts: 7998
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 1 guest

fashionable