[SOLVED]Desktop stubborn to load after update from backports

Everything about X, Gnome, KDE, ... and everything running on it

[SOLVED]Desktop stubborn to load after update from backports

Postby KBD47 » 2018-08-08 23:51

I got a bit greedy and updated my MATE desktop and the kernel from Debian Stretch Backports. Everything works all the way up to logging in and the start of the desktop loading, but it just doesn't load the desktop. I can trigger it to load if I push my power button as if waking from sleep, then everything is fine. But some sort of glitch keeping the desktop from loading properly.
Yeah I broke my own rule of 'it it ain't broke don't fix it'. I had no issue in the past using backports so I thought it would be OK.
Thinking it might just be a MATE problem I installed Xfce and logged into it, rebooted and same issue, it hangs before loading the desktop.
I welcome any help or ideas to fix this.
Edit: Never mind, I fixed it. I booted into the older 4.9 kernel and removed the newer 4.17 kernel which caused the issue. I'll leave this here in case someone else has this issue.

Code: Select all
System:    Host: debian Kernel: 4.17.0-0.bpo.1-amd64 x86_64 (64 bit gcc: 6.3.0)
           Desktop: MATE 1.20.3 (Gtk 3.22.11-1)
           Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: laptop System: LENOVO product: 4291ZDF v: ThinkPad X220
           Mobo: LENOVO model: 4291ZDF
           UEFI [Legacy]: LENOVO v: 8DET61WW (1.31 ) date: 04/25/2012
Battery    BAT0: charge: 33.8 Wh 99.9% condition: 33.8/62.2 Wh (54%)
           model: SANYO 42T4861 status: N/A
           hidpp__0: charge: N/A condition: NA/NA Wh
           model: Logitech Wireless Mouse M325 status: Discharging
CPU:       Dual core Intel Core i5-2520M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9968
           clock speeds: max: 3200 MHz 1: 844 MHz 2: 804 MHz 3: 798 MHz
           4: 801 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.19.2 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile
           GLX Version: 3.0 Mesa 13.0.6 Direct Rendering: Yes
Audio:     Card Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.17.0-0.bpo.1-amd64
Network:   Card-1: Intel 82579LM Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: 5080 bus-ID: 00:19.0
           IF: enp0s25 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak]
           driver: iwlwifi bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 320.1GB (19.1% used)
           ID-1: /dev/sda model: ST320LT007 size: 320.1GB
Partition: ID-1: / size: 287G used: 52G (19%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 6.32GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 43.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 1952
Info:      Processes: 164 Uptime: 9 min Memory: 971.1/5846.8MB
           Init: systemd runlevel: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.121) inxi: 2.3.5
KBD47
 
Posts: 61
Joined: 2011-09-04 09:07

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable