Missing Gnome functionality

Everything about X, Gnome, KDE, ... and everything running on it

Missing Gnome functionality

Postby HankB » 2018-08-17 13:05

I've found some capabilities missing from Gnome in Testing that I use heavily when sorting through photos. (My technique is the photographic equivalent of "spray and pray". ;) )

On my new laptop I'm running Testing because I could not get Killer WiFi working with Stretch. I'm using Wayland because my laptop has a QHD display and I sometimes use an external 1600x1200 monitor. Wayland lets me scale each display appropriately.

The first thing I missed is the ability in `eog` to advance to the next picture using the space bar. I frequently zoom to 1:1 to check focus and sharpness and then advance to the next picture. I can do this with one hand ('1' key and space bar) on my systems running Stretch but the space bar does nothing on Testing. It takes two hands for my work flow and takes my right hand away from my mouse. I searched the documentation for some way to remap keys for `eog` but did not find anything. (I did find documentation that indicated that the space bar still advances to the next image.)

The reason I want to keep my right hand on the mouse is that when I get to a picture I like, I copy it by dragging directly from `eog` to a `nautilus` window. That no longer works. The image 'drags' but when I try to drop, it springs back to the `eog` window. I'm using ZFS on this host. Does that make a difference?

Is there any way to restore the missing behaviors? I guess I should ask if there is an easy way to restore these behaviors. These are open source so I could always modify the code to do what I want, but I just prefer that it work without that kind of effort.

Thanks!
HankB
 
Posts: 46
Joined: 2012-03-07 15:15

Re: Missing Gnome functionality

Postby cds60601 » 2018-08-17 15:22

I am afraid I wont be much help and can only present possible considerations based on my own experiences in a situation much like yours.

There are a few ways you can look at this;

1. Remember, its "Testing" and therefore you can expect things to break from time to time (trust me, I understand your pain as I too
run Buster simply for the need to have KiCad at version 5) and in time, may end up getting corrected with an update.

2. It may simply be a Gnome issue (and not necessarily a Debian one) and therefore might be better to investigate your anomalies with the folks that develop Gnome.

3. If your WiFi works in Testing, have you tried the non-free firmware ISO for Stable? That has always worked for me when I ran Stable. It now becomes a natural
selection for me to just grab the non-free ISO from either Stable or Testing.

4. Debian (Stable) IS the perfect OS for stability however, if you require newer apps and features (with other distros, you MIGHT be offsetting stability for newer apps and that MIGHT be a risk not worth taking for some), Stable may not be the best option. Yes - there are Backports but that too may be a temporary fix to a long term issue. And not all apps you may need might not be in Backports.

5. If you still find no remedies w/Debian - there ARE other distros that might be a better fit for your needs. As in my case, there is a need to have a few apps
that I must keep up on to allow for the features I require to use. As much as I don't like the possibility of moving away from Debian, it is an option that I must entertain
as it may be something you may need to consider also.

As mentioned at the top of the post, this is by no means intended as a slam to you. Just offering some other possible avenues to consider based on my own experiences :)

Good luck to you in your quest
Chris
Yeah, 220, 221. Whatever it takes.
Server: Debian 9 (Stretch) Workstation: Archlinux
User avatar
cds60601
 
Posts: 136
Joined: 2017-11-25 05:58

Re: Missing Gnome functionality

Postby HankB » 2018-08-17 18:04

Hi Chris,
Thank you for the thoughtful reply. To respond.

1) Testing... Understood. Perhaps this is a bug and not intended behavior.

2) I searched for ways to reach out to the Gnome community. The information I found seemed to indicate that I should reach out to a community that ordinarily supports my distro. Considering 1) perhaps I should file bug reports and someone will indicate that these are bugs or features. I thought I'd try to ask before I do that.

3) First thing I do when installing Debian is to enable contrib and non-free. I appreciate that these are not enabled by default for those who prefer things that way. I also did some searching and tried some fixes I found with some improvement but not including full operation. I'm not convinced it is working fully at this point but that is a subject for the Dell forum as Ubuntu is supported on this H/W.

4) I'm running Stretch on a couple other PCs (My main desktop, my previous laptop and my local file server. Raspbian Stretch on a small pile of Raspberry Pis.) I have found some quirks but for the most part it is highly stable. Snaps and Docker provide the capability of running more modern applications on a stodgy OS (for some applications, anyway.)

5) Blasphemy! :shock: Just kidding. I'm a regular distro hopper. Most of my PCs have three system partitions that I can use to try out other distros. IIRC I started with Slackware decades ago and at some point moved to Debian. I don't recall why any more. I ran Ubuntu for a while until they started fooling with the shell (Unity.) I've taken a couple stabs at Ubuntu 17.10/18.04 and was one of those who had their BIOS clobbered (and later fixed.) I ran Mint for a while but didn't care for the update policy (and under the skin, it started to become a bit dated.) One wrinkle with this machine is that I'm running on a ZFS root and I'm not sure if I can configure that for multiple distros. (Note to self: Make image copy of the SSD before I try anything that exciting!) One of my podcast hosts (JB) is a huge fan of KDE Plasma and I've tried that a couple times and find it hard to come up to speed. I've even tried Fedora and Manjaro and decided that I like the Debian packaging system.

best,
hank
HankB
 
Posts: 46
Joined: 2012-03-07 15:15

Re: Missing Gnome functionality

Postby Bloom » 2018-08-17 19:02

You can install EOM, that is the MATE version of EOG. It will have the functionality that you desire.
User avatar
Bloom
 
Posts: 71
Joined: 2017-11-11 12:23

Re: Missing Gnome functionality

Postby HankB » 2018-08-17 19:21

Thanks. I opened the S/W store and saw that. I'll give it a try.
HankB
 
Posts: 46
Joined: 2012-03-07 15:15


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable