Missing Plasma system tray

Everything about X, Gnome, KDE, ... and everything running on it

Missing Plasma system tray

Postby Serenity » 2018-08-29 17:28

I just rebooted after installing a new version of KDE Plasma today, and my system tray seems to have gone missing. I can open the "Add Widgets..." tool, select the System Tray and drag it to where I want... but it never appears. It seems anything else will appear like a useless Analogue Clock that I can put where my system tray used to be, but the system tray (which I use every single day and is essential to making use of this computer) seemingly isn't an option no matter why I try to put it.

If I seem a little irritable about this, then it's because I am. After updating to Plasma 5 I've never got it working fully. Activities have never worked and desktop effects only ever partially, but this has really got to to me. As I stated, activities and desktop effects are something I'd like to have, but the system tray is something I <i>need</i> and now that's broken too! It feels like this damn thing is falling apart at the seams. I have no idea what's even happening.
Posts: 73
Joined: 2009-10-13 13:18

Re: Missing Plasma system tray

Postby bw123 » 2018-08-29 17:46

I haven't tried any newer versions than stretch, and it is working very well for a couple yrs now. Desktop effects and acitivities both work fine. If you are using testing, or some other foreign repo then I would probably check the mailing list https://lists.debian.org/debian-kde/ and bug reports, or documentation from wherever the new ver came from.

I recall there was a warning a couple weeks ago on the list that they were going to start some transition or other.

Code: Select all
$ apt policy plasma-desktop
  Installed: 4:5.8.6-1
  Candidate: 4:5.8.6-1
  Version table:
 *** 4:5.8.6-1 500
        500 http://http.us.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
User avatar
Posts: 3787
Joined: 2011-05-09 06:02

Re: Missing Plasma system tray

Postby Serenity » 2018-08-29 18:03

Forgot to mention that, yes I am on testing. Also I do have the deb-multimedia repository enabled but I doubt that's causing this. I should also note that while the activities and desktop effects problems are annoying, they're not new, and everything else seems to work fine. It's just that for some reason Plasma won't let me put a system tray anywhere on the desktop or panels. When I grab the system tray from the widgets menu and hover over stuff, other things shift around as if they're making room for it, but when I release the mouse button nothing happens.

Edit: ARGH! I hate everything.
Posts: 73
Joined: 2009-10-13 13:18

Re: Missing Plasma system tray

Postby sunrat » 2018-08-29 22:24

Serenity wrote:Edit: ARGH! I hate everything.

Another sad case where unstable is more stable than testing. Frameworks 5.49 is complete and working fine on my sid system.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
Posts: 2754
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 15 guests