Not able to open VLC over HDMI

Everything about X, Gnome, KDE, ... and everything running on it

Not able to open VLC over HDMI

Postby fred44nl » 2018-09-17 08:05

I have VLC 3.0.3 running on Debian 9 with LXDE
when I connect to my machine with Remote Desktop, I can open VLC, but the screen does not go to the HDMI-output.
when I open VLC on a screen that is connected with HDMI, VLC does not show, but is does run in the background.
as far as I can see, everything works over HDMI, except VLC

when I put the command vlc in Terminal, there is a complaint about "no suitable interface module" and also "interface "globalhotkeys,none"

have already looked around on the net, but no solution.
how can I solve this ??
Debian 9.6 on Compulab Fitlet2
User avatar
fred44nl
 
Posts: 88
Joined: 2018-07-14 08:54

Re: Not able to open VLC over HDMI

Postby arzgi » 2018-09-17 08:31

You searched net, but how? In 2 minutes I found many sites, with same result, DISPLAY environment variable has to be set. I don't have VLC installed.

https://stackoverflow.com/questions/9636268/play-a-video-with-vlc-in-x11-from-remote-terminal
arzgi
 
Posts: 389
Joined: 2008-02-21 17:03
Location: Finland

Re: Not able to open VLC over HDMI

Postby fred44nl » 2018-09-17 09:11

ok, thank you
I must have used the wrong searching phrase.
my wife always tells me, that I don't know how to search for things.
and you are proving here right :mrgreen:
Debian 9.6 on Compulab Fitlet2
User avatar
fred44nl
 
Posts: 88
Joined: 2018-07-14 08:54

Re: Not able to open VLC over HDMI

Postby fred44nl » 2018-10-08 07:40

so, after further reading suggestions, changing settings, etc.etc., I still can't get it to work.
most discussions are about controlling VLC from the command line, but that's not what I mean.
I can't get VLC to open up on rdp0: just like any other program.

it is mentioned, that the latest version for Stretch, i.e. 3.0.3, has a serious problem and that one should stick to the previous version, i.e. 2.2.7
so I have to pin VLC from Jessie. found how to do that.
when I run
Code: Select all
sudo apt-get --dry-run -t jessie install vlc
there are several dependencies, that are not met.

do I have to install the missing packages manually ??
or is there a better way ??
Debian 9.6 on Compulab Fitlet2
User avatar
fred44nl
 
Posts: 88
Joined: 2018-07-14 08:54

Re: Not able to open VLC over HDMI

Postby fred44nl » 2018-11-09 15:20

one month later, the problem is not solved.
at this moment, I have version 3.0.4-1~obs installed.
but the gui does not open on screen rdp0:
in terminal the 1st error is "no suitable interface module"
after that, there are more errors.

I'm sorry, but I have no idea how to solve this.
Debian 9.6 on Compulab Fitlet2
User avatar
fred44nl
 
Posts: 88
Joined: 2018-07-14 08:54


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable