GDM delay before showing desktop [SOLVED]

Everything about X, Gnome, KDE, ... and everything running on it

GDM delay before showing desktop [SOLVED]

Postby Totoxa » 2018-10-13 17:12

When I log in GDM screen is locked (all controls disabled) and it keeps waiting until I move the cursor.

After the desktop is shown journald shows the following:
Code: Select all
oct 13 14:41:23 debian systemd[1]: Started User Manager for UID 1000.
oct 13 14:41:29 debian systemd-timesyncd[682]: Synchronized to time server 200.189.40.8:123 (2.debian.pool.ntp.org).
oct 13 14:42:03 debian kernel: random: crng init done
oct 13 14:42:03 debian kernel: random: 7 urandom warning(s) missed due to ratelimiting

(I move the cursor at 14:42:03)

So I think the kernel is waiting for entropy, is there a way to avoid the necessity of me moving the cursor?
Last edited by Totoxa on 2018-10-16 00:32, edited 1 time in total.
Totoxa
 
Posts: 12
Joined: 2015-01-02 17:19

Re: GDM delay before showing desktop

Postby Head_on_a_Stick » 2018-10-13 17:33

Code: Select all
# apt install haveged
# systemctl enable haveged
I suffer from depression and may lash out occasionally, try not to take it personally.
User avatar
Head_on_a_Stick
 
Posts: 8170
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: GDM delay before showing desktop

Postby Totoxa » 2018-10-13 17:43

Head_on_a_Stick wrote:
Code: Select all
# apt install haveged
# systemctl enable haveged


Seems to work fine.

Thanks!
Totoxa
 
Posts: 12
Joined: 2015-01-02 17:19

Re: GDM delay before showing desktop

Postby Head_on_a_Stick » 2018-10-13 18:58

You're welcome :)

Please edit the title of the thread (in the first post) and add [SOLVED] to help others who may encounter this problem, thanks!
I suffer from depression and may lash out occasionally, try not to take it personally.
User avatar
Head_on_a_Stick
 
Posts: 8170
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Desktop & Multimedia

Who is online

Users browsing this forum: eveanne, tynman and 5 guests

fashionable