Too high cpu usage foobar2000 running in wine

Everything about X, Gnome, KDE, ... and everything running on it

Too high cpu usage foobar2000 running in wine

Postby Ornor » 2019-02-05 13:47

Coming from Linux Mint I'm trying to get things done in Debian now. I love the minimum net-install.
I've got most things running the way I want it, the only thing that's not working as it should is Foobar2000 under wine.

The problem is, Foobar2000 under wine is consuming very much cpu time in Debian9.7 Xfce, about 250%CPU in top (in Irix mode) and even higher up to 320%.
Doing the same thing in Linux mint18.3 Xfce, Foobar2000 is using about 50%CPU, watching top (in Irix mode).
I know the cpu usage is ridicules in any case for a music player.
One of the reasons is that I have a visualization plugin that seems to be heavy.
When I disable this plugin, cpu usage drops significantly, but I want to use this and some other plugins anyhow and it does not explain the difference between Mint and Debian.
I do not which to discuss in this topic why I am using Foobar2000 instead of some of the other Linux native media players.

I've been struggling with this problem for some days now, but I can't seem to find the cause of the problem.
This is what I have done so far:

    At first I tried to use the wine version delivered with the default repository, but that didn't work because I had trouble with Gecko not being installed,I tried to install gecko myself, but I failed so I skipped this part and went on with wine4.0, following these instructions:
    https://wiki.winehq.org/Debian

    WINEARCH=win32 and WINEARCH=win64 gave the same results.

    I build the same wine version 4.0 from source code as used in Linux Mint, did not solve it.

    I re-installed Debian9.7, net-install and tried:
    - only base system, and openbox.
    - xfce desktop

    I gave Debian10 testing a try, did not solve it.

    I even tried using Manjaro, which works fine, same results as in Mint, but I don't wanna use Manjaro for real :wink:
I suspected my graphics drivers at first, but I'm not sure if that's the problem.
I followed these instructions to install my graphics drivers:
https://wiki.debian.org/NvidiaGraphicsDrivers
I think the drivers work as they supposed to do now, no errors occurred during install.

I have no clue where to start looking, any help appreciated.

My system:
Athlon 4 cores @ 3.7Ghz
8G ram
MSI GeForce GTX 750 Ti
Linux Mint 18.3 Xfce
Linux Debian 9.7 Xfce
Ornor
 
Posts: 5
Joined: 2019-02-04 14:32

Re: Too high cpu usage foobar2000 running in wine

Postby CwF » 2019-02-05 14:07

Take a look at DEADBEEF. It is almost a foobar2000 clone. Otherwise, real time sound plugins can do this.

http://deadbeef.sourceforge.net/
CwF
 
Posts: 400
Joined: 2018-06-20 15:16

Re: Too high cpu usage foobar2000 running in wine

Postby Head_on_a_Stick » 2019-02-05 14:14

Ornor wrote:At first I tried to use the wine version delivered with the default repository, but that didn't work because I had trouble with Gecko not being installed,I tried to install gecko myself, but I failed

How did you try to install it?

How did it fail, exactly?

@CwF: don't wind up the OP :mrgreen:
User avatar
Head_on_a_Stick
 
Posts: 10346
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Too high cpu usage foobar2000 running in wine

Postby Ornor » 2019-02-05 14:29

I did this:
https://www.guyrutenberg.com/2016/06/12 ... an-jessie/
in short:
Code: Select all
wget https://dl.winehq.org/wine/wine-gecko/2.44/wine_gecko-2.44-x86.msi
wget https://dl.winehq.org/wine/wine-gecko/2.44/wine_gecko-2.44-x86_64.msi
wine-development msiexec /i wine_gecko-2.44-x86.msi
wine-development msiexec /i wine_gecko-2.44-x86_64.msi

To be honest I did try so many things the past couple of days, I don't remeber what exactly went wrong with this one :?
If you think the solution is in using the older version of wine delivered with the default repository, I could try it again and see what went wrong.
Ornor
 
Posts: 5
Joined: 2019-02-04 14:32

Re: Too high cpu usage foobar2000 running in wine

Postby Head_on_a_Stick » 2019-02-05 18:39

Ornor wrote:If you think the solution is in using the older version of wine delivered with the default repository

I haven't a clue tbh (I don't use WINE) but the official repository packages are usually best.

Forum member @stevepusser has a stretch-compatible repository with WINE-staging, that might be worth a shot. The link is in his signature if you search the members list.
User avatar
Head_on_a_Stick
 
Posts: 10346
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Too high cpu usage foobar2000 running in wine

Postby Ornor » 2019-02-06 12:24

@Head_on_a_Stick I disabled the https://dl.winehq.org/wine-builds/debian/ repository in my sources.list, then tried to install wine-stagging, but there is no wine-stagging when disabling that rep.

As someone pointed out on the IRC wineHQ channel, I did not install the 32 bit Nvidea drivers.
Here: https://wiki.winehq.org/3D_Driver_Issues They show how to find out if 3d rendering is working correctly.

So I tried:
Code: Select all
WINEDEBUG=+wgl wine Foobar2000/foobar2000.exe &> wine.log
grep "X11DRV_WineGL_InitOpenglInfo" wine.log

output:
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo GL version : 4.6.0 NVIDIA 390.87.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo GL renderer : GeForce GTX 750 Ti/PCIe/SSE2.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo GLX version : 1.4.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo Server GLX version : 1.4.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo Server GLX vendor: : NVIDIA Corporation.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo Client GLX version : 1.4.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo Client GLX vendor: : NVIDIA Corporation.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo Direct rendering enabled: True

All seems fine to me, correct me if I'm wrong.
However, as sugested here: https://www.reddit.com/r/linuxquestions/comments/3wqnog/libgl_error_with_steam_on_debian_8/ you can install I386 drivers with apt-get install libgl1-nvidia-glx:i386.

So I did with:
Code: Select all
sudo apt-get install -t stretch-backports libgl1-nvidia-glx:i386

The package wasn't installed yet, so I wonder how it even was possible to see rendering enabled in the previous command output.
I did a reboot, but still no results. same cpu usage.
Ornor
 
Posts: 5
Joined: 2019-02-04 14:32

Re: Too high cpu usage foobar2000 running in wine

Postby bester69 » 2019-02-06 16:50

Ornor wrote:@Head_on_a_Stick I disabled the https://dl.winehq.org/wine-builds/debian/ repository in my sources.list, then tried to install wine-stagging, but there is no wine-stagging when disabling that rep.

As someone pointed out on the IRC wineHQ channel, I did not install the 32 bit Nvidea drivers.
Here: https://wiki.winehq.org/3D_Driver_Issues They show how to find out if 3d rendering is working correctly.

So I tried:
Code: Select all
WINEDEBUG=+wgl wine Foobar2000/foobar2000.exe &> wine.log
grep "X11DRV_WineGL_InitOpenglInfo" wine.log

output:
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo GL version : 4.6.0 NVIDIA 390.87.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo GL renderer : GeForce GTX 750 Ti/PCIe/SSE2.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo GLX version : 1.4.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo Server GLX version : 1.4.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo Server GLX vendor: : NVIDIA Corporation.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo Client GLX version : 1.4.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo Client GLX vendor: : NVIDIA Corporation.
    0194:trace:wgl:X11DRV_WineGL_InitOpenglInfo Direct rendering enabled: True

All seems fine to me, correct me if I'm wrong.
However, as sugested here: https://www.reddit.com/r/linuxquestions/comments/3wqnog/libgl_error_with_steam_on_debian_8/ you can install I386 drivers with apt-get install libgl1-nvidia-glx:i386.

So I did with:
Code: Select all
sudo apt-get install -t stretch-backports libgl1-nvidia-glx:i386

The package wasn't installed yet, so I wonder how it even was possible to see rendering enabled in the previous command output.
I did a reboot, but still no results. same cpu usage.

I dont know If this will help you, but there's a foobar version in snap repositories
snap install foobar2000 (v1.4.2)
by the way, I think to remember it also gave me hight CPU when I test it, the same happened with Aimp, so It must be something with wine. So I finally got them away and stayed with Audacious
bester69 wrote:You wont change my mind when I know Im right, Im not an ...
User avatar
bester69
 
Posts: 1413
Joined: 2015-04-02 13:15

Re: Too high cpu usage foobar2000 running in wine

Postby Ornor » 2019-02-08 13:25

I just installed Mint 19 (I was using Min18) to see how Foobar under wine performs there. Same as in Debian, very high cpu usage, which surprised me a bit.
I checked the Nvidia drivers:
In Debian9 I use nvidia 390.87 drivers
In Mint19 I use nvidia 390.77 drivers
in Mint18 I use nvidia 384.130 drivers
So maybe this problem is due to the newer nvidia drivers?

I want to try to install the exact same drivers as used in Mint18, but tbh I'm not sure how to do this.

edit.
I think Debian Jessie uses the driver I want to try.
Is it possible to install packets from jessie in Stretch? I know you can use backports for packets from newer releases, but does this work for packets from older releases too?
Ornor
 
Posts: 5
Joined: 2019-02-04 14:32

Re: Too high cpu usage foobar2000 running in wine

Postby Ornor » 2019-02-08 18:27

Ok, I feel a bit ashamed to admit, but it was my own fault. Problem is solved now.

The problem was the nvidia driver, I installed the one from backports, apparently this does not work well in combination with wine.
So what I did, I removed the newer driver (390.87) from backports and installed the driver delivered by the default repository (384.130), which is exactly the same used as with Mint18 and now all works well.

I should not have used the backports in the first place, but it was advised here: https://wiki.debian.org/NvidiaGraphicsDrivers That's why I did it.
I still do use wine4.0 as described here: https://wiki.winehq.org/Debian because wine delivered by the default repository does not install gecko and I had trouble doing it myself.

I'm really happy problem is solved now, because this was the last step holding me back to use Debian instead of Mint. I think Mint is a great distro, but I like the net-install of Debian much better, it's way less bloated. Mint did help me to step away from Windows, and I'm really thankful for that to Mint :)

Thanks all for the help provided.
Ornor
 
Posts: 5
Joined: 2019-02-04 14:32


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable