[SOLVED] Mouse buttons issue after upgrading to MATE 1.20

Everything about X, Gnome, KDE, ... and everything running on it

[SOLVED] Mouse buttons issue after upgrading to MATE 1.20

Postby TheExplorer » 2019-03-03 18:11

Hello, guys!

I'm running stable Stretch 64-bit and yesterday I upgraded MATE from 1.16 to 1.20 (from backports):

Code: Select all
sudo apt install -t stretch-backports mate-desktop-environment-extras

I'm experiencing an issue with my mouse buttons. My mouse is Logitech M318e (simple gaming mouse with a wheel/button and backward/forward buttons on the side).
I wouldn't have noticed that actually but I regularly play Openarena/Quake games. Now I simply cannot rocket jump anymore (when left+right buttons pressed at the same time). I've seen somewhat similar problems from other people running Debian Testing.

After running the following command I see that now 1) pressing on the wheel button and 2) pressing left+right buttons simultaneously are handled as the same event - button 2:

Code: Select all
xev | grep ', button'

left button - button 1
right button - button 3
pressing the middle wheel - button 2
pressing left+right buttons simultaneously - button 2

Fortunately I have Jessie installed on another drive. So I tested it there and the result is:

left button - button 1
right button - button 3
pressing the middle wheel - button 2
pressing left+right buttons simultaneously - button 1 and button 3

I'm aware that Debian has switched to libinput instead of synaptics, but there's nothing libinput related in the APT logs and everything was OK prior to that MATE upgrade.

I don't even know what package might have caused this issue in order to file a proper bug report.

Any help would be appreciated. Thank you!

UPDATE:

The solution is quite obvious and simple via .xsessionrc:

Code: Select all
xinput --set-prop DEVICE_ID "libinput Middle Emulation Enabled" 0

Where your DEVICE_ID can be found via xinput.

P.P.S. It's a new MATE feature that was added in new versions. And it is enabled by default. It can be disabled via dconf-editor (org.mate.peripherals-mouse). Now you know :)
Last edited by TheExplorer on 2019-03-07 08:22, edited 4 times in total.
Money is the evil of all root. Be free. Use Linux.
User avatar
TheExplorer
 
Posts: 254
Joined: 2010-05-31 15:04

Re: Mouse buttons issue after upgrading to MATE 1.20

Postby TheExplorer » 2019-03-03 18:58

I've found an obvious and simple solution via .xsessionrc:

Code: Select all
xinput --set-prop DEVICE_ID "libinput Middle Emulation Enabled" 0


Where your DEVICE_ID can be found via xinput.

Don't know why it was enabled by default...
Last edited by TheExplorer on 2019-03-03 19:24, edited 1 time in total.
Money is the evil of all root. Be free. Use Linux.
User avatar
TheExplorer
 
Posts: 254
Joined: 2010-05-31 15:04

Re: Mouse buttons issue after upgrading to MATE 1.20

Postby Head_on_a_Stick » 2019-03-03 19:10

Just for the record...
TheExplorer wrote:Now I simply cannot rocket jump anymore (when left+right buttons pressed at the same time)

That's not how to execute a proper rocket jump — you should jump just before you fire, doing both at the same time costs a lot more health.
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10675
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Mouse buttons issue after upgrading to MATE 1.20

Postby TheExplorer » 2019-03-03 19:20

Yeah, I know, let's leave it for the Quake gurus :) The issue is connected with the Middle mouse button emulation. I've already found something in the Debian Mail Lists and Bug tracker.
Money is the evil of all root. Be free. Use Linux.
User avatar
TheExplorer
 
Posts: 254
Joined: 2010-05-31 15:04

Re: Mouse buttons issue after upgrading to MATE 1.20

Postby TheExplorer » 2019-03-05 14:40

Head_on_a_Stick wrote:That's not how to execute a proper rocket jump


The thing is that it is frequently processed as that faulty one event even when I press jump and then fire simply because these button clicks go promptly one after another.
It didn't happen before and now it's actually very annoying and a bit unplayable. That is the issue. I don't know what package to blame and I would really like to file a bug report or something.
Money is the evil of all root. Be free. Use Linux.
User avatar
TheExplorer
 
Posts: 254
Joined: 2010-05-31 15:04

Re: Mouse buttons issue after upgrading to MATE 1.20

Postby Head_on_a_Stick » 2019-03-05 19:39

TheExplorer wrote:I don't know what package to blame and I would really like to file a bug report or something.

Blame xserver-xorg-input-libinput but I don't think this is a bug, as such, just standard behaviour that you don't like :P
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10675
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: [SOLVED] Mouse buttons issue after upgrading to MATE 1.2

Postby TheExplorer » 2019-03-06 18:40

1) There was no upgrade of any xserver package;
2) Everything was OK before the upgrade.

Anyway, thanks.
Money is the evil of all root. Be free. Use Linux.
User avatar
TheExplorer
 
Posts: 254
Joined: 2010-05-31 15:04

Re: [SOLVED] Mouse buttons issue after upgrading to MATE 1.2

Postby Head_on_a_Stick » 2019-03-06 18:51

Does MATE have a GUI tool to configure the touchpad?

Perhaps that changed your settings.
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10675
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: [SOLVED] Mouse buttons issue after upgrading to MATE 1.2

Postby TheExplorer » 2019-03-06 20:00

Yes, there is a tool for configuring mouse, but there is nothing to tweak button emulation.
Money is the evil of all root. Be free. Use Linux.
User avatar
TheExplorer
 
Posts: 254
Joined: 2010-05-31 15:04

Re: [SOLVED] Mouse buttons issue after upgrading to MATE 1.2

Postby TheExplorer » 2019-03-06 20:25

Well... Now after reboot middle mouse emulation is enabled again:

Code: Select all
xinput list-props 8
libinput Middle Emulation Enabled (291):   1

While the next string from the output says:

Code: Select all
libinput Middle Emulation Enabled Default (292):   0

Seems that .xsessionrc doesn't work now and that's a bug, I guess. But I don't know what package might have caused this issue :(
Money is the evil of all root. Be free. Use Linux.
User avatar
TheExplorer
 
Posts: 254
Joined: 2010-05-31 15:04

Re: [SOLVED] Mouse buttons issue after upgrading to MATE 1.2

Postby Head_on_a_Stick » 2019-03-06 20:31

Any clues in ~/.xsession-errors or the systemd journal?

You can configure libinput by copying /usr/share/X11/xorg.conf.d/40-libinput.conf to /etc/X11/xorg.conf.d/40-libinput.conf and editing it with reference to libinput(4) but I have no idea if MATE will honour those settings.
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10675
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: [SOLVED] Mouse buttons issue after upgrading to MATE 1.2

Postby TheExplorer » 2019-03-07 08:21

I've finally found out (phew, it was a bit hard and cost me some grey hair :)). It's a new MATE feature that was added in new versions. It is enabled by default now and can be disabled via dconf-editor (org.mate.peripherals-mouse).
Money is the evil of all root. Be free. Use Linux.
User avatar
TheExplorer
 
Posts: 254
Joined: 2010-05-31 15:04


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable