Mutt, Goobook and Debian Stable [Solved]

Everything about X, Gnome, KDE, ... and everything running on it

Mutt, Goobook and Debian Stable [Solved]

Postby larry77 » 2019-07-23 13:14

Dear All,
I happen to have minor hiccups with goobook in combination with mutt every second year or so, but now the issue has come again.
I updated to the new debian stable and reinstalled goobook from the debian stable repository.
However, see what happens when I invoke it

Code: Select all
~$ goobook
Traceback (most recent call last):
  File "/usr/local/bin/goobook", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3191, in <module>
    @_call_aside
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3175, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3204, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'goobook==1.9' distribution was not found and is required by the application


It seems that my system is looking for goobook 1.9 when the installed version is now 3.3 from the repositories.
Does anyone know how to fix this?
Cheers

larry
Last edited by larry77 on 2019-07-23 20:36, edited 1 time in total.
User avatar
larry77
 
Posts: 505
Joined: 2006-09-24 17:59

Re: Mutt, Goobook and Debian Stable

Postby ruwolf » 2019-07-23 14:12

PyPI.org: goobook 3.3 wrote:If you only have Python 2.7 you need to use GooBook 1.x. If you have Python 3.6+ you need to use GooBook 3.x.
User avatar
ruwolf
 
Posts: 357
Joined: 2008-02-18 05:04
Location: Slovakia, Banovce nad Bebravou, Matice slovenskej 1260/4-7

Re: Mutt, Goobook and Debian Stable

Postby larry77 » 2019-07-23 20:35

Actually, the issue was a leftover configuration file still mentioning goobook 1.9.
Once I removed it, everything worked.
User avatar
larry77
 
Posts: 505
Joined: 2006-09-24 17:59


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable