[Solved] Debian 10 - No sound card available to Pulseaudio

Everything about X, Gnome, KDE, ... and everything running on it

[Solved] Debian 10 - No sound card available to Pulseaudio

Postby Azgu » 2019-08-07 18:37

Hey,

I have a problem with sound on my laptop that has Buster, which I upgraded to from Stretch. In Stretch I had no problem with sound.

My troubleshooting began, when I noticed that the sound output options only has "Dummy Output". After Ducking a bit I found that I should check the status of Alsa, but that gave me this result:

Code: Select all
root@buster:/# alsactl init
bash: alsactl: command not found


So it seems that for some reason I don't have Alsa - could someone help me with this problem? I've been unable to find any instructions as to what I should do.

Here are the outputs of some of the other commands, that might be useful:

Code: Select all
root@buster:/# lsmod | grep snd
snd_hrtimer            16384  1
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            40960  1 snd_seq_midi
snd_seq                81920  3 snd_seq_midi,snd_seq_midi_event
snd_seq_device         16384  3 snd_seq,snd_seq_midi,snd_rawmidi
snd_soc_skl           114688  0
snd_soc_skl_ipc        73728  1 snd_soc_skl
snd_soc_sst_ipc        16384  1 snd_soc_skl_ipc
snd_soc_sst_dsp        36864  1 snd_soc_skl_ipc
snd_hda_ext_core       28672  1 snd_soc_skl
snd_soc_acpi_intel_match    24576  1 snd_soc_skl
snd_hda_codec_hdmi     57344  1
snd_soc_acpi           16384  2 snd_soc_acpi_intel_match,snd_soc_skl
snd_soc_core          253952  1 snd_soc_skl
snd_hda_codec_generic    86016  1
snd_compress           24576  1 snd_soc_core
snd_hda_intel          45056  4
snd_hda_codec         151552  3 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel
snd_hda_core           94208  6 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_soc_skl
snd_hwdep              16384  1 snd_hda_codec
snd_pcm_oss            61440  0
snd_mixer_oss          28672  1 snd_pcm_oss
snd_pcm               114688  9 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_pcm_oss,snd_soc_core,snd_soc_skl,snd_hda_core
snd_timer              36864  4 snd_seq,snd_hrtimer,snd_pcm
snd                    94208  21 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_compress,snd_pcm_oss,snd_soc_core,snd_pcm,snd_rawmidi,snd_mixer_oss
soundcore              16384  1 snd


Code: Select all
root@buster:/# lspci -nnk | grep -A2 Audio
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
   Subsystem: Lenovo Sunrise Point-LP HD Audio [17aa:3837]
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd_hda_intel, snd_soc_skl


Code: Select all
root@buster:/# dpkg -l alsa*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================================
un  alsa-base      <none>       <none>       (no description available)
ii  alsa-tools     1.1.7-1      amd64        Console based ALSA utilities for specific hardwar
ii  alsa-utils     1.1.8-2      amd64        Utilities for configuring and using ALSA
Last edited by Azgu on 2019-08-10 12:18, edited 1 time in total.
Azgu
 
Posts: 3
Joined: 2019-01-31 11:52

Re: Debian 10 - Alsa missing

Postby ruwolf » 2019-08-07 18:55

As you can see it, you have not installed alsa-base package...
Code: Select all
sudo apt-get install alsa-base
User avatar
ruwolf
 
Posts: 392
Joined: 2008-02-18 05:04
Location: Slovakia, Banovce nad Bebravou, Matice slovenskej 1260/4-7

Re: Debian 10 - Alsa missing

Postby Head_on_a_Stick » 2019-08-07 19:41

Azgu wrote:
Code: Select all
bash: alsactl: command not found

viewtopic.php?f=16&t=142973
User avatar
Head_on_a_Stick
 
Posts: 10498
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Debian 10 - Alsa missing

Postby sunrat » 2019-08-08 00:00

ruwolf wrote:As you can see it, you have not installed alsa-base package...
Code: Select all
sudo apt-get install alsa-base


Package is deprecated - https://packages.debian.org/search?keyw ... ection=all
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2823
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Debian 10 - Alsa missing

Postby vbrummond » 2019-08-08 02:23

The command alsactl is in: alsa-utils
Always on Debian Testing
vbrummond
 
Posts: 4468
Joined: 2010-03-02 01:42

Re: Debian 10 - Alsa missing

Postby L_V » 2019-08-08 07:52

Azgu wrote:
Code: Select all
ii  alsa-utils     1.1.8-2      amd64        Utilities for configuring and using ALSA
alsa-utils => /usr/sbin/alsactl

Either launch /usr/sbin/alsactl
or
Code: Select all
PATH=$PATH:/usr/sbin/
alsactl
L_V
 
Posts: 1083
Joined: 2007-03-19 09:04

Re: Debian 10 - Alsa missing

Postby Head_on_a_Stick » 2019-08-09 08:21

L_V wrote:Either launch /usr/sbin/alsactl
or
Code: Select all
PATH=$PATH:/usr/sbin/
alsactl

Or use the su command correctly, as explained in my [FAQ] link.
User avatar
Head_on_a_Stick
 
Posts: 10498
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Debian 10 - Alsa missing

Postby Azgu » 2019-08-10 12:08

I was able to run the command, but that did not fix the problem:

Code: Select all
root@buster:~# alsactl init
Found hardware: "HDA-Intel" "Realtek Generic" "HDA:10ec0230,17aa3820,00100002 HDA:8086280b,80860101,00100000" "0x17aa" "0x3837"
Hardware is initialized using a generic method


It seems, that even thought the operating system sees the sound card, it is not available to Pulseaudio, for some reason:

Code: Select all
antti@buster:~$ pacmd list-cards
0 card(s) available.


Alsa-base is deprecated, so I can't re-install it. I tried purging and re-installing Pulseaudio, but that did not fix the problem.
Azgu
 
Posts: 3
Joined: 2019-01-31 11:52

Re: [Solved] Debian 10 - No sound card available to Pulseaud

Postby Azgu » 2019-08-10 12:20

After Ducking some more about this issue, I found a solution here:

https://wiki.archlinux.org/index.php/Pu ... g#No_cards

For some reason I had a program called Timidity installed on my machine, and it was hogging the snd-files, so they were not available to Pulseaudio. The issue was fixed thusly:

Code: Select all
apt remove timidity
Azgu
 
Posts: 3
Joined: 2019-01-31 11:52


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable