[SOLVED] Sunpinyin strange behaviour, missing characters?

Everything about X, Gnome, KDE, ... and everything running on it

[SOLVED] Sunpinyin strange behaviour, missing characters?

Postby debbiethekiwi » 2019-10-01 07:49

I am using Sunpinyin with fcitx for Chinese input. Why not the recommended Google-pinyin? Because Sunpinyin behaviour is closer the MacOS pinyin input method I'm used to, and it learns my vocabulary, which Google-pinyin seems not to. I have Linux Mint 19.2 Mate with Sunpinyin working well, the following components are installed via Synaptic:
fcitx-sunpinyin 0.4.2-1
libsunpinyin3v5 3.0.0-git20160910-1
sunpinyin-data 0.1.22+20170109-1

I also have a Debian 10.1.0 net-install with a manual install of Mate desktop and the following Sunpinyin components were given to me by Synaptic:
fcitx-sunpinyin 0.4.22-2
libsunpinyin3v5 3.0.0-rc1+ds1-2
sunpinyin-data 0.1.22+20170109-2

With identical settings in the fcitx config panel: Use Shuangpin; ZIRANMA; Fuzzy Segmentation; Number of Sentence...1; Number of Best Tail...1; Memory Strength 3;
the Debian version will break the pinyin dian [diàn 电] into di-an and present character pairs. If I turn off Fuzzy Segmentation it will offer single characters but it seems to be missing the character 电. This is a common character, meaning electric. I looked at the https://github.com/sunpinyin Sunpinyin page on github, and there is a separate version for Debian, but, who looks after it? The Debian package maintrainers, or the Sunpinyin folks?
Last edited by debbiethekiwi on 2019-10-02 21:37, edited 1 time in total.
Posts: 18
Joined: 2019-08-31 04:15

Re: Sunpinyin strange behaviour, missing characters?

Postby debbiethekiwi » 2019-10-02 21:36

Fat finger? or not? The behaviour is exactly as it should be if the fcitx add-on "Translate into Traditional Chinese" is switched on. This function toggles on, and off, with Ctrl+Shift+F, which is a combination that I never use in any other application, and I don't see how I could have accidentally done it since I've mapped the left Ctrl to Alt & Alt to Win. A fresh install of fcitx and Sunpinyin on another system on this machine, Debian 10.1.0 netinstall + Plasma desktop, and the default OTB behaviour was the same...
Posts: 18
Joined: 2019-08-31 04:15

Return to Desktop & Multimedia

Who is online

Users browsing this forum: djk44883 and 9 guests