[Sid] Gnome-terminal don't start anymore connection refused

Everything about X, Gnome, KDE, ... and everything running on it

[Sid] Gnome-terminal don't start anymore connection refused

Postby temporpippo » 2019-10-01 12:43

Hi, I tried everything :(

I'm running Debian sid (unstable) and after some updates it's been a couple of weeks already that gnome-terminal doesn't work anymore. This is a standard Gnome 3 desktop from a Dell laptop (integrated Intel VGA) on an external monitor (HDMI) - but without external monitor nothing changes.

If I try to launch gnome-terminal from the desktop icon nothing happens. XTerm works, so I try to launch it from there:

Code: Select all
# _g_io_module_get_default: Found default implementation dconf (DConfSettingsBackend) for ‘gsettings-backend’
# watch_fast: "/org/gnome/desktop/interface/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/settings-daemon/peripherals/mouse/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/sound/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/privacy/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/wm/preferences/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/a11y/" (establishing: 0, active: 0)
# watch_established: "/org/gnome/desktop/interface/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/peripherals/mouse/" (establishing: 1)
# watch_established: "/org/gnome/desktop/sound/" (establishing: 1)
# watch_established: "/org/gnome/desktop/privacy/" (establishing: 1)
# watch_established: "/org/gnome/desktop/wm/preferences/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 1)
# watch_established: "/org/gnome/desktop/a11y/" (establishing: 1)
# _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for ‘gio-vfs’
# Warning: DESKTOP_STARTUP_ID not set and no fallback available.
# watch_fast: "/org/gnome/terminal/legacy/" (establishing: 0, active: 0)
# unwatch_fast: "/org/gnome/terminal/legacy/" (active: 0, establishing: 1)
# watch_established: "/org/gnome/terminal/legacy/" (establishing: 0)


From sudo:

Code: Select all
# _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
# posix_spawn avoided (fd close requested)
# _g_io_module_get_default: Found default implementation dconf (DConfSettingsBackend) for ‘gsettings-backend’
# watch_fast: "/org/gnome/terminal/legacy/" (establishing: 0, active: 0)
# unwatch_fast: "/org/gnome/terminal/legacy/" (active: 0, establishing: 1)
# watch_established: "/org/gnome/terminal/legacy/" (establishing: 0)


I tried to purge locales, regenerating, and then rebooting, does not work. My /etc/default/locale:

Code: Select all
#  File generated by update-locale
LANG=en_US.UTF-8
LANGUAGE="en_US:en"


Output of localectl:

Code: Select all
   System Locale: LANG=en_US.UTF-8
                  LANGUAGE=en_US:en
                  LC_NUMERIC=en_GB.UTF-8
                  LC_TIME=en_GB.UTF-8
                  LC_MONETARY=en_GB.UTF-8
                  LC_PAPER=en_GB.UTF-8
                  LC_MEASUREMENT=en_GB.UTF-8
       VC Keymap: us
      X11 Layout: us
       X11 Model: pc105+inet
     X11 Options: terminate:ctrl_alt_bks


Any idea?

Thanks in advance :)
temporpippo
 
Posts: 6
Joined: 2019-07-21 19:08

Re: [Sid] Gnome-terminal don't start anymore connection refu

Postby temporpippo » 2019-10-03 08:57

Up. Nobody?
temporpippo
 
Posts: 6
Joined: 2019-07-21 19:08

Re: [Sid] Gnome-terminal don't start anymore connection refu

Postby temporpippo » 2019-10-09 09:54

Still nothing... why? o.O
temporpippo
 
Posts: 6
Joined: 2019-07-21 19:08

Re: [Sid] Gnome-terminal don't start anymore connection refu

Postby Head_on_a_Stick » 2019-10-12 11:19

temporpippo wrote:why?

Because you're running sid and sometimes sid just breaks. Have you tried updating the system?
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10613
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: [Sid] Gnome-terminal don't start anymore connection refu

Postby temporpippo » 2019-10-29 08:06

As suggested I waited for a few days to see if the problem solved itself but unfortunately no, it still persists. I have really no clue what's going wrong but this is terribly frustrating :(
temporpippo
 
Posts: 6
Joined: 2019-07-21 19:08

Re: [Sid] Gnome-terminal don't start anymore connection refu

Postby dilberts_left_nut » 2019-10-29 08:10

temporpippo wrote:I have really no clue what's going wrong but this is terribly frustrating :(

Sid is not for everyone. Try stable.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 5017
Joined: 2009-10-05 07:54
Location: enzed

Re: [Sid] Gnome-terminal don't start anymore connection refu

Postby arid » 2019-10-29 17:43

You cannot be serious.

1. There is more than one 'terminal' available.

2. I have xfce-sid and a few other gnome packages.

3. I just downloaded gnome-terminal and gnome-terminal-data.

4.Latest version 3.34.2 works here.

5.Perhaps your desktop link is screwed up.

6.Open it from a terminal :lol:

Debian stable is for people that can't intellectually keep up.
There's no drama in my sid......
arid
 
Posts: 72
Joined: 2014-05-08 18:40
Location: Aridzona

Re: [Sid] Gnome-terminal don't start anymore connection refu

Postby dilberts_left_nut » 2019-10-29 18:15

arid wrote:Debian stable is for people that can't intellectually keep up.

No, stable is for those that want a working system with no drama.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 5017
Joined: 2009-10-05 07:54
Location: enzed

Re: [Sid] Gnome-terminal don't start anymore connection refu

Postby arid » 2019-10-29 21:06

There's no drama in my grandma...
There's no drama in my sid......
arid
 
Posts: 72
Joined: 2014-05-08 18:40
Location: Aridzona

Re: [Sid] Gnome-terminal don't start anymore connection refu

Postby arid » 2019-10-30 00:57

Well, OP, if this were my problem of all that magical code not working, I would simply cut out the middleman, right click on my desktop, choose Create Launcher and:

Code: Select all
/usr/bin/gnome-terminal.wrapper
Now I can pretty it up and put it wherever I want.

My working gnome terminal not the homeade one:

Code: Select all
$ gnome-terminal
# _g_io_module_get_default: Found default implementation dconf (DConfSettingsBackend) for ‘gsettings-backend’
# watch_fast: "/org/gnome/terminal/legacy/" (establishing: 0, active: 0)
# unwatch_fast: "/org/gnome/terminal/legacy/" (active: 0, establishing: 1)
# watch_established: "/org/gnome/terminal/legacy/" (establishing: 0)


Now I have gnome terminal and xfce4 terminal and ... terminal and ...terminal and... :shock:
There's no drama in my sid......
arid
 
Posts: 72
Joined: 2014-05-08 18:40
Location: Aridzona


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable