Closing the lid interrupts the shutdown and it suspends.....

Everything about X, Gnome, KDE, ... and everything running on it

Closing the lid interrupts the shutdown and it suspends.....

Postby ImperfectSoldier » 2019-10-05 09:33

When I manually shutdown the laptop and close the lid, the shutdown process just freezes. Later when I open the lid, I find that that it resumes the shutdown process, and that it was suspended due to closing the lid, not shutdown. I have looked it up and I couldn't find an exact match for this problem and the solutions to related topics suggested removing the suspend function.
I don't want that, I want to be able to close the lid to suspend and also the shutdown process to NOT be interrupted when I close the lid (similar to how it is on Windows).
I have TLP installed but the problem persisted even when I disable TLP with command
"sudo systemctl disable tlp"
What can I do so that the shutdown is not interrupted by closing the lid?
ImperfectSoldier
 
Posts: 3
Joined: 2019-10-05 09:17

Re: Closing the lid interrupts the shutdown and it suspends.

Postby Head_on_a_Stick » 2019-10-05 15:48

Try setting LidSwitchIgnoreInhibited to no in /etc/systemd/logind.conf
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10613
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Closing the lid interrupts the shutdown and it suspends.

Postby ImperfectSoldier » 2019-10-08 03:55

Head_on_a_Stick wrote:Try setting LidSwitchIgnoreInhibited to no in /etc/systemd/logind.conf


Thank you for the response, but the issue still persists even after changing that...
Anything else that I can do to fix it?
ImperfectSoldier
 
Posts: 3
Joined: 2019-10-05 09:17

Re: Closing the lid interrupts the shutdown and it suspends.

Postby Head_on_a_Stick » 2019-10-12 10:55

How exactly are you shutting the system down?
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10613
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Closing the lid interrupts the shutdown and it suspends.

Postby ImperfectSoldier » 2019-10-17 15:31

Head_on_a_Stick wrote:How exactly are you shutting the system down?

From the KDE UI
KDE Icon at bottom left -> Leave -> Shutdown
ImperfectSoldier
 
Posts: 3
Joined: 2019-10-05 09:17

Re: Closing the lid interrupts the shutdown and it suspends.

Postby Head_on_a_Stick » 2019-10-17 15:50

GNOME works for me, check systemd-inhibit to see if Plasma is handling the lid action ("suspend-key"):
Code: Select all
empty@E485 ~ % systemd-inhibit --no-p
WHO    UID  USER  PID  COMM           WHAT                                                     WHY                            MODE
UPower 0    root  724  upowerd        sleep                                                    Pause device polling           delay
empty  1000 empty 1164 gsd-media-keys handle-power-key:handle-suspend-key:handle-hibernate-key GNOME handling keypresses      block
empty  1000 empty 1164 gsd-media-keys sleep                                                    GNOME handling keypresses      delay
empty  1000 empty 1125 gsd-power      sleep                                                    GNOME needs to lock the screen delay

4 inhibitors listed.
empty@E485 ~ %
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10613
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable