xorg stuck in loop

Everything about X, Gnome, KDE, ... and everything running on it

xorg stuck in loop

Postby kerryhall » 2019-10-19 22:50

I just upgraded my system from 9 to 10.

Xorg is stuck in a loop where it will show the login manager for about 1 second, then back to the terminal, over and over.

Xorg log file doesn't have any error messages in it (EE) or (WW) in it, but first step would be: how do I even copy my xorg log file to another system to paste it here? I don't have iwconfig installed on this system, and I can't install it because I can't connect to the internet...
kerryhall
 
Posts: 132
Joined: 2008-08-19 11:06

Re: xorg stuck in loop

Postby CwF » 2019-10-19 23:19

Try to grab control with a different terminal, press <Ctrl><Alt><F2>, or F1 and log into the terminal from there. You can fix it there or maybe try to start a separate graphical session.
CwF
 
Posts: 502
Joined: 2018-06-20 15:16

Re: xorg stuck in loop

Postby kerryhall » 2019-10-19 23:35

I can get to a terminal but I can't determine what is going wrong. It just loops over and over with no error messages.
kerryhall
 
Posts: 132
Joined: 2008-08-19 11:06

Re: xorg stuck in loop

Postby CwF » 2019-10-20 00:10

If you can get to the terminal then it is here it's nice to have another user, or root, with something set up to help like aptitude and ranger, ncurses to the rescue. If not, you still have the command line. You should be able to use tty2/8 while tty1/7 is looping.
CwF
 
Posts: 502
Joined: 2018-06-20 15:16

Re: xorg stuck in loop

Postby kerryhall » 2019-10-20 08:29

It looks like the upgrade from 9 to 10 didn't work correctly, tons of broken dependencies.

I had to wipe my system and reinstall.
kerryhall
 
Posts: 132
Joined: 2008-08-19 11:06

Re: xorg stuck in loop

Postby Head_on_a_Stick » 2019-10-20 09:36

kerryhall wrote:It looks like the upgrade from 9 to 10 didn't work correctly, tons of broken dependencies

The official Release Notes have an extensive upgrade guide, perhaps check that next time.
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10613
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: xorg stuck in loop

Postby kerryhall » 2019-10-21 21:20

Ah, yes I read those, I just assumed everything had gone correctly when I rebooted.

Easier to just do a full reinstall than to try and connect a system to the internet if it doesn't have iwconfig.
kerryhall
 
Posts: 132
Joined: 2008-08-19 11:06


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable