Xorg bug (2100?) causing app crashes?

Everything about X, Gnome, KDE, ... and everything running on it

Xorg bug (2100?) causing app crashes?

Postby Mr. Lumbergh » 2019-10-30 01:01

I've been using the LMMS 1.2.0 AppImage (an open-source audio workstation) and it was very stable under Debian up until I started mastering and adding EQ to a track. The EQ is a parametric type that allows the cutting/adding of frequencies by adjusting a curve across the frequency band. Once I started doing this, the stability was lost; it would sometimes hard freeze the app and I'd have to close and restart it. In googling for a solution I came across the following thread on the Ubuntu forums that mentions Xorg bug #2100 that causes issues with drawing arcs, which is what it would have to do to redraw the EQ curve: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1449167. As recently as September users of Debian derivatives such as Ubuntu and Mint and even some Arch users were reporting similar problems.
Is there an official patch available for this issue, or would I be able to pull in an updated Xorg from Sid, or has it even been addressed yet in unstable? It runs OK on the other distro I have installed on this desktop (a Mandriva derivative) but not nearly as fast (at least pre-crash) because I'd started tweaking Debian to be better at sound production (installing RT kernel and JACK audio, adding my user to the "audio" group, etc.).
Thanks.
Mr. Lumbergh
 
Posts: 18
Joined: 2019-08-02 04:28

Re: Xorg bug (2100?) causing app crashes?

Postby sunrat » 2019-10-30 02:35

I'd suggest starting LMMS from a terminal and seeing if it generates any useful error messages when it crashes. Presumably you can do this for appimages, I don't use them.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2885
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Xorg bug (2100?) causing app crashes?

Postby Mr. Lumbergh » 2019-11-01 02:37

sunrat wrote:I'd suggest starting LMMS from a terminal and seeing if it generates any useful error messages when it crashes. Presumably you can do this for appimages, I don't use them.

There isn't anything there that's useful unfortunately:
Code: Select all
lumbergh@HAL9000-Deb:~$ ~/lmms/lmms-1.2.0-linux-x86_64.AppImage
Carla appears to be installed on this system at /usr/lib[64]/carla so we'll use it.
Jack appears to be installed on this system, so we'll use it.
Notice: could not set realtime priority.
Mr. Lumbergh
 
Posts: 18
Joined: 2019-08-02 04:28

Re: Xorg bug (2100?) causing app crashes?

Postby Mr. Lumbergh » 2019-11-07 03:06

Here's some additional code that was generated after another forced close:
Code: Select all
QtXmlWrapper::loadXMLfile(): empty data
000f:err:service:process_send_command receiving command result timed out
Starting using X11Embed protocol.
unique ID: mm13
RemotePlugin::DebugMessage: inputs: 0  output: 2
RemotePlugin::DebugMessage: creating editor
RemotePlugin::DebugMessage: editor successfully created
Starting using X11Embed protocol.
unique ID: jjm1
RemotePlugin::DebugMessage: inputs: 0  output: 2
RemotePlugin::DebugMessage: creating editor
RemotePlugin::DebugMessage: editor successfully created
Starting using X11Embed protocol.
unique ID: jjm1
RemotePlugin::DebugMessage: inputs: 0  output: 2
RemotePlugin::DebugMessage: creating editor
RemotePlugin::DebugMessage: editor successfully created
Starting using X11Embed protocol.
unique ID: jjm1
RemotePlugin::DebugMessage: inputs: 0  output: 2
RemotePlugin::DebugMessage: creating editor
RemotePlugin::DebugMessage: editor successfully created
Starting using X11Embed protocol.
unique ID: jjm1
RemotePlugin::DebugMessage: inputs: 0  output: 2
RemotePlugin::DebugMessage: creating editor
RemotePlugin::DebugMessage: editor successfully created
Starting using X11Embed protocol.
unique ID: SQ8L
RemotePlugin::DebugMessage: inputs: 0  output: 2
RemotePlugin::DebugMessage: creating editor
[b]0039:err:winediag:MIDIMAP_drvOpen[/b] No software synthesizer midi port found, Midi sound output probably won't work.
RemotePlugin::DebugMessage: editor successfully created
/tmp/.mount_lmms-1ha6t3E/AppRun: line 24: 20805 Killed                  QT_X11_NO_NATIVE_MENUBAR=1 $DIR/usr/bin/lmms.real "$@"

This looks like it's pointing to WINE as the issue, which is necessary to run the SQ8L and jjim1's, which are VST's written for Windows, but they all worked well up until I started EQ'ing as I mentioned in my OP.
Mr. Lumbergh
 
Posts: 18
Joined: 2019-08-02 04:28


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable