Virtual terminals don't work with NVIDIA drivers

Everything about X, Gnome, KDE, ... and everything running on it

Virtual terminals don't work with NVIDIA drivers

Postby Rezadora » 2019-10-30 18:35

Hello:
I can't use any virtual terminal (the ones accessed with the Ctrl + Alt + F# combination) using the proprietary NVIDIA graphic driver. When I try to switch to a virtual terminal the monitor detects no signal and enters sleep mode. These are my card model and the version of the drivers I'm using:
Code: Select all
$ inxi -G
Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
  driver: i915 v: kernel
  Device-2: NVIDIA GF119 [GeForce GT 610] driver: nvidia v: 390.116
  Display: x11 server: X.Org 1.20.4 driver: nvidia resolution: 1366x768~60Hz
  OpenGL: renderer: GeForce GT 610/PCIe/SSE2 v: 4.6.0 NVIDIA 390.116


The strange thing is that they are listed, which makes me believe the problem is that the graphic driver doesn't switch to them properly:
Code: Select all
$ systemctl list-units | grep getty
getty@tty1.service                                                                       loaded active running   Getty on tty1                                                               
getty@tty2.service                                                                       loaded active running   Getty on tty2                                                               
getty@tty3.service                                                                       loaded active running   Getty on tty3                                                               
getty@tty6.service                                                                       loaded active running   Getty on tty6                                                               
system-getty.slice                                                                       loaded active active    system-getty.slice                                                         
getty.target                                                                             loaded active active    Login Prompts   


This is what appears in the /var/log/Xorg.0.log file when switching to the virtual console:
Code: Select all
[  5148.238] (II) event1  - Power Button: device removed
[  5148.253] (II) event2  - Video Bus: device removed
[  5148.289] (II) event0  - Power Button: device removed
[  5148.306] (II) event4  - LITEON Technology USB Keyboard: device removed
[  5148.325] (II) event3  - Logitech USB Optical Mouse: device removed
[  5154.653] (--) NVIDIA(GPU-0): CRT-0: disconnected
[  5154.653] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[  5154.653] (--) NVIDIA(GPU-0):
[  5154.667] (--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VS197 (CRT-1): connected
[  5154.667] (--) NVIDIA(GPU-0): Ancor Communications Inc ASUS VS197 (CRT-1): 400.0 MHz maximum pixel clock
[  5154.667] (--) NVIDIA(GPU-0):
[  5154.669] (--) NVIDIA(GPU-0): DFP-0: disconnected
[  5154.669] (--) NVIDIA(GPU-0): DFP-0: Internal TMDS
[  5154.669] (--) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[  5154.669] (--) NVIDIA(GPU-0):
[  5154.669] (--) NVIDIA(GPU-0): DFP-1: disconnected
[  5154.669] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[  5154.669] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[  5154.669] (--) NVIDIA(GPU-0):
[  5154.681] (II) NVIDIA(0): Setting mode "VGA-0: nvidia-auto-select @1366x768 +0+0 {ViewPortIn=1366x768, ViewPortOut=1366x768+0+0, ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
[  5154.738] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[  5154.738] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[  5154.738] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[  5154.738] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[  5154.738] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[  5154.738] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[  5154.738] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[  5154.738] (II) NVIDIA(0):     Config Options in the README.
[  5154.757] (II) event1  - Power Button: is tagged by udev as: Keyboard
[  5154.757] (II) event1  - Power Button: device is a keyboard
[  5154.758] (II) event2  - Video Bus: is tagged by udev as: Keyboard
[  5154.758] (II) event2  - Video Bus: device is a keyboard
[  5154.759] (II) event0  - Power Button: is tagged by udev as: Keyboard
[  5154.759] (II) event0  - Power Button: device is a keyboard
[  5154.760] (II) event4  - LITEON Technology USB Keyboard: is tagged by udev as: Keyboard
[  5154.760] (II) event4  - LITEON Technology USB Keyboard: device is a keyboard
[  5154.761] (II) event3  - Logitech USB Optical Mouse: is tagged by udev as: Mouse
[  5154.761] (II) event3  - Logitech USB Optical Mouse: device is a pointer


I read in the Debian wiki that the vlock package prevents switching to the virtual console, but it isn't installed.

Why can't I access to the virtual consoles?

I'm using Debian 10 Buster under amd64 architecture with the MATE desktop environment.
Thanks in advance.
Rezadora
 
Posts: 11
Joined: 2019-10-23 15:30

Re: Virtual terminals don't work with NVIDIA drivers

Postby Rezadora » 2019-11-03 18:05

This issue is clearly related to using the proprietary NVIDIA drivers, because even if the virtual terminals don't appear I'm able to type my login credentials and run commands, which are recorded on my .bash_history file and I can see them when I go back to the graphical environment (with Ctrl + Alt + F7).

The following message that appears in the log I pasted attracted my attention:
Code: Select all
[  5154.738] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[  5154.738] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[  5154.738] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[  5154.738] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[  5154.738] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[  5154.738] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[  5154.738] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[  5154.738] (II) NVIDIA(0):     Config Options in the README.

But I don't think this is the cause, because if I understood correctly, acpid is used for lid-closing events.

I forgot to say how I have the X server configured. This is the content of my /etc/X11/xorg.conf file:
Code: Select all
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 390.116

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Ancor Communications Inc ASUS VS197"
    HorizSync       24.0 - 83.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 610"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-1"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Rezadora
 
Posts: 11
Joined: 2019-10-23 15:30


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable