[SOLVED] Deb10 proper display of "Helvetica", "Book Antiqua"

Everything about X, Gnome, KDE, ... and everything running on it

[SOLVED] Deb10 proper display of "Helvetica", "Book Antiqua"

Postby Fernando Negro » 2019-11-02 18:33

I thought this was a problem specific to Xubuntu, when I moved from 16.04 to 18.04 (https://ubuntuforums.org/showthread.php?t=2400583) but, the same thing has happened in Debian, now that I moved from version 9 to 10.


1) Concerning the "Helvetica" font (http://www.identifont.com/show?MR) and when using this webpage sample, I now get the following (notice the news title, below the image, "Far-Left ... Party Office").

Image

2) Concerning the "Book Antiqua" font (http://www.identifont.com/show?1MX) and when using this webpage sample, I now get the following (notice the "g" in the word "agente", above the second hyperlink).

Image


This happened to me also in Debian 9, if I only installed Fluxbox, instead of Xfce, after a minimal installation. But, for some reason, the problem would be solved if I installed the GIMP package - viewtopic.php?f=6&t=137150#p678676 - which I also tried this time, but didn't work. And, using the command "sudo fc-cache -f -v" to refresh the fonts cache files doesn't solve the problem either.

If anyone wants to see a comparison between what it was like in Debian 9 and is now in Debian 10, the following screenshots that I took, a year ago, when using Xubuntu 16.04 and 18.04, show the same differences: https://ubuntuforums.org/showthread.php ... st13802983


I'm using Debian 10 with Xfce (which is the official/recommended desktop environment).

Does anyone know how to make these two fonts be properly displayed?
Last edited by Fernando Negro on 2019-11-02 21:00, edited 1 time in total.
I just *love* the stability, much more bug-free nature, and also modular installation options, of Debian. Apart from the unfortunate adoption of "systemd" (viewtopic.php?f=20&t=129881&start=165#p671030) this distribution is *great*.
User avatar
Fernando Negro
 
Posts: 125
Joined: 2013-11-24 01:29
Location: Portugal

Re: Deb10 not proper displaying "Helvetica"+"Book Antiqua" f

Postby Head_on_a_Stick » 2019-11-02 18:57

Fernando Negro wrote:I'm using Debian 10 with Xfce (which is the official/recommended desktop environment).

GNOME is the "official/recommended" desktop environment and I can see the correct font in your first link from my buster GNOME system:
Code: Select all
empty@E485:~ $ fc-match helvetica                                                       
texgyreheros-regular.otf: "TeX Gyre Heros" "Regular"
empty@E485:~ $ apt-file search texgyreheros-regular.otf
fonts-texgyre: /usr/share/texmf/fonts/opentype/public/tex-gyre/texgyreheros-regular.otf
empty@E485:~ $

Worth a try, perhaps?
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10613
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Deb10 not proper displaying "Helvetica"+"Book Antiqua" f

Postby Fernando Negro » 2019-11-02 20:01

Thank you for your answer, Head_on_a_Stick.

You're right... :P

I've just checked the Internet, and Debian did went back to GNOME, after having shortly adopted Xfce as default.

(Because, when I downloaded my "netinst.iso" file, from a mirror - of the original Debian server: https://cdimage.debian.org/debian-cd/cu ... 64/iso-cd/ - I could see that the only .iso image, for my architecture, that was not a "net install" one, was a "xfce-CD-1.iso", I made the wrong assumption that this latter file was the regular/official Debian installation image...)

If you say that, in GNOME, you can see the fonts being correctly displayed, I believe you. (Indeed, I was finding it strange that such a quality-driven distribution as Debian could have this serious problem.)

But, anyway, I really prefer Xfce to GNOME... And so, if anyone knows how to make these two fonts be properly displayed in Xfce...

(I will, in the meantime, try to install some GNOME packages/programs, to see if it helps.)

When using the same commands as you did, this is what I get:

Code: Select all
*******@*******:~$ fc-match helvetica
Arial.ttf: "Arial" "Regular"
*******@*******:~$ apt-file search texgyreheros-regular.otf
fonts-texgyre: /usr/share/texmf/fonts/opentype/public/tex-gyre/texgyreheros-regular.otf
*******@*******:~$
I just *love* the stability, much more bug-free nature, and also modular installation options, of Debian. Apart from the unfortunate adoption of "systemd" (viewtopic.php?f=20&t=129881&start=165#p671030) this distribution is *great*.
User avatar
Fernando Negro
 
Posts: 125
Joined: 2013-11-24 01:29
Location: Portugal

Re: Deb10 not proper displaying "Helvetica"+"Book Antiqua" f

Postby Fernando Negro » 2019-11-02 20:58

Solved! :)

I first tried to install some GNOME (and also non-GNOME) packages/programs - besides GIMP - and nothing worked.

I then had a look at the commands that Head_on_a_Stick used, and figured out that, I didn't have the mentioned "fonts-texgyre" package installed (in which the proper substitute for "Helvetica" is) - and, that was apparently all that I needed to install, in order to have the correct substitutes/correspondences working, for both fonts.

Thank you very much, Head_on_a_Stick, for your last command! :)
I just *love* the stability, much more bug-free nature, and also modular installation options, of Debian. Apart from the unfortunate adoption of "systemd" (viewtopic.php?f=20&t=129881&start=165#p671030) this distribution is *great*.
User avatar
Fernando Negro
 
Posts: 125
Joined: 2013-11-24 01:29
Location: Portugal


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable