External HDD detected but can't mounted.

Everything about X, Gnome, KDE, ... and everything running on it

External HDD detected but can't mounted.

Postby hack3rcon » 2020-01-12 07:54

Hello,
I have an external HDD and when I plugged it to my system then it is detected, but not mounted:
Code: Select all
$ lsusb
Bus 002 Device 037: ID 125f:a15a A-DATA Technology Co., Ltd. DashDrive Durable HD710 portable HDD various size

And:
Code: Select all
$ sudo fdisk -l
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Disk model: STXXX
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: C40840DC-B308-4919-B387-E2BD0C61DD5F

Device         Start       End   Sectors   Size Type
/dev/sda1       2048   1368063   1366016   667M EFI System
/dev/sda2    1368064 177930239 176562176  84.2G Microsoft basic data
/dev/sda3  177930240 959180799 781250560 372.5G Microsoft basic data
/dev/sda4  959180800 976771071  17590272   8.4G Linux swap


Disk /dev/sdb: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Disk model: STXXX
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x00d600d6

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sdb1              63 419425019 419424957   200G  7 HPFS/NTFS/exFAT
/dev/sdb2       419425020 976773167 557348148 265.8G  7 HPFS/NTFS/exFAT

Partition 1 does not start on physical sector boundary.
Partition 2 does not start on physical sector boundary.

And:
Code: Select all
$ dmesg | tail -n 17
[ 8235.103120] usb 2-7: new high-speed USB device number 66 using xhci_hcd
[ 8235.252558] usb 2-7: New USB device found, idVendor=125f, idProduct=a15a, bcdDevice= 1.00
[ 8235.252560] usb 2-7: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[ 8235.252561] usb 2-7: Product: HD710
[ 8235.252562] usb 2-7: Manufacturer: ADATA
[ 8235.252563] usb 2-7: SerialNumber: 04A28201002800000062
[ 8235.253482] usb-storage 2-7:1.0: USB Mass Storage device detected
[ 8235.253729] scsi host6: usb-storage 2-7:1.0
[ 8236.283962] scsi 6:0:0:0: Direct-Access     ADATA    HD710            0    PQ: 0 ANSI: 6
[ 8236.284680] sd 6:0:0:0: Attached scsi generic sg3 type 0
[ 8236.285699] sd 6:0:0:0: [sdc] Spinning up disk...

How can I access to the disk?

Thank you.
hack3rcon
 
Posts: 343
Joined: 2015-02-16 09:54

Re: External HDD detected but can't mounted.

Postby Head_on_a_Stick » 2020-01-12 10:01

Does it show up in lsblk? Looks like it's been assigned to /dev/sdc and it doesn't have any partitions.

This might make it show up in fdisk:
Code: Select all
# partprobe /dev/sdc

Or maybe the drive is broken, have you double-checked with a live ISO image?
User avatar
Head_on_a_Stick
 
Posts: 11503
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: External HDD detected but can't mounted.

Postby hack3rcon » 2020-01-12 11:58

The result is:
Code: Select all
$ sudo partprobe /dev/sdc
Error: Could not stat device /dev/sdc - No such file or directory.
hack3rcon
 
Posts: 343
Joined: 2015-02-16 09:54

Re: External HDD detected but can't mounted.

Postby p.H » 2020-01-13 13:11

Kernel messages are missing or the drive initialization is incomplete. Maybe it is defective, or the power is insufficient.
How is it powered ?
p.H
 
Posts: 1296
Joined: 2017-09-17 07:12


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable