sddm theme error

Everything about X, Gnome, KDE, ... and everything running on it

Re: sddm theme error

Postby L_V » 2020-01-27 07:34

Anyway, Qt11 should not prevent creation of /usr/share/sddm/themes/McMojave directory.
There is something wrong here to be first clarified. Step by step.

@nickettke
You should avoid/limit installation of external KDE packages for the moment.
Debian stable is stable, but ....sometimes a bit late on some points, waiting for backports.
Qt.11 with different QtQuick /QtQuick.Control versions is not clean and confusing (not easily trackable with Debian package version).
No immediate solution to update Buster to Qt 5.12, which does not mean it is not feasible, but probably not to be recommended to you.
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: sddm theme error

Postby Chrisdb » 2020-01-27 07:46

L_V wrote:Anyway, Qt11 should not prevent creation of /usr/share/sddm/themes/McMojave directory.
There is something wrong here to be first clarified. Step by step.


This is indeed strange, but at some point the theme did exist in '/usr/share/sddm/themes' according to the screenshot. Maybe the system removes the theme entry after failure...

btw, which version and OS are you running L_V?

@nickettke
For most of the QML files, simply downgrading QtQuick.Controls 2.5 to QtQuick.Controls 2.4 solves the problem.
You can try and modify the 'Clock.qml' file and change
Code: Select all
import QtQuick.Controls 2.5


TO

Code: Select all
import QtQuick.Controls 2.4


And see if it works, but I'm afraid it will be trial and error...

**EDIT
Another option is to ask the creator for help in the comments: https://store.kde.org/p/1312086/
Chrisdb
 
Posts: 273
Joined: 2018-04-10 07:16

Re: sddm theme error

Postby L_V » 2020-01-27 08:32

Chrisdb wrote: Maybe the system removes the theme entry after failure.
I really don't believe it.
Chrisdb wrote:which version and OS are you running L_V ?
Something like this: libqt5core5a 5.12 / plasma-workspace 4:5.17
Chrisdb wrote: You can try and modify the 'Clock.qml' file and change "import QtQuick.Controls 2.X"
Not fan of this proposal which is ugly, especially for nickette who said: "I'm sort of a novice".

Is a kind of novice who wants KDE with latest fancy features should run Debian Stable ?
It is just a question (I may have an idea).
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: sddm theme error

Postby nickettke » 2020-01-27 17:44

Thanks guys. I tried this
Chrisdb wrote:For most of the QML files, simply downgrading QtQuick.Controls 2.5 to QtQuick.Controls 2.4 solves the problem.
You can try and modify the 'Clock.qml' file and change
Code: Select all
import QtQuick.Controls 2.5


TO

Code: Select all
import QtQuick.Controls 2.4
and no change at all, just some more errors.

It's ok, I'm leaving it there. Some things are not meant to be. And I'm a quitter of sort.
nickettke
 
Posts: 16
Joined: 2020-01-20 12:05

Re: sddm theme error

Postby Chrisdb » 2020-01-28 05:47

nickettke wrote:It's ok, I'm leaving it there. Some things are not meant to be. And I'm a quitter of sort.


If you say so, but I think you will bump into more issues like this if you use themes that rely on this version..
If you're still interested, we can have a look at the errors and try to make it work with your current setup
Chrisdb
 
Posts: 273
Joined: 2018-04-10 07:16

Re: sddm theme error

Postby nickettke » 2020-01-28 15:47

Chrisdb wrote:If you say so, but I think you will bump into more issues like this if you use themes that rely on this version..
If you're still interested, we can have a look at the errors and try to make it work with your current setup

I'm okay with going on but it takes a lot of patience since I don't know much in the current scenario. You're gonna have to dumb it down a lot.

So please tell me what to do.
nickettke
 
Posts: 16
Joined: 2020-01-20 12:05

Re: sddm theme error

Postby Chrisdb » 2020-01-28 18:45

nickettke wrote:
Chrisdb wrote:If you say so, but I think you will bump into more issues like this if you use themes that rely on this version..
If you're still interested, we can have a look at the errors and try to make it work with your current setup

I'm okay with going on but it takes a lot of patience since I don't know much in the current scenario. You're gonna have to dumb it down a lot.

So please tell me what to do.


You mentioned extra errors when you replaced the original code with
Code: Select all
Import QtQuick.Controls 2.4


Please post the errors
Chrisdb
 
Posts: 273
Joined: 2018-04-10 07:16

Previous

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable