Media keys doesn't work

Everything about X, Gnome, KDE, ... and everything running on it

Media keys doesn't work

Postby pedronovaes » 2020-02-04 01:53

Hi,

When I use the Spotify app on Debian 10, sometimes the media keys don't work. I press the play/pause or next or before buttons and it doesn't work.

Can someone help me?
pedronovaes
 
Posts: 16
Joined: 2019-08-07 17:49

Re: Media keys doesn't work

Postby Chrisdb » 2020-02-04 08:45

Is this a Debian package or Snap install?

Did it work before? If so and you're using snap, try a previous version and see if it worked then.

spotify forums:
https://community.spotify.com/t5/Desktop-Linux/bd-p/desktop_linux
Chrisdb
 
Posts: 226
Joined: 2018-04-10 07:16

Re: Media keys doesn't work

Postby pedronovaes » 2020-02-04 12:10

Chrisdb wrote:Is this a Debian package or Snap install?


It is a Debian package. I installed using these commands:

Code: Select all
curl -sS https://download.spotify.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb http://repository.spotify.com stable non-free" | sudo tee /etc/apt/sources.list.d/spotify.list
sudo apt-get update && sudo apt-get install spotify-client


When I turn on my computer, it works. But, over time, it stops working.
The same behavior for the Rhythmbox or other music player.
pedronovaes
 
Posts: 16
Joined: 2019-08-07 17:49

Re: Media keys doesn't work

Postby Chrisdb » 2020-02-04 12:34

Which DE are you using (Gnome, KDE, Xfce,...)
Chrisdb
 
Posts: 226
Joined: 2018-04-10 07:16

Re: Media keys doesn't work

Postby pedronovaes » 2020-02-04 12:49

Chrisdb wrote:Which DE are you using (Gnome, KDE, Xfce,...)


I'm using Gnome
pedronovaes
 
Posts: 16
Joined: 2019-08-07 17:49

Re: Media keys doesn't work

Postby Chrisdb » 2020-02-04 13:22

pedronovaes wrote:I'm using Gnome


Ok, can you post output of the journal from the moment you experienced the issue, f.e. your previous session:
Code: Select all
sudo journalctl -x -b -1
Chrisdb
 
Posts: 226
Joined: 2018-04-10 07:16

Re: Media keys doesn't work

Postby pedronovaes » 2020-02-06 01:39

It appears this message: Specifying boot ID or boot offset has no effect, no persistent journal was found.
pedronovaes
 
Posts: 16
Joined: 2019-08-07 17:49

Re: Media keys doesn't work

Postby Head_on_a_Stick » 2020-02-06 05:18

Code: Select all
# mkdir -p /var/log/journal
User avatar
Head_on_a_Stick
 
Posts: 11114
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Media keys doesn't work

Postby pedronovaes » 2020-02-07 01:59

It appears this message:

Feb 06 09:14:02 inspiron systemd-shutdown[1]: Syncing filesystems and block devices.
Feb 06 09:14:02 inspiron systemd-shutdown[1]: Sending SIGTERM to remaining processes...
Feb 06 09:14:02 inspiron systemd-journald[339]: Journal stopped
-- Subject: The journal has been stopped
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- The system journal process has shut down and closed all currently
-- active journal files.
pedronovaes
 
Posts: 16
Joined: 2019-08-07 17:49

Re: Media keys doesn't work

Postby pedronovaes » 2020-02-07 02:05

I just took a test. I opened spotify and it was working normally, then I opened a tab in chrome with youtube and closed spotify. I opened spotify and then the buttons stopped working with spotify and continued to work with youtube. Then I closed chrome and opened Spotify, so it worked normally.

Any idea what it might be?
pedronovaes
 
Posts: 16
Joined: 2019-08-07 17:49

Re: Media keys doesn't work

Postby Chrisdb » 2020-02-07 09:53

pedronovaes wrote:I just took a test. I opened spotify and it was working normally, then I opened a tab in chrome with youtube and closed spotify. I opened spotify and then the buttons stopped working with spotify and continued to work with youtube. Then I closed chrome and opened Spotify, so it worked normally.

Any idea what it might be?


Sounds like GNOME is playing tricks on you :D
Gnome is probably intercepting your media key events

Try this:
Code: Select all
sudo apt install dconf-editor


Now go to org.gnome.settings-daemon.plugins.media-keys and change the respective buttons to none ('')
Chrisdb
 
Posts: 226
Joined: 2018-04-10 07:16

Re: Media keys doesn't work

Postby pedronovaes » 2020-02-10 02:49

Chrisdb wrote:Sounds like GNOME is playing tricks on you :D
Gnome is probably intercepting your media key events

Try this:
Code: Select all
sudo apt install dconf-editor


Now go to org.gnome.settings-daemon.plugins.media-keys and change the respective buttons to none ('')


I tried, but it didn't work. So, do you have another solution?
pedronovaes
 
Posts: 16
Joined: 2019-08-07 17:49

Re: Media keys doesn't work

Postby Chrisdb » 2020-02-10 18:39

Chrisdb
 
Posts: 226
Joined: 2018-04-10 07:16


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable