[SOLVED] system settings won't open anymore

Everything about X, Gnome, KDE, ... and everything running on it

[SOLVED] system settings won't open anymore

Postby Coulomb » 2020-03-02 18:29

My system Settings ( The crossed tools-symbol) won't open anymore. I click on them nothing whatsoever happens. I did a bit of googleing and someone suggested to reinstall the package from synaptic pm which I did but it changed nothing. I have version 4:5.17.5-2
Last edited by Coulomb on 2020-03-07 18:27, edited 1 time in total.
Coulomb
 
Posts: 26
Joined: 2019-10-26 07:07

Re: system settings won't open anymore

Postby Coulomb » 2020-03-04 16:38

I still haven't been able to figure it out.

I reinstalled gnome-control-center, opening it from the terminal, I get this error message:;

Code: Select all
phil@debianlenovo:~$ gnome-control-center
**
ERROR:../shell/cc-shell-model.c:458:cc_shell_model_set_panel_visibility: assertion failed: (valid)
Aborted
Coulomb
 
Posts: 26
Joined: 2019-10-26 07:07

Re: system settings won't open anymore

Postby stevepusser » 2020-03-05 23:58

So, you're running Testing, but didn't bother to tell us that, and don't know the difference between the KDE systemsettings version in Bullseye and gnome-control-center?

WTH are you doing running testing? :roll:
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kodi 18.6, Blender 2.8.2, 5.5 kernels, Chromium with va-api, Telegram-desktop 1.9.21, Clipgrab 3.8.11
User avatar
stevepusser
 
Posts: 11557
Joined: 2009-10-06 05:53

Re: system settings won't open anymore

Postby Coulomb » 2020-03-07 09:34

stevepusser wrote:So, you're running Testing, but didn't bother to tell us that, and don't know the difference between the KDE systemsettings version in Bullseye and gnome-control-center?

WTH are you doing running testing? :roll:


I needed to update the GNU-C-Compiler and that's why I enabled testing. I forgot to disable it in my sources... I can shoot myself now pretty much. Nonetheless, I reverted back to stable and everything works fine now.
Coulomb
 
Posts: 26
Joined: 2019-10-26 07:07

Re: system settings won't open anymore

Postby arzgi » 2020-03-07 17:58

Coulomb wrote: I reverted back to stable and everything works fine now.


Good you got it working. Could you please edit the header of your first post in the thread, and add [SOLVED] to the front of it.
arzgi
 
Posts: 568
Joined: 2008-02-21 17:03
Location: Finland

Re: [SOLVED] system settings won't open anymore

Postby Coulomb » 2020-03-07 18:29

I did. though technically the systemsettings in bullseye testing don't open :o
Coulomb
 
Posts: 26
Joined: 2019-10-26 07:07

Re: [SOLVED] system settings won't open anymore

Postby stevepusser » 2020-03-07 22:46

Did you need to update gcc to run something, compile something, or develop something?

Purely by chance, I happen to have backported a fairly recent version of gcc-9.2.1 on vanilla Buster for MX 19...
http://mxrepo.com/mx/experimental/pool/test/g/gcc-9/

Sure generates a lot of packages, don't it?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kodi 18.6, Blender 2.8.2, 5.5 kernels, Chromium with va-api, Telegram-desktop 1.9.21, Clipgrab 3.8.11
User avatar
stevepusser
 
Posts: 11557
Joined: 2009-10-06 05:53

Re: [SOLVED] system settings won't open anymore

Postby Coulomb » 2020-03-08 06:41

I updated the GNU-C compiler for use within the scope of the Arduino IDE, but after I did that I learned that the IDE brings its "own" compiler, avr-gcc. So I only had to update the Arduino IDE from a deb package provided on their website, as the version in the official debian repositories is years behind. So I literally simply forgot about having enabled testing and caused a mess after updating/upgrading.
Coulomb
 
Posts: 26
Joined: 2019-10-26 07:07


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable