Xfce "Directory menu" makes the whole desktop unresponsive

Everything about X, Gnome, KDE, ... and everything running on it

Xfce "Directory menu" makes the whole desktop unresponsive

Postby eliasYFGM » 2020-03-14 21:56

I have recently installed Debian 10 (64-bits) on my system with Xfce, but I found something with the "Directory menu" item that can be added to a panel.

Everytime I open the Directory menu from the panel, it freezes the whole system and takes like 2 minutes to be responsive again. And when I do that from the second time onward, it freezes for about 10 seconds only, but it still makes the whole desktop unresponsive during that time.

This did not happen at all on Debian 9 and Xubuntu (which was the OS I had before Debian 10). There seems to be a lot of activity on the hard disk when I open the menu too.

Is there any workaround or fix for this? I can just remove it from the panel and not use it but this certain item has proven to be very useful for me everytime I want to open a directory or terminal quickly.
Last edited by eliasYFGM on 2020-03-15 02:02, edited 2 times in total.
eliasYFGM
 
Posts: 3
Joined: 2016-10-01 22:11

Re: Xfce "Directory menu" makes the whole desktop unresponsi

Postby CwF » 2020-03-15 00:26

Where do you have it pointed? IE base directory, and filtering, and hidden files? Any lingering root files in the way.

Works great for me, even multiple instances.
CwF
 
Posts: 607
Joined: 2018-06-20 15:16

Re: Xfce "Directory menu" makes the whole desktop unresponsi

Postby eliasYFGM » 2020-03-15 01:57

CwF wrote:Where do you have it pointed? IE base directory, and filtering, and hidden files? Any lingering root files in the way.

Works great for me, even multiple instances.

Hey, thanks for the reply. It currently points to my default Home directory. In fact, I only left the default options, and I have not changed any setting. It looks like this:

Image

My home dir doesn't have any files owned by root either.

Edit: Okay, I sorta found what the problem was.

It has to do with Compiz being used on my Xfce desktop. When I disabled certain plugins and options that I didn't need in CompizConfig, the Directory menu now works fine without freezing. The options that I disabled where all of the "Image loading" plugins, Glib, Focus position polling, Mouse position polling and others that I don't remember well.

Weird, but at least everything works fine now.
eliasYFGM
 
Posts: 3
Joined: 2016-10-01 22:11


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable