Wine: can't install it

Everything about X, Gnome, KDE, ... and everything running on it

Wine: can't install it

Postby xlepws » 2020-03-16 14:22

Hi, I have been trying to install WineHQ. Followed these instructions:
https://wiki.winehq.org/Debian
https://forum.winehq.org/viewtopic.php?t=29697 (this, because it seems I needed Release.key instead of winehq.key)

So:
apt-get install --install-recommends winehq-stable (also without --install-recommends, same error)
--> error: "winehq-stable : Dipende: wine-stable (= 3.0.4~sid)" (my system is in Italian)

then, apt-get install wine-stable --> error: "wine-stable : Dipende: wine-stable-i386 (= 3.0.4~sid)"
then, apt-get install wine-stable-i386 -->
Code: Select all
I seguenti pacchetti hanno dipendenze non soddisfatte:
wine-stable-i386:i386 : Dipende: libasound2:i386 (>= 1.0.16)
Dipende: libc6:i386 (>= 2.28) ma non sta per essere installato
Dipende: libglib2.0-0:i386 (>= 2.12.0) ma non sta per essere installato
Dipende: libgphoto2-6:i386 (>= 2.5.10) ma non sta per essere installato
Dipende: libgphoto2-port12:i386 (>= 2.5.10) ma non sta per essere installato
Dipende: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) ma non sta per essere installato
Dipende: libgstreamer1.0-0:i386 (>= 1.4.0) ma non sta per essere installato
Dipende: liblcms2-2:i386 (>= 2.2+git20110628) ma non sta per essere installato
Dipende: libldap-2.4-2:i386 (>= 2.4.7) ma non sta per essere installato
Dipende: libmpg123-0:i386 (>= 1.13.7) ma non sta per essere installato
Dipende: libopenal1:i386 (>= 1.14) ma non sta per essere installato
Dipende: libpcap0.8:i386 (>= 0.9.8) ma non sta per essere installato
Dipende: libpulse0:i386 (>= 0.99.1) ma non sta per essere installato
Dipende: libudev1:i386 (>= 183) ma non sta per essere installato
Dipende: libx11-6:i386 ma non sta per essere installato
Dipende: libxext6:i386 ma non sta per essere installato
Dipende: libxml2:i386 (>= 2.9.0) ma non sta per essere installato
Dipende: zlib1g:i386 (>= 1:1.1.4) ma non sta per essere installato
Dipende: libasound2-plugins:i386 ma non sta per essere installato
Dipende: libncurses5:i386 ma non sta per essere installato
Raccomanda: libcapi20-3:i386 ma non sta per essere installato
Raccomanda: libcups2:i386 (>= 1.4.0) ma non sta per essere installato
Raccomanda: libdbus-1-3:i386 (>= 1.9.14) ma non sta per essere installato
Raccomanda: libfontconfig1:i386 (>= 2.12.6) ma non sta per essere installato
Raccomanda: libfreetype6:i386 (>= 2.2.1) ma non sta per essere installato
Raccomanda: libglu1-mesa:i386 ma non sta per essere installato oppure
libglu1:i386
Raccomanda: libgnutls30:i386 (>= 3.5.0) ma non sta per essere installato
Raccomanda: libgsm1:i386 (>= 1.0.13) ma non sta per essere installato
Raccomanda: libjpeg62-turbo:i386 (>= 1.3.1) ma non sta per essere installato
Raccomanda: libkrb5-3:i386 (>= 1.6.dfsg.2) ma non sta per essere installato
Raccomanda: libncurses6:i386 (>= 6) ma non sta per essere installato
Raccomanda: libodbc1:i386 (>= 2.3.1) ma non sta per essere installato
Raccomanda: libosmesa6:i386 (>= 10.2~) ma non sta per essere installato
Raccomanda: libpng16-16:i386 (>= 1.6.2-1) ma non sta per essere installato
Raccomanda: libsane:i386 (>= 1.0.24) ma non sta per essere installato
Raccomanda: libtiff5:i386 (>= 4.0.3) ma non sta per essere installato
Raccomanda: libv4l-0:i386 (>= 0.5.0) ma non sta per essere installato
Raccomanda: libxcomposite1:i386 (>= 1:0.3-1) ma non sta per essere installato
Raccomanda: libxcursor1:i386 (> 1.1.2) ma non sta per essere installato
Raccomanda: libxfixes3:i386 ma non sta per essere installato
Raccomanda: libxi6:i386 ma non sta per essere installato
Raccomanda: libxinerama1:i386 ma non sta per essere installato
Raccomanda: libxrandr2:i386 ma non sta per essere installato
Raccomanda: libxrender1:i386 ma non sta per essere installato
Raccomanda: libxslt1.1:i386 (>= 1.1.25) ma non sta per essere installato
Raccomanda: libxxf86vm1:i386 ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.


..help! :(
xlepws
 
Posts: 21
Joined: 2020-03-16 14:09

Re: Wine: can't install it

Postby Hallvor » 2020-03-16 15:35

Lenovo ThinkPad T440S, Intel Core i7-4600U CPU @ 2.10GHz, 8 GB RAM, 256 GB SSD, Debian Buster (KDE)
Lenovo ThinkPad X240, Intel Core i5-4300U CPU @ 2.90GHz, 8 GB RAM, 120 GB SSD, Debian Buster (KDE)
User avatar
Hallvor
 
Posts: 1030
Joined: 2009-04-16 18:35
Location: Norway

Re: Wine: can't install it

Postby xlepws » 2020-03-16 16:03

Hi, it won't work unfortunately:

Code: Select all
root@debian02:/home/manu# apt install wine-development wine32-development wine64-development libwine-development libwine-development:i386 fonts-wine
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire che è stata richiesta una situazione impossibile oppure, se si sta usando una distribuzione in sviluppo, che alcuni pacchetti richiesti non sono ancora stati creati o sono stati rimossi  da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 libwine-development:i386 : Dipende: libc6:i386 (>= 2.29) ma non sta per essere installato
                            Dipende: libfontconfig1:i386 (>= 2.12.6) ma non sta per essere installato
                            Dipende: libfreetype6:i386 (>= 2.6.2) ma non sta per essere installato
                            Dipende: libncurses6:i386 (>= 6) ma non sta per essere installato
                            Dipende: libtinfo6:i386 (>= 6) ma non sta per essere installato
                            Dipende: libasound2:i386 (>= 1.0.16)
                            Dipende: libfaudio0:i386 (>= 19.06.07) ma non sta per essere installato
                            Dipende: libglib2.0-0:i386 (>= 2.12.0) ma non sta per essere installato
                            Dipende: libgphoto2-6:i386 (>= 2.5.10) ma non sta per essere installato
                            Dipende: libgphoto2-port12:i386 (>= 2.5.10) ma non sta per essere installato
                            Dipende: libgstreamer-plugins-base1.0-0:i386 (>= 1.0.0) ma non sta per essere installato
                            Dipende: libgstreamer1.0-0:i386 (>= 1.4.0) ma non sta per essere installato
                            Dipende: liblcms2-2:i386 (>= 2.2+git20110628) ma non sta per essere installato
                            Dipende: libldap-2.4-2:i386 (>= 2.4.7) ma non sta per essere installato
                            Dipende: libmpg123-0:i386 (>= 1.13.7) ma non sta per essere installato
                            Dipende: libopenal1:i386 (>= 1.14) ma non sta per essere installato
                            Dipende: libpcap0.8:i386 (>= 0.9.8) ma non sta per essere installato
                            Dipende: libpulse0:i386 (>= 0.99.1) ma non sta per essere installato
                            Dipende: libudev1:i386 (>= 183) ma non sta per essere installato
                            Dipende: libvkd3d1:i386 (>= 1.0) ma non sta per essere installato
                            Dipende: libx11-6:i386 ma non sta per essere installato
                            Dipende: libxext6:i386 ma non sta per essere installato
                            Dipende: libxml2:i386 (>= 2.9.0) ma non sta per essere installato
                            Dipende: ocl-icd-libopencl1:i386 ma non sta per essere installato oppure
                                     libopencl1:i386
                            Dipende: zlib1g:i386 (>= 1:1.1.4) ma non sta per essere installato
                            Raccomanda: libcapi20-3:i386 ma non sta per essere installato
                            Raccomanda: libcups2:i386 (>= 1.4.0) ma non sta per essere installato
                            Raccomanda: libdbus-1-3:i386 (>= 1.9.14) ma non sta per essere installato
                            Raccomanda: libgl1:i386 ma non sta per essere installato
                            Raccomanda: libglu1-mesa:i386 ma non sta per essere installato oppure
                                        libglu1:i386
                            Raccomanda: libgnutls30:i386 (>= 3.6.5) ma non sta per essere installato
                            Raccomanda: libgsm1:i386 (>= 1.0.18) ma non sta per essere installato
                            Raccomanda: libgssapi-krb5-2:i386 (>= 1.6.dfsg.2) ma non sta per essere installato
                            Raccomanda: libjpeg62-turbo:i386 (>= 1.3.1) ma non sta per essere installato
                            Raccomanda: libkrb5-3:i386 (>= 1.6.dfsg.2) ma non sta per essere installato
                            Raccomanda: libodbc1:i386 (>= 2.3.1) ma non sta per essere installato
                            Raccomanda: libosmesa6:i386 (>= 10.2~) ma non sta per essere installato
                            Raccomanda: libpng16-16:i386 (>= 1.6.2-1) ma non sta per essere installato
                            Raccomanda: libsane:i386 (>= 1.0.24) ma non sta per essere installato
                            Raccomanda: libsdl2-2.0-0:i386 (>= 2.0.10) ma non sta per essere installato
                            Raccomanda: libtiff5:i386 (>= 4.0.3) ma non sta per essere installato
                            Raccomanda: libv4l-0:i386 (>= 0.5.0) ma non sta per essere installato
                            Raccomanda: libvulkan1:i386 (>= 1.2.131.2) ma non sta per essere installato
                            Raccomanda: libxcomposite1:i386 (>= 1:0.3-1) ma non sta per essere installato
                            Raccomanda: libxcursor1:i386 (> 1.1.2) ma non sta per essere installato
                            Raccomanda: libxfixes3:i386 ma non sta per essere installato
                            Raccomanda: libxi6:i386 ma non sta per essere installato
                            Raccomanda: libxinerama1:i386 ma non sta per essere installato
                            Raccomanda: libxrandr2:i386 ma non sta per essere installato
                            Raccomanda: libxrender1:i386 ma non sta per essere installato
                            Raccomanda: libxslt1.1:i386 (>= 1.1.25) ma non sta per essere installato
                            Raccomanda: libxxf86vm1:i386 ma non sta per essere installato
                            Raccomanda: libgl1-mesa-dri:i386 ma non sta per essere installato
                            Raccomanda: libasound2-plugins:i386 ma non sta per essere installato
                            Raccomanda: gstreamer1.0-plugins-good:i386 ma non sta per essere installato
 wine32-development:i386 : Dipende: libc6:i386 (>= 2.28) ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
xlepws
 
Posts: 21
Joined: 2020-03-16 14:09

Re: Wine: can't install it

Postby Hallvor » 2020-03-16 16:38

Remove all packages not installed from Debian Stable, if that is what you are running. Then try again.
Lenovo ThinkPad T440S, Intel Core i7-4600U CPU @ 2.10GHz, 8 GB RAM, 256 GB SSD, Debian Buster (KDE)
Lenovo ThinkPad X240, Intel Core i5-4300U CPU @ 2.90GHz, 8 GB RAM, 120 GB SSD, Debian Buster (KDE)
User avatar
Hallvor
 
Posts: 1030
Joined: 2009-04-16 18:35
Location: Norway

Re: Wine: can't install it

Postby Head_on_a_Stick » 2020-03-16 19:21

@OP: please post the output of
Code: Select all
LC_ALL=C apt policy
User avatar
Head_on_a_Stick
 
Posts: 11528
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Wine: can't install it

Postby xlepws » 2020-03-16 20:11

Head_on_a_Stick wrote:@OP: please post the output of
Code: Select all
LC_ALL=C apt policy
Hi, here's the output
Code: Select all
root@debian02:/home/manu# LC_ALL=C apt policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages
     release v=1.0,o=Google LLC,a=stable,n=stable,l=Google,c=main,b=amd64
     origin dl.google.com
 500 https://dl.winehq.org/wine-builds/debian sid/main i386 Packages
     release v=11.0,o=dl.winehq.org,a=unstable,n=sid,l=winehq,c=main,b=i386
     origin dl.winehq.org
 500 https://dl.winehq.org/wine-builds/debian sid/main amd64 Packages
     release v=11.0,o=dl.winehq.org,a=unstable,n=sid,l=winehq,c=main,b=amd64
     origin dl.winehq.org
 500 http://ftp.it.debian.org/debian sid/non-free i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free,b=i386
     origin ftp.it.debian.org
 500 http://ftp.it.debian.org/debian sid/non-free amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=non-free,b=amd64
     origin ftp.it.debian.org
 500 http://ftp.it.debian.org/debian sid/contrib i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib,b=i386
     origin ftp.it.debian.org
 500 http://ftp.it.debian.org/debian sid/contrib amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=contrib,b=amd64
     origin ftp.it.debian.org
 500 http://ftp.it.debian.org/debian sid/main i386 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main,b=i386
     origin ftp.it.debian.org
 500 http://ftp.it.debian.org/debian sid/main amd64 Packages
     release o=Debian,a=unstable,n=sid,l=Debian,c=main,b=amd64
     origin ftp.it.debian.org
Pinned packages:
root@debian02:/home/manu
xlepws
 
Posts: 21
Joined: 2020-03-16 14:09

Re: Wine: can't install it

Postby andre@home » 2020-03-19 09:12

For Debian 10.
Some months ago I wanted to test if my Windows genealogy program was working under Wine...
So I thought: Lets approach it by first trying a popular program as Notepad++ to get that working under Wine.

I remember to follow this path.
https://superuser.com/questions/221783/ ... untu-linux
The complete Wine environment was installed following exactly the input written there but also following the messages on screen.

After that, my Windows genealogy program was very easy to install.
My work was done in a VM, but I think it should work in a "normal" setup too.
Give it a thought.
andre@home
 
Posts: 356
Joined: 2011-10-02 08:00


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable