X Server won't start

Everything about X, Gnome, KDE, ... and everything running on it

X Server won't start

Postby walterc » 2020-05-31 15:47

Hi. I'm new here. I was a SUSE enthusiast for many years (since 2002). Last year I bought a DELL XPS8930 with an NVIDIA graphics processor (GeForce RTX 2060). There's also an Intel display controller. Here's some stuff from "lspci":

Code: Select all
00:02.0 Display controller: Intel Corporation Device 3e98 (rev 02)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1f08 (rev a1)

I should also say something about my monitor -- it's an HP23bw, 1920 x 1080 @60 Hz, connected via DVI.

Since I now have a lot of disk space, I decided to try several different flavors of Linux. I had a little trouble getting the graphical desktops to work properly under Debian and also under openSUSE, but eventually I got the kinks worked out (I had to install the proprietary NVIDIA driver), and for a while I was as happy as a clam. Until about a month ago, when DELL pushed some new video firmware onto my machine. Now my Ubuntu-based systems work just fine, but I can't get the gui desktop to work on Debian (I've tried several different things, but nothing seems to work), and the SUSE installation .isos won't even start in graphics mode ... they get as far as "Starting UDEV", and then they die.

This morning I started with a clean install of debian-live-10.4.0-amd64-kde+nonfree.iso. The only installation errors I ran into involved two missing firmware files called ath10k/pre-cal-pci_0000.03:00.0.bin and ath10k/cal-pci_0000.03:00.0.bin. I'm pretty sure these are for wi-fi; since I have a direct ethernet connection to the internet, I don't much care about wi-fi on this machine.

So I ran the install and let it boot from /SDA14. Nothing. Totally blank screen. I booted it up again in recovery mode -- I should note that I have to add "nomodeset" to the "linux" command to get recovery mode to boot properly (by properly, I mean so I can see the messages on my monitor). Everything looked pretty normal, so I logged in as root when prompted and saved some files on a USB stick, then told the system to continue. It tried, then came right back to the command prompt. So I issued the command "startx", to see if I could start the display manager. The X server failed. Here are the relevant portions of the Xorg.0.log:

Code: Select all
[   640.256] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   640.263] (II) Module fbdevhw: vendor="X.Org Foundation"
[   640.263]    compiled for 1.20.4, module version = 0.0.2
[   640.263]    ABI class: X.Org Video Driver, version 24.0
[   640.263] (EE) Unable to find a valid framebuffer device
[   640.263] (WW) Falling back to old probe method for fbdev
[   640.263] (II) Loading sub module "fbdevhw"
[   640.263] (II) LoadModule: "fbdevhw"
[   640.263] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   640.264] (II) Module fbdevhw: vendor="X.Org Foundation"
[   640.264]    compiled for 1.20.4, module version = 0.0.2
[   640.264]    ABI class: X.Org Video Driver, version 24.0
[   640.264] (II) FBDEV(2): using default device
[   640.264] (EE) Screen 0 deleted because of no matching config section.
[   640.264] (II) UnloadModule: "modesetting"
[   640.264] (EE) Screen 0 deleted because of no matching config section.
[   640.264] (II) UnloadModule: "fbdev"
[   640.264] (II) UnloadSubModule: "fbdevhw"
[   640.264] (EE)
Fatal server error:
[   640.264] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[   640.264] (EE)
[   640.264] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   640.264] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   640.264] (EE)
[   640.268] (EE) Server terminated with error (1). Closing log file.

I looked at Xorg.0.log.old, and exactly the same thing happened the first time I booted the newly installed system.

I really don't know very much about the X server, except that it usually works. Will somebody please give me a hint? I suppose I need to fix a configuration file somewhere, but I'm not sure where to start. Thanks!
User avatar
walterc
 
Posts: 4
Joined: 2020-05-29 15:13
Location: Canyon Lake, Texas

Re: X Server won't start

Postby CwF » 2020-05-31 16:11

Code: Select all
Fatal server error:
[   640.264] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices


You can specify the bus address in a hint file. If you create such a file it will be read on next logon. So there is a sequence to move the active display among available gpu's. The first used will be the boot declared, any other needs the bus id. If you change the bus id in the hint file and log off, your greeter should appear on the gpu you just defined...now if you change it to another gpu id and log off, the greeter, or cli, will appear on that other gpu.

Your Intel seems to be the boot gpu.

Dynamically moving the active display to multiple gpu's works fine for me and the caveats are no other xorg file and only xorg drivers (nouveau).
CwF
 
Posts: 696
Joined: 2018-06-20 15:16

Re: X Server won't start

Postby Head_on_a_Stick » 2020-05-31 16:49

walterc wrote:I have to add "nomodeset" to the "linux" command to get recovery mode to boot properly

The Intel card needs kernel mode setting enabled so remove that parameter. You can set a larger console font with
Code: Select all
# apt install console-setup
# dpkg-reconfigure console-setup

EDIT: and you will need the firmware-misc-nonfree package for full graphics performance with that generation Intel. The intel-microcode package would probably also be a good idea.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12194
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: X Server won't start

Postby walterc » 2020-06-01 16:09

CwF wrote:
Code: Select all
Fatal server error:
[   640.264] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices

You can specify the bus address in a hint file. ...


Where can I read about this hint file? I tried searching the internet, but couldn't find anything about it. Thanks!
User avatar
walterc
 
Posts: 4
Joined: 2020-05-29 15:13
Location: Canyon Lake, Texas

Re: X Server won't start

Postby CwF » 2020-06-01 17:18

I call it a hint file, a minimalist declaration of basic parameters and switches that could be found in a full xorg.conf file. Generally you need no rigid xorg.conf, unless automagical enumeration fails.

Create this file somewhere in /etc/X11 as some prefer or as I do, either location is checked when X starts.
Code: Select all
usr/share/X11/xorg.conf.d/52-active_gpu.conf:

Section “Screen”
    Identifier  “Default Screen”
    Device      “Card0”
EndSection

Section "Device"
   Identifier  "Card0"
   Driver      "nouveau"
   BusID       "PCI:3:0:0"
EndSection

Pretend there is an amd active, the above would swap to the 750Ti as seen as available here, usually the attached sound device isn't an issue...After the file is edited it is ignored until you reinitialize X through a log off/on cycle or a restart. Extra credit if you can unbind the FX1500 from vfio, rebind to nouveau, and then switch X to that display, yes, it's doable!
Code: Select all
# lspci -nnk -d 10de:
03:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2)
   Subsystem: Gigabyte Technology Co., Ltd GM107 [GeForce GTX 750 Ti] [1458:36ca]
   Kernel driver in use: nouveau
   Kernel modules: nouveau
03:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:0fbc] (rev a1)
   Subsystem: Gigabyte Technology Co., Ltd Device [1458:36ca]
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd_hda_intel
04:00.0 VGA compatible controller [0300]: NVIDIA Corporation G71GL [Quadro FX 1500] [10de:029e] (rev a1)
   Subsystem: NVIDIA Corporation G71GL [Quadro FX 1500] [10de:032c]
   Kernel driver in use: vfio-pci
   Kernel modules: nouveau


Again, not at all verified with nvidia, just nouveau and the other open drivers.
CwF
 
Posts: 696
Joined: 2018-06-20 15:16

Re: X Server won't start

Postby walterc » 2020-06-01 18:13

Head_on_a_Stick wrote:
walterc wrote:I have to add "nomodeset" to the "linux" command to get recovery mode to boot properly

The Intel card needs kernel mode setting enabled so remove that parameter.

Perhaps I was not clear enough. When I boot the system without the "nomodeset" flag, I see a few lines of system output flash by. Then the screen goes completely dark, and I never see another thing appear there until I force the system to power down so I can reboot.

I thought the problem might be related to the KDE desktop manager, So I created another partition and installed a new system from the debian-live-10.4.0-amd64-kde+nonfree.iso file. This time I had the presence of mind to save the log files from the first boot. Here's what I spot in "syslog":
Code: Select all
Jun  1 07:44:52 debian systemd[788]: Reached target Default.
Jun  1 07:44:52 debian systemd[788]: Startup finished in 526ms.
Jun  1 07:44:52 debian systemd[1]: Started User Manager for UID 117.
Jun  1 07:44:52 debian systemd[1]: Started Session c1 of user Debian-gdm.
Jun  1 07:44:52 debian nm-dispatcher: req:4 'connectivity-change': start running ordered scripts...
Jun  1 07:44:52 debian systemd[788]: Started D-Bus User Message Bus.
Jun  1 07:44:52 debian ModemManager[606]: <info>  Couldn't check support for device '/sys/devices/pci0000:00/0000:00:1c.3/0000:04:00.0': not supported by any plugin
Jun  1 07:44:54 debian systemd[1]: Started Disk Manager.
Jun  1 07:44:54 debian udisksd[599]: Acquired the name org.freedesktop.UDisks2 on the system message bus
Jun  1 07:44:55 debian gnome-shell[859]: Failed to create backend: Could not find a primary drm kms device
Jun  1 07:44:55 debian gnome-session[836]: gnome-session-binary[836]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Jun  1 07:44:55 debian gnome-session-binary[836]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Jun  1 07:44:55 debian gnome-session-binary[836]: Unrecoverable failure in required component org.gnome.Shell.desktop

So the system can't recognize the Intel graphics chips on the mother board, and it can't configure my NVIDIA card correctly, either. At least, that's what I think this says.

Here's some more information pointing in that direction. I compared the output from the Debian X-server to the corresponding output from my "Neon" (ubuntu-based) X-server:

Code: Select all
[   106.686] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   106.686] (II) FBDEV: driver for framebuffer: fbdev
[   106.686] (II) VESA: driver for VESA chipsets: vesa
[   106.687] (II) [drm] nouveau interface version: 1.3.1
[   106.687] (EE) Unknown chipset: NV166
[   106.687] (II) [drm] nouveau interface version: 1.3.1
[   106.687] (EE) Unknown chipset: NV166
[   106.687] (II) [drm] nouveau interface version: 1.3.1
[   106.687] (EE) Unknown chipset: NV166
[   106.688] (II) [drm] nouveau interface version: 1.3.1
[   106.688] (EE) Unknown chipset: NV166
[   106.688] (II) modeset(0): using drv /dev/dri/card1
[   106.688] (WW) Falling back to old probe method for fbdev
[   106.688] (II) Loading sub module "fbdevhw"
[   106.688] (II) LoadModule: "fbdevhw"
[   106.688] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   106.689] (II) Module fbdevhw: vendor="X.Org Foundation"
[   106.689]    compiled for 1.19.6, module version = 0.0.2
[   106.689]    ABI class: X.Org Video Driver, version 23.0
[   106.689] (WW) Falling back to old probe method for vesa
[   106.689] (II) modeset(G0): using drv /dev/dri/card0
[   106.689] (II) modeset(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[   106.689] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[   106.689] (==) modeset(0): RGB weight 888
[   106.689] (==) modeset(0): Default visual is TrueColor

Above from Neon system. That one boots up OK
****

[   640.126] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   640.126] (II) FBDEV: driver for framebuffer: fbdev
[   640.126] (II) VESA: driver for VESA chipsets: vesa
[   640.256] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
[   640.256] (EE) open /dev/dri/card0: No such file or directory
[   640.256] (WW) Falling back to old probe method for modesetting
[   640.256] (EE) open /dev/dri/card0: No such file or directory
[   640.256] (II) Loading sub module "fbdevhw"
[   640.256] (II) LoadModule: "fbdevhw"
[   640.256] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   640.263] (II) Module fbdevhw: vendor="X.Org Foundation"
[   640.263]    compiled for 1.20.4, module version = 0.0.2
[   640.263]    ABI class: X.Org Video Driver, version 24.0
[   640.263] (EE) Unable to find a valid framebuffer device
[   640.263] (WW) Falling back to old probe method for fbdev
[   640.263] (II) Loading sub module "fbdevhw"
[   640.263] (II) LoadModule: "fbdevhw"
[   640.263] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   640.264] (II) Module fbdevhw: vendor="X.Org Foundation"
[   640.264]    compiled for 1.20.4, module version = 0.0.2
[   640.264]    ABI class: X.Org Video Driver, version 24.0
[   640.264] (II) FBDEV(2): using default device
[   640.264] (EE) Screen 0 deleted because of no matching config section.
[   640.264] (II) UnloadModule: "modesetting"
[   640.264] (EE) Screen 0 deleted because of no matching config section.
[   640.264] (II) UnloadModule: "fbdev"
[   640.264] (II) UnloadSubModule: "fbdevhw"
[   640.264] (EE)
Fatal server error:
[   640.264] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[   640.264] (EE)
[   640.264] (EE)

Above is from booting Debian in recovery mode without specifying nomodeset

What I notice here is that Debian apparently doesn't even try to configure my NVIDIA card, because the messages about the nouveau driver are missing. And for some reason it couldn't recognize the Intel chips on the motherboard, either. So I end up with no graphics.

Head_on_a_Stick wrote:You can set a larger console font with
Code: Select all
# apt install console-setup
# dpkg-reconfigure console-setup

Well, that's sort of cute. It doesn't help me with my problem, but it's good to know. Thank you.

Head_on_a_Stick wrote: and you will need the firmware-misc-nonfree package for full graphics performance with that generation Intel. The intel-microcode package would probably also be a good idea.

I'll try installing both those packages in both versions (kde and gnome) and report back. That's probably the problem ... my old Debian system from 2019 was working OK until DELL pushed some new firmware onto my machine. Thanks again.
User avatar
walterc
 
Posts: 4
Joined: 2020-05-29 15:13
Location: Canyon Lake, Texas

Re: X Server won't start

Postby CwF » 2020-06-01 18:35

walterc wrote: Debian apparently doesn't even try to configure my NVIDIA card,


Exactly, a 'feature' people like me prefer. The method I laid out is the missing info, you define the right ID. Your card does require the firmware listed by hoas. As I mentioned, you need to have nouveau installed for my help to work. I do think your boot defined gpu is the intel = hook up a display to it you may have a cli there, Ctrl+Alt+F1 if you see a blinking cursor on a blank screen, login, and fix it!
I can't offer anything else, especially if you have nvidia installed, and an xorg.conf, remove both I say! After that works you can then venture into nvidia drivers. I don't bother.

ADD: Do you get a post screen on the nvidia output? If not, visit your bios first.
CwF
 
Posts: 696
Joined: 2018-06-20 15:16

Re: X Server won't start

Postby walterc » 2020-06-03 20:33

Thanks for trying to help. I did install all the suggested firmware, and the microcode. It didn't help. The nouveau driver was still as dead as a door nail.

When I installed Debian 10.0 for the first time on the same machine, I got it to go pretty easily by using the NVIDIA driver from the manufacturer. I tried that on the current version of "Buster" (10.4, I think), and got sort of mixed results. I could get the graphical network to go by booting up in recovery mode and logging in as root, then saying "NetworkManager" followed by "startx". That brought up my graphical desktop, with my internet connection operational. But that's less than satisfactory, and I'm not such a Debian die hard that I want to mess with it any longer.

Thanks again. Maybe I'll try to install Debian in a year or so, when my hardware is getting a little longer in the tooth. Just FYI, I installed MXLinux over top of Debian this morning, and it all went as smooth as silk. So the problem has to be with some of the "non-free" software / firmware.
User avatar
walterc
 
Posts: 4
Joined: 2020-05-29 15:13
Location: Canyon Lake, Texas


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable
cron