Select application for print preview Debian Buster + KDE

Everything about X, Gnome, KDE, ... and everything running on it

Select application for print preview Debian Buster + KDE

Postby jlinkels » 2020-06-08 18:20

When I select File -> Print in Dia or Inkscape I am presented with a print dialog which offers a print preview option. Whenever I select this, a temporary PDF is created, which is then opened.

Unfortunately this PDF is opened with Gimp. That is obviously nonsense. I want Okular to open that PDF.

I can't find where to set this. In System Settings -> Applications I have set to use Okular to open PDFs. From the file (Okular, Delfins) manager this is the default application.

Many other applications (LibreOffice, Chrome, Firefox, Konqueror) seem to come with a different Print dialog. It is just Dia and Inkscape which have this dialog. Maybe more, but I have not found them.

I can't even find which application (or if an application runs) when I open this dialog. The only thing is I do not want to open Gimp because it is useless to view the PDF. And especially in these two application I badly need a preview.

In earlier Debian versions this has never been a problem. Once Okular was set as default application Print Preview also opened in Okular.

jlinkels

Edit: I have renamed the Gimp executable so it could not be called anymore. Now Print Preview opens Okular. But it reverts to the incorrect situation if I reverse the renaming. So I am trying to find some setting where Gimp is mentioned as first alternative and Okular as second. In all of KDE's settings I am not able to find it. BTW it looks like Dia and Inkscape are GTK applications. Is that correct?
jlinkels
 
Posts: 40
Joined: 2008-07-12 14:34

[SOLVED] Select application for print preview Debian Buster+

Postby jlinkels » 2020-06-09 00:08

OK, it is solved, but it was a tough one.

The print application is GTK all right. By default is uses Evince, but if that is not installed it falls back to Gimp.

The configure the correct application, add this line in $HOME/.gtkrc-2.0:
Code: Select all
gtk-print-preview-command="/usr/bin/okular %f"


Alternatively if you use GTK 3,0 (now or inthe future, add the same line to $HOME/.gtkrc-3.0

Alternatively, you might want to use the system default for PDFs, then add this line instead:
Code: Select all
gtk-print-preview-command="/usr/bin/xdg-open %f"

Which the more proper way.

For non-Debian systems, the location of the config files might be different.

jlinkels
jlinkels
 
Posts: 40
Joined: 2008-07-12 14:34


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable