Screen is randomly turning off after reboot

Everything about X, Gnome, KDE, ... and everything running on it

Re: Screen is randomly turning off after reboot

Postby Deb-fan » 2020-07-25 21:27

^ LMAO, ... Was under the wrong impression, thought OP's whole system was doing that (off/on) bad ram and psu's are associated with that kinda crap. Apparently it's just his monitor and I'm boggled as to possible causes/cures for it. Outside of the usual suspects, vidcard, driver etc. One reason I've always stuck with open source graphics drivers was to avoid tech nightmares like these. Ah Op quit responding a long time ago, so looking like the mystery will never be solved, dammit! Wanted to know what's going on here, in case ever come across it in the future.

Op? What's the situation now, what all have you tried ... etc? Op? Respond dammit! Op !?! :)

PS, really do want to maintain that weird thought about checking stuff like a power strip, they do go bad and could cause all manner of odd tech problems. Likely to be the absolute last thing anyone would consider or never even check at all.

Ps2, How insidious would it be if it turned out the cord or port Op is using to connect this problem system to that monitor has a short in it? We could all be standing there with physical access to the damn thing and would probably never get around to checking that.
Most powerful FREE tech-support tool on the planet * HERE. *
Deb-fan
 
Posts: 1008
Joined: 2012-08-14 12:27

Re: Screen is randomly turning off after reboot

Postby cuckooflew » 2020-07-27 15:44

kerryhall wrote:I noticed in nvidia-settings, that the refresh rate constantly returns to "auto". I used to have it on 60hz, which worked great until I rebooted.

Now when I try and set it to 60hz, it doesn't "stick" and instead keeps returning to "auto". I think this could be part of the problem.

Also when I change settings to "advanced" I see two 60hz settings, 60hz (1) and 60 hz (2)....this seems very very wrong to me and perhaps the source of the issue.

Also version info:

NVIDIA Driver Version: 418.113
Server Version Number: 11.0
Server Vendor Version: 1.20.4

The correct quote :mrgreen:
Please Read What we expect you have already Done
Search Engines know a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
and
Just say NO to help vampires!
cuckooflew
 
Posts: 681
Joined: 2018-05-10 19:34
Location: Some where out west

Re: Screen is randomly turning off after reboot

Postby kerryhall » 2021-02-18 21:54

Apologies for the delay, but after months of mucking around with nvidia-settings and different hdmi cables, I had no additional data.

Until today! I think I figured out what is going on here.

After that reboot, there now appears to be a mismatch in color depth between my monitor and xorg.

My monitor normally has the "UHD color" setting enabled. (Which is apparently the setting for 30 bit color)

If this is enabled, and xorg is set to 24 bit color, and my resolution is set to 4k, and refresh rate to 60 hz, I get display artifacts and monitor power offs (when dragging a window to a specific region of the screen).

With xorg set to 24 bit color and "UHD color" disabled, 4k@60hz, no issues whatsoever.

With xorg set to 30 bit color, "UHD color" enabled, 4k@60hz, also no issues with the display! I am assuming that xorg was originally set to 30 bit color before the reboot, and something got mangled. I knew it wasn't a hardware failure with my video card, as the issue started immediately after rebooting, after being stable for months.

However, 30 bit color no longer seems to work. With xorg set to use 30 bit color, the window manager won't start after logging in. My window manager is fluxbox, and login manager is lightdm.

Is there any way I can get 30 bit color working? Colors all look off now after disabling "UHD color" in my monitor, especially red text on a black background, which looks very "smeared". At least 60hz works now!

Or if it's not possible to get 30 bit color working, maybe there is some sort of workaround for getting red text to show up correctly on a black background?
kerryhall
 
Posts: 210
Joined: 2008-08-19 11:06

Previous

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable