No cut and past in terminal

Everything about X, Gnome, KDE, ... and everything running on it

No cut and past in terminal

Postby Haines » 2020-06-30 20:11

I'm running fluxbox without a DE. I was using cut and past in an mlterm terminal last evening, but this morning it no longer works. I normally do select with a mouse sweep and a past with middle button.

The problem for both root and user. The problem also with eterm, but not with GUI applications such as emacs.

Oddly I cannot start xterm. A process starts, but nothing shows up. I don't know if this related to the cut and past problem. In any case I did # dpkg-reconfigure server-xorg. This may be an old problem
until now unnoticed, because I never use xterm. No (EE) errors in /var/log/Xorg.0.log. Doing # xsel -cp && xsel -cs && xsel -cb did not help.
-
The problem affects root as well as user. I can select text in a terminal and do Ctl-Shift-v. Then when I start xclipboard the copyed text shows up. However I cannot past it into a terminal or into a GUI application.
Haines
 
Posts: 6
Joined: 2014-07-29 01:57

Re: No cut and past in terminal

Postby stevepusser » 2020-07-01 03:00

Almost impossible to diagnose. Maybe you could install inxi and let us look at the result of "inxi -r" in case it's bad repos. You can redirect the output to a text file, since you can get it out of the terminal

Code: Select all
inxi -r > output.txt
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kodi 18.7, Strawberry 0.6.12, Pale Moon 28.10.0, Xscreensaver 5.44, Krita 4.3.0, Foliate 2.4.0
User avatar
stevepusser
 
Posts: 11786
Joined: 2009-10-06 05:53

Re: No cut and past in terminal

Postby Head_on_a_Stick » 2020-07-01 18:57

Haines wrote:Oddly I cannot start xterm. A process starts, but nothing shows up.

What if you try to start xterm from another terminal? Does that show any error messages?

Haines wrote:No (EE) errors in /var/log/Xorg.0.log.

How about ~/.xsession-errors?

Haines wrote:when I start xclipboard

Does the PRIMARY start working again if you kill xclipboard?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12150
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable