Where ffmpeg/mpv mantained for stretch?

Everything about X, Gnome, KDE, ... and everything running on it

Where ffmpeg/mpv mantained for stretch?

Postby bester69 » 2020-07-20 14:25

Hi,

Ive seen stretch ffmpeg codecs are starting to be outdated.. where can we keep getting video codecs stretch updated??

I was using mpv0.28...with libavcodec58 from Steve repositories..but I have had to downgrade to mpv027 and point to debian-multimedia codecs in order to get newer codecs availability in a build of libavcodec57.. unless I thing thats what ive achieved, becouse some youtube videso were not playing, and once ive move it to debian-multimedia repository, issues seems to be gone...

So, my question, do we have to use debian-multimedia for stretch to keep updated codecs?

by the way, very interesting!!, kodi18 is available for stretch in theses respositories
bester69 wrote:You wont change my mind when I know Im right, Im not an ...
User avatar
bester69
 
Posts: 1644
Joined: 2015-04-02 13:15

Re: Where ffmpeg/mpv mantained for stretch?

Postby Head_on_a_Stick » 2020-07-20 16:45

bester69 wrote:kodi18 is available for stretch in theses respositories

Image
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12316
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Where ffmpeg/mpv mantained for stretch?

Postby stevepusser » 2020-07-20 23:47

In the MX 17/18 repositories. :lol:

I'm not really sure what you mean about libavcodec58 having older codecs than libavcodec57--can you explain? You can have them both installed at the same time, you know, unless you mix deb-multimedia into your brew. I may had had that mpv-0.28 building and using its own internal ffmpeg, though...I did that at one time.

I do have ffmpeg-4.3 in the MX 17/18 test repo.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0, QMPlay2 20.07.04, Pale Moon 28.12.0, KeepassXC 2.6.0, Arqiver 0.6.0+git, Foliate 2.4.2
User avatar
stevepusser
 
Posts: 11891
Joined: 2009-10-06 05:53

Re: Where ffmpeg/mpv mantained for stretch?

Postby bester69 » 2020-07-21 00:43

stevepusser wrote:In the MX 17/18 repositories. :lol:

I'm not really sure what you mean about libavcodec58 having older codecs than libavcodec57--can you explain? You can have them both installed at the same time, you know, unless you mix deb-multimedia into your brew. I may had had that mpv-0.28 building and using its own internal ffmpeg, though...I did that at one time.

I do have ffmpeg-4.3 in the MX 17/18 test repo.

Hi Steve, its all very confusing to me.. I just know I prefer to use libavcodec57, (but last build of this branch codecs).. cos libavcodec58 didnt work very well in my old hardware or mpv > 0.28...perhaps the problem were the mpv version .. the mpv version i was using (mpv0.28), was build against libavcodec58 embeded.. and was working very well, until youtube has started to update codecs or bringht new ones..

Ive installed debian-multimedia mpv0.27, this is what i've now and according to my tests.. no more issued with youtube movies..by the way, Ive both libavcodec installed and mixed repositories only for codecs... :roll: .. thought i think no app is using libavcodec58, perhaps kodi17, i dont know
Image

In the repos I have you dropped mpv0.28 and is only mpv0.29.. I would like to keep using a previous version to mpv0.29 ( 28 or 27 version) with codecs always updated.. can you provide me a source repostory for stretch, if possible?, if not possible I will use debian-multimedia as it seems to be working with mpv0.27

Thanks a lot, Steve. :roll:
bester69 wrote:You wont change my mind when I know Im right, Im not an ...
User avatar
bester69
 
Posts: 1644
Joined: 2015-04-02 13:15

Re: Where ffmpeg/mpv mantained for stretch?

Postby stevepusser » 2020-07-21 03:39

The YouTube problem may because it uses youtube-dl to access the videos, and Debian has old versions of that in Stretch and Buster, while deb-multimedia does keep it current--so if you updated it from there, that may be the fix.

Mpv >= 0.28 requires at libavcodec58, either internally or as a system library. Way back when I did mpv 0.28, Debian didn't even have it in any repo, so I did the internal build version.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0, QMPlay2 20.07.04, Pale Moon 28.12.0, KeepassXC 2.6.0, Arqiver 0.6.0+git, Foliate 2.4.2
User avatar
stevepusser
 
Posts: 11891
Joined: 2009-10-06 05:53

Re: Where ffmpeg/mpv mantained for stretch?

Postby bester69 » 2020-07-21 10:57

stevepusser wrote:The YouTube problem may because it uses youtube-dl to access the videos, and Debian has old versions of that in Stretch and Buster, while deb-multimedia does keep it current--so if you updated it from there, that may be the fix.

Mpv >= 0.28 requires at libavcodec58, either internally or as a system library. Way back when I did mpv 0.28, Debian didn't even have it in any repo, so I did the internal build version.


As for youtube-dl, im updating throught snap repository:
youtube-dl --version
2020.05.29
the good about mpv Internal version, is that allowed me to keep several mpv versions together and i can switch among them with a script..

smpv.sh
Code: Select all
#!/bin/bash
mpdflag=/home/user/.mpd/mpdflag.txt
touch $mpdflag
A=$(cat $mpdflag)

if [  -z  $A ]
 then
A=27
 fi
 
if [ ! -z  $1 ]
 then
A=$1
 fi

 if [ $A -eq 27 ]
then
sudo ln -sf /usr/bin/mpv27 /usr/bin/mpv
sudo ln -sf /etc/mpv/encoding-profiles.conf.27 /etc/mpv/encoding-profiles.conf
echo "27" > $mpdflag
fi

 
 
if [ $A -eq 28 ]
then
sudo ln -sf /usr/bin/mpv28 /usr/bin/mpv
sudo ln -sf /etc/mpv/encoding-profiles.conf.28 /etc/mpv/encoding-profiles.conf
echo "28" > $mpdflag
fi

if [ $A -eq 29 ]
then
sudo ln -sf /usr/bin/mpv29 /usr/bin/mpv
sudo ln -sf /etc/mpv/encoding-profiles.conf.29 /etc/mpv/encoding-profiles.conf
echo "29" > $mpdflag
fi

mpv --version



My doubt is.. do an updated previus version of ffmpeg come up with latest codecs??..
for example... can ffmpeg 3.4.9 come up with newer codec than a bigger version and outdated one such as ffmpeg 4.1.4.. or newer codecs, only comes with bigger versions of ffmpeg?

in the MX 17/18 you have ffmpeg 4.3 and I guess you will have there mpv29... that mpv version doesnt work very well in my old laptop.. I would have to build mpv028.. and that, everytime you updated ffmpeg..so I thing I will stay with debia-multimedia ( mpv027 + ffmpeg 3.4.X) to stay updated without having to compile anytime.


thanks.
bester69 wrote:You wont change my mind when I know Im right, Im not an ...
User avatar
bester69
 
Posts: 1644
Joined: 2015-04-02 13:15

Re: Where ffmpeg/mpv mantained for stretch?

Postby bester69 » 2020-07-21 12:38

Hi Steve,
Repos ..you told me, are these?..
deb http://mxrepo.com/mx/repo/ stretch main non-free
deb http://mxrepo.com/mx/testrepo/ stretch test

I saw, there are ffmpeg 4.3 and a lot of newer stretch version apps (gimp, dolphin, okular..).. very interesting . :o
bester69 wrote:You wont change my mind when I know Im right, Im not an ...
User avatar
bester69
 
Posts: 1644
Joined: 2015-04-02 13:15

Re: Where ffmpeg/mpv mantained for stretch?

Postby stevepusser » 2020-07-22 03:00

MX17 are the Stretch-based versions. MX19 are the Buster-based packages. You could always try an MX 18 (still stretch) or MX 19 live USB or DVD to see if you still see the slowness there, since MX has been noted for its speed by many reviewers.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0, QMPlay2 20.07.04, Pale Moon 28.12.0, KeepassXC 2.6.0, Arqiver 0.6.0+git, Foliate 2.4.2
User avatar
stevepusser
 
Posts: 11891
Joined: 2009-10-06 05:53


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable