Gnome shell high CPU usage with Wayland

Everything about X, Gnome, KDE, ... and everything running on it

Gnome shell high CPU usage with Wayland

Postby diplatis » 2020-07-28 13:52

Hi,

I'm using Debian Buster with linux kernel 5.6.14-2~bpo10+1 from backports on my Lenovo ThinkPad X1 Carbon 8th(Intel(R) Core(TM) i5-10310U) gen on a fresh install. With Wayland enabled gnome-shell uses all almost all CPU available, especially when there are open windows and mouse movement. When I disable Wayland everything runs smoothly.
Any suggestions? I'm a newbie, so please, as more detailed as possible.
Thank you very much.
diplatis
 
Posts: 2
Joined: 2020-07-28 13:44

Re: Gnome shell high CPU usage with Wayland

Postby Head_on_a_Stick » 2020-07-28 16:15

Install the firmware-misc-nonfree .deb package from Debian sid. Do not add the sid repositories, they will break your system.

http://deb.debian.org/debian/pool/non-f ... -1_all.deb
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12316
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Gnome shell high CPU usage with Wayland

Postby diplatis » 2020-07-29 06:30

Thanks for the reply.
I downloaded the deb package from the given link and installed, enabled Wayland, but still the same outcome.
diplatis
 
Posts: 2
Joined: 2020-07-28 13:44

Re: Gnome shell high CPU usage with Wayland

Postby oswaldkelso » 2020-07-29 15:23

I've installed over well 40 Desktop environments and window managers and Gnome is by far the heaviest and hence slowest of them all. It is the only one of the 40+ that had me screaming at my PC. Why Debian "The universal operating system" chooses to stick it at the top of the list is beyond me. New users install it because they know no better even though they may be on all-sorts of hardware. As well as being fat and slow it also has a interface that make windows 95 look slick. Pick another Desktop environment and be happy. Xfce is a safe place to get your feet wet and learn.
Ash init durbatulûk, ash init gimbatul,
Ash init thrakatulûk agh burzum-ishi krimpatul.
User avatar
oswaldkelso
 
Posts: 1255
Joined: 2005-07-26 23:20
Location: UK

Re: Gnome shell high CPU usage with Wayland

Postby Head_on_a_Stick » 2020-07-29 19:03

oswaldkelso wrote:I've installed over well 40 Desktop environments and window managers and Gnome is by far the heaviest and hence slowest of them all.

The OP has a tenth-generation Intel CPU and that should run GNOME just fine. My 10-year-old X201 certainly has no problems with it. GNOME uses hardware acceleration for moving the windows around so it is potentially faster than Xfce if the graphics chip is half-decent.

And anyway the OP doesn't have the problem if they use the X session rather than Wayland.

@OP: have you checked the systemd journal for any relevant errors?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12316
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Gnome shell high CPU usage with Wayland

Postby oswaldkelso » 2020-07-29 20:53

Requiring hardware acceleration for moving the windows around is a feature! One that usually requires non-free firmware that seems to fly in the face of both Debian's and Gnomes espoused aims? Bonkers ...... new thread req I think
Ash init durbatulûk, ash init gimbatul,
Ash init thrakatulûk agh burzum-ishi krimpatul.
User avatar
oswaldkelso
 
Posts: 1255
Joined: 2005-07-26 23:20
Location: UK

Re: Gnome shell high CPU usage with Wayland

Postby m798 » 2020-08-05 16:33

I have the exact same issue, sorry for hijacking :). I'm also new to using Linux and using a relatively recent Intel Core i3 10100 with UHD 630 iGPU. Gnome is very choppy in Wayland, a bit smoother in X11, but still using software rendering. I'm using kernel 5.6, originally installed using openmediavault installation image. I installed Gnome using the tasksel command. I tried to install the above deb file, but no luck. glxinfo | grep OpenGL" gives:

Code: Select all
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 7.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.3.6
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.1 Mesa 18.3.6
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.3.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:


Maybe I missed something, or I broke something trying to get this to work?

Edit: I found this among the systemd journal:
Code: Select all
org.gnome.Shell.desktop[3983]: pci id for fd 11: 8086:9bc8, driver (null)
org.gnome.Shell.desktop[3983]: can't load /usr/lib/x86_64-linux-gnu/spa/support/libspa-support.so: /usr/lib/x86_64-li
org.gnome.Shell.desktop[3983]: glamor: 'wl_drm' not supported
org.gnome.Shell.desktop[3983]: Missing Wayland requirements for glamor GBM backend
org.gnome.Shell.desktop[3983]: Failed to initialize glamor, falling back to sw
gnome-shell[3983]: Failed to launch ibus-daemon: Failed to execute child process “ibus-daemon” (No such file or direc


And a bit later, when loading the session:
Code: Select all
(--) PCI:*(0@0:2:0) 8086:9bc8:1458:d000 rev 3, Mem @ 0xb0000000/16777216, 0xa00000
 (II) "glx" will be loaded. This was enabled by default and also specified in the c
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
         compiled for 1.20.4, module version = 1.0.0
        ABI class: X.Org Server Extension, version 10.0
(II) LoadModule: "modesetting"
(II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
(II) Module modesetting: vendor="X.Org Foundation"
         compiled for 1.20.4, module version = 1.20.4
         Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 24.0
 (II) modesetting: Driver for Modesetting Kernel Drivers: kms
(II) modeset(0): using drv /dev/dri/card0
(WW) Falling back to old probe method for modesetting
(WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
 (==) modeset(0): Depth 24, (==) framebuffer bpp 32
 (==) modeset(0): RGB weight 888
 (==) modeset(0): Default visual is TrueColor
 (II) Loading sub module "glamoregl"
(II) LoadModule: "glamoregl"
 (II) Loading /usr/lib/xorg/modules/libglamoregl.so
 (II) Module glamoregl: vendor="X.Org Foundation"
         compiled for 1.20.4, module version = 1.0.1
         ABI class: X.Org ANSI C Emulation, version 0.4
 pci id for fd 12: 8086:9bc8, driver (null)
(II) modeset(0): Refusing to try glamor on llvmpipe
 (EE) modeset(0): glamor initialization failed
(II) modeset(0): ShadowFB: preferred YES, enabled YES
(II) modeset(0): Double-buffered shadow updates: off
broken atomic modeset userspace detected, disabling atomic
m798
 
Posts: 8
Joined: 2020-08-05 16:17
Location: Netherlands

Re: Gnome shell high CPU usage with Wayland

Postby Head_on_a_Stick » 2020-08-05 19:17

^ Check
Code: Select all
# dmesg | grep firmware

And confirm which firmware packages you have installed.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12316
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Gnome shell high CPU usage with Wayland

Postby m798 » 2020-08-05 19:46

Code: Select all
# dmesg | grep firmware
[    6.311755] r8169 0000:06:00.0: firmware: direct-loading firmware rtl_nic/rtl8168h-2.fw
[    6.655624] i915 0000:00:02.0: firmware: direct-loading firmware i915/kbl_dmc_ver1_04.bin
[    6.656237] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
m798
 
Posts: 8
Joined: 2020-08-05 16:17
Location: Netherlands

Re: Gnome shell high CPU usage with Wayland

Postby Head_on_a_Stick » 2020-08-05 21:04

m798 wrote:installed using openmediavault installation image

^ What does this mean, exactly?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12316
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Gnome shell high CPU usage with Wayland

Postby m798 » 2020-08-05 21:18

Head_on_a_Stick wrote:
m798 wrote:installed using openmediavault installation image

^ What does this mean, exactly?


I used an ISO image ftom https://www.openmediavault.org/download.html to make a bootable usb stick for installation of the OS. Openmediavault is based on Debian and is pre-configured to be used as a NAS, making it easier to setup.
m798
 
Posts: 8
Joined: 2020-08-05 16:17
Location: Netherlands

Re: Gnome shell high CPU usage with Wayland

Postby cuckooflew » 2020-08-05 22:05

In other words, you are not really using Debian, but something else that is "based on" Debian, ? Remove that software, and install Debian, use a official image from Debian.org, https://www.debian.org/distrib/

Post by m798 » 2020-08-05 16:33
I have the exact same issue,---
But it is not the exact same OS, is it ?
Please Read What we expect you have already Done
Google knows a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
…one flew east, one flew west,
One flew over the cuckoo’s nest.
cuckooflew
 
Posts: 546
Joined: 2018-05-10 19:34
Location: Some where out west

Re: Gnome shell high CPU usage with Wayland

Postby m798 » 2020-08-05 22:32

Oops, I guess you're right. I didn't think of this. Thanks and apologies for hijacking with not exactly the same issue. I'll try to do a fresh install and see if that helps.
m798
 
Posts: 8
Joined: 2020-08-05 16:17
Location: Netherlands

Re: Gnome shell high CPU usage with Wayland

Postby cuckooflew » 2020-08-05 23:11

Since the same thing is happening, even with a pure Debian, re-installing might not change anything, but at least then is will really be exactly the same.
The Gnome "factor" probably is another topic as well, all though I agree with oswaldkelso .
Head_on_a_Stick wrote:^ Check
Code: Select all
# dmesg | grep firmware

And confirm which firmware packages you have installed.

If you want, maybe consider still showing us this, and see what H_O_A_S says, they may have "non-free' firmware packages, that are not used in the default Debian install,.. thus making the set-up easier.
Openmediavault is based on Debian and is pre-configured to be used as a NAS, making it easier to setup.

If they do have some kind of support forum, that might be a better option, I suppose that might depend on how long you have been using the Openmediavault, if it is a fresh install, re-installing is no big deal, if it has been your main OS for sometime, be sure to make a copy / backup of everything you want/need to save, eg /home/directory.
Please Read What we expect you have already Done
Google knows a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
…one flew east, one flew west,
One flew over the cuckoo’s nest.
cuckooflew
 
Posts: 546
Joined: 2018-05-10 19:34
Location: Some where out west

Re: Gnome shell high CPU usage with Wayland

Postby stevepusser » 2020-08-06 05:33

Take it from me--Intel tenth-generation GPUs also need a newer Mesa, which isn't in backports. :(
I speak from experience from the AHS edition of MX Linux, which does have its own backports. Or you could ignore this advice--let's get the popcorn and watch.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0, QMPlay2 20.07.04, Pale Moon 28.12.0, KeepassXC 2.6.0, Arqiver 0.6.0+git, Foliate 2.4.2
User avatar
stevepusser
 
Posts: 11891
Joined: 2009-10-06 05:53

Next

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable