Android VM problem on buster

Everything about X, Gnome, KDE, ... and everything running on it

Android VM problem on buster

Postby Scorpion » 2020-09-25 18:50

On debian 9 I had a VM, made with virt-manager, with android, but now on buster (debian 10):
Code: Select all
Booting from Hard Disk...
Boot failed: not a bootable disk

No bootable device.


I remade the android VM but when I open it after the first time I have that problem again.
User avatar
Scorpion
 
Posts: 243
Joined: 2018-10-17 11:38

Re: Android VM problem on buster

Postby CwF » 2020-09-25 20:56

Do you have a copy of the working xml ?
...just the machine type, boot orders, disc emulators...
Something changed! A fresh 10 version is different than the working 9 version.
CwF
 
Posts: 790
Joined: 2018-06-20 15:16

Re: Android VM problem on buster

Postby Scorpion » 2020-09-26 06:15

Where is it saved?
The others VMs are fine.
User avatar
Scorpion
 
Posts: 243
Joined: 2018-10-17 11:38

Re: Android VM problem on buster

Postby CwF » 2020-09-27 14:16

the vm's xml is saved in /etc/libvirt/qemu.
I suspect your image was boot chained to an iso? Your prior xml would have shown this.
CwF
 
Posts: 790
Joined: 2018-06-20 15:16

Re: Android VM problem on buster

Postby Scorpion » 2020-09-27 17:57

I do not have the files from /etc.

I remade the VM and I also tried another ISO, so no chained ISO problems.
User avatar
Scorpion
 
Posts: 243
Joined: 2018-10-17 11:38


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable