USB storage not showing on Debian

Everything about X, Gnome, KDE, ... and everything running on it

USB storage not showing on Debian

Postby ItsShowtime » 2020-10-21 18:12

Hi guys,

I am really confused about this issue, I cannot seem to find my USB storage on my Debain computer.
Both 'df' output as well as screenshot of Disks app can be found below.

This device is a 128GB SanDisk Extreme Pro USB stick. I have tried each (front) USB port on my desktop (both 2.0 as well as 3.0). Any other USB stick works as expected.
The USB stick works just fine on my Windows laptop, since it's brand new I tried formatting it to NTFS and also to ExFAT, but it is still not showing. I also tried deleting the volume on the Windows machine, and recreating it from scratch as well as formatting it in the process, this doesn't work either. I never tried a full format, only a quick one, if not mistaken that means it doesn't mess with the database/boot structure of partition during format. The USB blue light pinks when plugged into my Windows machine, and simply turns on without pinking when plugged into my Debian machine.
Windows Disk Management output can be found below

If I were to guess, this must be a driver that's missing to operate this high speed USB, but I don't want to break my system trying to find out the solution when still being unsure about the issue itself. I am not an expert.


df:
Code: Select all
root@Maxim-Desktop:~# df
Filesystem     1K-blocks      Used Available Use% Mounted on
udev             8164332         0   8164332   0% /dev
tmpfs            1636840     10016   1626824   1% /run
/dev/sda2      228111788  31957492 184497132  15% /
tmpfs            8184180    183100   8001080   3% /dev/shm
tmpfs               5120         4      5116   1% /run/lock
tmpfs            8184180         0   8184180   0% /sys/fs/cgroup
/dev/sdb       245085812   8246856 224319620   4% /mnt/MEGA
/dev/sdc       960381672 186996968 724530192  21% /mnt/Data
/dev/sdd       960381672 692113260 219413900  76% /mnt/Plex
/dev/sda1         523248      5224    518024   1% /boot/efi
tmpfs            1636836        16   1636820   1% /run/user/115
tmpfs            1636836        52   1636784   1% /run/user/1000

Disks:
Image
https://ibb.co/Mc6pj3m

Windows:
Image
https://ibb.co/hmhSZzD
ItsShowtime
 
Posts: 21
Joined: 2019-02-28 14:21

Re: USB storage not showing on Debian

Postby p.H » 2020-10-21 19:43

Did you check the output of lsusb and dmesg before and after plugging the USB stick ?
p.H
 
Posts: 1521
Joined: 2017-09-17 07:12

Re: USB storage not showing on Debian

Postby sgosnell » 2020-10-21 19:51

Do you have fuse and ntfs-3g installed?
Take my advice, I'm not using it.
sgosnell
 
Posts: 910
Joined: 2011-03-14 01:49


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable
cron