USB storage not showing on Debian

Everything about X, Gnome, KDE, ... and everything running on it

USB storage not showing on Debian

Postby ItsShowtime » 2020-10-21 18:12

Hi guys,

I am really confused about this issue, I cannot seem to find my USB storage on my Debain computer.
Both 'df' output as well as screenshot of Disks app can be found below.

This device is a 128GB SanDisk Extreme Pro USB stick. I have tried each (front) USB port on my desktop (both 2.0 as well as 3.0). Any other USB stick works as expected.
The USB stick works just fine on my Windows laptop, since it's brand new I tried formatting it to NTFS and also to ExFAT, but it is still not showing. I also tried deleting the volume on the Windows machine, and recreating it from scratch as well as formatting it in the process, this doesn't work either. I never tried a full format, only a quick one, if not mistaken that means it doesn't mess with the database/boot structure of partition during format. The USB blue light pinks when plugged into my Windows machine, and simply turns on without pinking when plugged into my Debian machine.
Windows Disk Management output can be found below

If I were to guess, this must be a driver that's missing to operate this high speed USB, but I don't want to break my system trying to find out the solution when still being unsure about the issue itself. I am not an expert.


df:
Code: Select all
root@Maxim-Desktop:~# df
Filesystem     1K-blocks      Used Available Use% Mounted on
udev             8164332         0   8164332   0% /dev
tmpfs            1636840     10016   1626824   1% /run
/dev/sda2      228111788  31957492 184497132  15% /
tmpfs            8184180    183100   8001080   3% /dev/shm
tmpfs               5120         4      5116   1% /run/lock
tmpfs            8184180         0   8184180   0% /sys/fs/cgroup
/dev/sdb       245085812   8246856 224319620   4% /mnt/MEGA
/dev/sdc       960381672 186996968 724530192  21% /mnt/Data
/dev/sdd       960381672 692113260 219413900  76% /mnt/Plex
/dev/sda1         523248      5224    518024   1% /boot/efi
tmpfs            1636836        16   1636820   1% /run/user/115
tmpfs            1636836        52   1636784   1% /run/user/1000

Disks:
Image
https://ibb.co/Mc6pj3m

Windows:
Image
https://ibb.co/hmhSZzD
ItsShowtime
 
Posts: 25
Joined: 2019-02-28 14:21

Re: USB storage not showing on Debian

Postby p.H » 2020-10-21 19:43

Did you check the output of lsusb and dmesg before and after plugging the USB stick ?
p.H
 
Posts: 1674
Joined: 2017-09-17 07:12

Re: USB storage not showing on Debian

Postby sgosnell » 2020-10-21 19:51

Do you have fuse and ntfs-3g installed?
Take my advice, I'm not using it.
sgosnell
 
Posts: 974
Joined: 2011-03-14 01:49

Re: USB storage not showing on Debian

Postby ItsShowtime » 2020-12-28 12:43

p.H wrote:Did you check the output of lsusb and dmesg before and after plugging the USB stick ?


Hi there, sorry for the very late reply. I have been completely of the grid for some time. I didn't see anything popping up using the commands, output before and after can be found below:

Code: Select all
root@Maxim-Desktop:~# lsusb
Bus 001 Device 002: ID 8087:8001 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 045e:0810 Microsoft Corp.
Bus 002 Device 003: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 002 Device 005: ID 04ca:007d Lite-On Technology Corp.
Bus 002 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@Maxim-Desktop:~#

root@Maxim-Desktop:~# lsusb
Bus 001 Device 002: ID 8087:8001 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 045e:0810 Microsoft Corp.
Bus 002 Device 003: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 002 Device 005: ID 04ca:007d Lite-On Technology Corp.
Bus 002 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@Maxim-Desktop:~#


Any ideas on what to try next?
ItsShowtime
 
Posts: 25
Joined: 2019-02-28 14:21

Re: USB storage not showing on Debian

Postby ItsShowtime » 2020-12-28 12:46

sgosnell wrote:Do you have fuse and ntfs-3g installed?


Hi there, sorry for the very late reply. I have been completely of the grid for some time.

Yes, both fuse and ntfs-3g were already installed.
Code: Select all
root@Maxim-Desktop:~# apt install fuse
Reading package lists... Done
Building dependency tree       
Reading state information... Done
fuse is already the newest version (2.9.9-1+deb10u1).
fuse set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

root@Maxim-Desktop:~# apt install ntfs-3g
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ntfs-3g is already the newest version (1:2017.3.23AR.3-3).
ntfs-3g set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


Any ideas on what to try next?
ItsShowtime
 
Posts: 25
Joined: 2019-02-28 14:21

Re: USB storage not showing on Debian

Postby p.H » 2020-12-28 13:11

I do not see the output of dmesg after plugging the USB drive.
p.H
 
Posts: 1674
Joined: 2017-09-17 07:12

Re: USB storage not showing on Debian

Postby ItsShowtime » 2021-02-15 14:46

p.H wrote:I do not see the output of dmesg after plugging the USB drive.


Excuse me for the delay, I forgot to add the outputs, you can download them using the following links:

BEFORE:
https://mega.nz/file/yjJjiIaL#dX15jBGyHFqrzqPWiDb7OlmER6N6OVk3_K-NZxwNO6c

AFTER:
https://mega.nz/file/SjQxSCzb#uboFZzB25HorB2injzj8TIy_aOwHnECCKja5DcKdrPQ
ItsShowtime
 
Posts: 25
Joined: 2019-02-28 14:21

Re: USB storage not showing on Debian

Postby p.H » 2021-02-16 13:30

I did not see any difference between the two files, they are exactly the same. Unless you made a mistake and posted the same file twice, this means that the kernel did not detect the USB stick. This matches the output of lsusb showing no difference with or without the stick plugged in.
Kernel or hardware issue.
p.H
 
Posts: 1674
Joined: 2017-09-17 07:12


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable