kdenlive in Debian Strech

Everything about X, Gnome, KDE, ... and everything running on it

kdenlive in Debian Strech

Postby peter_irich » 2020-10-23 18:57

Hello!
Sorry for the my English.
Tell me, please, does kdeinlive works in Debian Stretch and what is needed for this?

In Ubuntu-20.04 i works. I work in Debian Stretch system based and kdenlive not runnings in it with message:
kdenlive: relocation error: kdenlive: symbol qt_qhash_seed, version Qt_5 not defined in file libQt5Core.so.5 with link time reference
This message is in Internet, or it is more simply search qt_qhash_seed.

kdenlive was installed with packets
kded5-dev_5.28.0-1_amd64.deb
kded5_5.28.0-1_amd64.deb
kdenlive-data_16.12.2-1_all.deb
kdenlive-dbg_16.12.2-1_amd64.deb
kdenlive_16.12.2-1_amd64.deb
kinit-dev_5.28.0-1_amd64.deb
kinit_5.28.0-1_amd64.deb
libmlt++3_6.4.1-4_amd64.deb
libmlt-data_6.4.1-4_all.deb
libmlt6_6.4.1-4_amd64.deb
libmovit5_1.4.0-1_amd64.deb
librtaudio5a_4.1.2~ds0-4_amd64.deb
melt_6.4.1-4_amd64.deb
oxygen-icon-theme_5.28.0-1_all.deb
peter_irich
 
Posts: 1299
Joined: 2009-09-10 20:15
Location: Saint-Petersburg, Russian Federation


Re: kdenlive in Debian Strech

Postby peter_irich » 2020-10-23 19:55

I saw this page and kdenlive was installed successfully with packets from my list.
Others packages were already installed.
peter_irich
 
Posts: 1299
Joined: 2009-09-10 20:15
Location: Saint-Petersburg, Russian Federation

Re: kdenlive in Debian Strech

Postby stevepusser » 2020-10-24 03:01

Maybe your Qt 5 is broken, possibly due to incompatible repositories, i.e. FrankenDebian...

Have you tried a Kdenlive AppImage?
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12136
Joined: 2009-10-06 05:53

Re: kdenlive in Debian Strech

Postby peter_irich » 2020-10-24 08:31

No, I use the local repository, assembled from two DVDs with original system, Qt version is 5.11.
The remaining packages are from Debian Stretch, Far example, tcsh and smplayer with packages needed to it.
Kdenlive AppImage not tried.
But it perhaps that my system is FrankenDebian, I can check it 26.10. In my system kernel's version is 4.15,
but Debian Stretch includes kernel-image-4.9.
peter_irich
 
Posts: 1299
Joined: 2009-09-10 20:15
Location: Saint-Petersburg, Russian Federation

Re: kdenlive in Debian Strech

Postby Head_on_a_Stick » 2020-10-24 15:36

peter_irich wrote:I use the local repository, assembled from two DVDs with original system, Qt version is 5.11.

Perhaps check the libqt5core5a version, it should match https://packages.debian.org/stretch/libqt5core5a (currently from the Security repositories).

peter_irich wrote:In my system kernel's version is 4.15

Well that's not right :?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12795
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: kdenlive in Debian Strech

Postby peter_irich » 2020-10-24 17:07

I already checks libqt5core5a.so and reason is exactly in it. Versions this lib in my system and in Debian Stretch are not the same.
libqt5core5a.so in Debian Stretch contains qt_qhash_seed but in my system not.
stevepusser is right, I have FrankenDebian.
I thank all answered.
peter_irich
 
Posts: 1299
Joined: 2009-09-10 20:15
Location: Saint-Petersburg, Russian Federation


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable