Problem with system tray icons

Everything about X, Gnome, KDE, ... and everything running on it

Problem with system tray icons

Postby MagnusT » 2021-01-04 23:44

Hello everybody,
I hope someone can tell me what I'm missing. I can't get apps with system tray icons to run correctly in my setup. Some apps don't run at all, others run but does so without icons. "Pasystray", for example, aborts with the error below:
Code: Select all
(pasystray:8162): Gtk-WARNING **: 01:19:00.775: Could not find the icon 'audio-volume-medium-ltr'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
   http://icon-theme.freedesktop.org/releases

(pasystray:8162): Gtk-WARNING **: 01:19:00.776: Could not load a pixbuf from /org/gtk/libgtk/icons/16x16/status/image-missing.png.
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:../../../../gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /org/gtk/libgtk/icons/16x16/status/image-missing.png: Okänt bildfilformat (gdk-pixbuf-error-quark, 3)
 

The file-path ("/org/...") seems wrong to me. Where is this path set? I have a fresh Buster install. Everything works fine when I log in to LXDE, but not when I log in to EXWM as WM and Polybar from backports as a task bar. In EXWM i manage gtk-settings with xsettingsd, but that doesn't seem to affect the path in the error message above.

/Confused
MagnusT
 
Posts: 1
Joined: 2021-01-04 23:19

Re: Problem with system tray icons

Postby arzgi » 2021-01-05 16:41

Code: Select all
$ apt-file search /16x16/status/image-missing.png
adwaita-icon-theme: /usr/share/icons/Adwaita/16x16/status/image-missing.png
gnome-icon-theme: /usr/share/icons/gnome/16x16/status/image-missing.png
mate-icon-theme: /usr/share/icons/mate/16x16/status/image-missing.png
oxygen-icon-theme: /usr/share/icons/oxygen/base/16x16/status/image-missing.png
tango-icon-theme: /usr/share/icons/Tango/16x16/status/image-missing.png

$ apt-file search audio-volume-medium-ltr
$                             



Seems you need some icon-theme.
arzgi
 
Posts: 701
Joined: 2008-02-21 17:03
Location: Finland

Re: Problem with system tray icons

Postby Brittonn » 2021-01-11 06:55

CODE: SELECT ALL
$ apt-file search /16x16/status/image-missing.png
adwaita-icon-theme: /usr/share/icons/Adwaita/16x16/status/image-missing.png
gnome-icon-theme: /usr/share/icons/Target Pay and Benefits/16x16/status/image-missing.png
mate-icon-theme: /usr/share/icons/mate/16x16/status/image-missing.png
oxygen-icon-theme: /usr/share/icons/oxygen/base/16x16/status/image-missing.png
tango-icon-theme: /usr/share/icons/Tango/16x16/status/image-missing.png

$ apt-file search audio-volume-medium-ltr
$



Seems you need some icon-theme.


If you still don't see icons on your system tray, use the Turn system icons on or off setting and see if it helps. To do this, right-click the Taskbar > Taskbar Settings.
Brittonn
 
Posts: 1
Joined: 2021-01-11 06:54


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable