Debian Squeeze: No Sound

Everything about X, Gnome, KDE, ... and everything running on it

Debian Squeeze: No Sound

Postby proveyourselfthom » 2009-05-15 00:56

Hi, after upgrade to Debian Squeeze, my sound isn't working.
Here is my situation
Code: Select all
Linux thomas 2.6.26-2-486 #1 Thu Mar 26 00:13:41 UTC 2009 i686 GNU/Linux
Code: Select all
lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 05)
Code: Select all
lsmod | grep snd
snd_seq_dummy           2692  0
snd_seq_oss            26112  0
snd_seq_midi            5664  0
snd_rawmidi            18848  1 snd_seq_midi
snd_seq_midi_event      6528  2 snd_seq_oss,snd_seq_midi
snd_seq                41168  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_seq_device          6540  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd_pcm_oss            33056  0
snd_mixer_oss          12800  1 snd_pcm_oss
snd_hda_intel          22344  2
snd_hda_codec_analog    55424  1
snd_hda_codec          59008  2 snd_hda_intel,snd_hda_codec_analog
snd_hwdep               6276  1 snd_hda_codec
snd_pcm                61448  4 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer              17796  3 snd_seq,snd_pcm
snd                    46628  15 snd_seq_dummy,snd_seq_oss,snd_rawmidi,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_hda_codec_analog,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore               6112  1 snd
snd_page_alloc          7816  2 snd_hda_intel,snd_pcm
Code: Select all
dpkg -l alsa*
Desejado=U=Desconhecido/Instalar/Remover/exPurgar/H=Reter
| Estado=Não/Inst/arqs-Cfg/U=Descomp/Falhou-cfg/H=semi-inst/W=trig-adiado/Trig-pend
|/ Erro?=(nenhum)/H=Ret/precisa-Reinst/X=ambos-problemas (Est,Err: maiúsculas=ruim)
||/ Nome           Versão        Descrição
+++-==============-==============-============================================
un  alsa           <nenhuma>      (nenhuma descrição disponível)
ii  alsa-base      1.0.19.dfsg-3  ALSA driver configuration files
ii  alsa-modules-2 1.0.19.dfsg-3+ ALSA modules for kernel 2.6.26-2-486
ii  alsa-oss       1.0.17-1       ALSA wrapper for OSS applications
ii  alsa-source    1.0.19.dfsg-3  ALSA driver sources
pn  alsa-tools     <nenhuma>      (nenhuma descrição disponível)
ii  alsa-utils     1.0.19-2       ALSA utilities

Someone can help me? Thanks
proveyourselfthom
 
Posts: 67
Joined: 2009-05-15 00:45

Re: Debian Squeeze: No Sound

Postby sunrat » 2009-05-15 14:40

First make sure your volumes are up and unmuted in mixer app.
Next you can run alsaconf as root.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 1277
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Debian Squeeze: No Sound

Postby widz » 2009-05-15 20:03

alsaconf is no more in alsa-utils, so yep, its gonna be hard one :)
you have to laugh at the things that hurt you just to keep the world from running you plumb crazy
User avatar
widz
 
Posts: 206
Joined: 2008-01-03 16:44
Location: Currently Scotland, Bulgaria

Re: Debian Squeeze: No Sound

Postby proveyourselfthom » 2009-05-16 16:13

All volumes are up and there isn't alsaconf :(
proveyourselfthom
 
Posts: 67
Joined: 2009-05-15 00:45

Re: Debian Squeeze: No Sound

Postby mlundblad » 2009-05-17 19:42

I seem to have the same problem, quite similar h/w

sagittarius$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

I manually re-set sound devices in Gnome's sound settings.
Now sound works in Rhythmbox and other Gstreamer applications, it seems.
But still no sound in Totem (using xine backend) or VLC.

Did you find a solution?
I'm not quite sure which package to file a bug report against in the BTS
mlundblad
 
Posts: 84
Joined: 2007-02-02 09:51
Location: Uppsala, Sweden

Re: Debian Squeeze: No Sound

Postby proveyourselfthom » 2009-05-18 14:08

My sound still not working. :(
proveyourselfthom
 
Posts: 67
Joined: 2009-05-15 00:45

Re: Debian Squeeze: No Sound

Postby contredire » 2009-05-18 16:41

I am having this problem myself in the last update of squeeze. I don't know how to solve it without starting gnome though. and it has to be done after every boot:
double klick the speaker icon 'volume' and select the previously deselected 'front'. now the sound will work.

I suppose this error will be gone after updating.....
Debian Lenny
contredire
 
Posts: 188
Joined: 2009-01-10 23:12
Location: Linköping, sweden

Re: Debian Squeeze: No Sound

Postby Penguin Skinner » 2009-05-18 17:42

Try running 'alsactl init' (and BTW don't be surprised if it returns some kind of error message saying it can't identify your card and is guessing at the settings; it guess pretty good. :) )
Penguin Skinner
 
Posts: 709
Joined: 2005-09-15 20:37
Location: North by Northwest

Re: Debian Squeeze: No Sound

Postby proveyourselfthom » 2009-05-18 22:06

Code: Select all
alsactl init
Unknown hardware: "HDA-Intel" "Analog Devices AD1986A" "HDA:11d41986" "0x1043" "0x81b3"
Hardware is initialized using a guess method
Nothing. No sound :(
Thank u.
proveyourselfthom
 
Posts: 67
Joined: 2009-05-15 00:45

Re: Debian Squeeze: No Sound

Postby kevin01123 » 2009-05-19 04:17

This is a bug with alsa .19 and snd-hda-intel cards. .20 fixed the majority of these regressions, but that probably doesn't help you out too much. Had this same problem when I was running sid.

http://en.opensuse.org/SDB:Intel-HDA_sound_problems
http://bbs.archlinux.org/viewtopic.php?id=69178

Hope those help. They did me, but my laptop wouldn't recognize when my headphones were plugged in, so sound played out of both the speakers and the headphones.
User avatar
kevin01123
 
Posts: 97
Joined: 2009-05-18 02:19

Re: Debian Squeeze: No Sound

Postby st.steele » 2009-05-19 21:56

After rebooting I had lost all sound today. Fixed it, somewhat randomly, by unmuting the microphone in the volume control (double click on volume applet). I don't know what the issue was, but hopefully that will help someone.

EDIT - I think booting the computer with my USB webcam plugged in caused the problem. It's a Hercules Dualpix Exchange, and if it's not plugged in at boot, no problems. If it is plugged in, you have to unmute mic in volume control.
st.steele
 
Posts: 7
Joined: 2009-05-05 23:23

Re: Debian Squeeze: No Sound

Postby Murz » 2009-07-22 14:35

Same problem on Debian Squeeze & alsa:
Code: Select all
# alsactl init
Unknown hardware: "HDA-Intel" "VIA VIA VT1708B 8-Ch" "HDA:1106e721" "0x1043" "0x82ea"
Hardware is initialized using a guess method


But in KDE (4.2) I hear the startup sound!

What is the number of bug in the tracker for subscribe?
Last edited by Murz on 2009-07-23 05:26, edited 1 time in total.
Murz
 
Posts: 4
Joined: 2009-07-22 14:33

Re: Debian Squeeze: No Sound

Postby milomak » 2009-07-22 21:19

Same problem on Sid

Code: Select all
root ~ # dpkg -l *alsa*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                                   Version                                Description
+++-======================================-======================================-============================================================================================
un  alsa                                   <none>                                 (no description available)
ii  alsa-base                              1.0.20+dfsg-1                          ALSA driver configuration files
un  alsa-oss                               <none>                                 (no description available)
ii  alsa-tools-gui                         1.0.20-1                               GUI based ALSA utilities for specific hardware
ii  alsa-utils                             1.0.20-2                               ALSA utilities
ii  alsamixergui                           0.9.0rc2-1-9                           graphical soundcard mixer for ALSA soundcard driver
ii  gnome-alsamixer                        0.9.7~cvs.20060916.ds.1-2              ALSA sound mixer for GNOME
ii  gstreamer0.10-alsa                     0.10.23-3                              GStreamer plugin for ALSA
un  libarts-alsa                           <none>                                 (no description available)
ii  libesd-alsa0                           0.2.41-5                               Enlightened Sound Daemon (ALSA) - Shared libraries
ii  libsdl1.2debian-alsa                   1.2.13-4+b1                            Simple DirectMedia Layer (with X11 and ALSA options)
root ~ # lspci | grep -i Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
Laptop (64-bit) - Debian Sid and Win8
Desktop (64-bit) - Debian Sid, ArchLinux, Win8 and Fedora 19
MythTV BE/FE - Debian Stable
MythTV FE - Debian Sid
milomak
 
Posts: 1406
Joined: 2009-06-09 22:20

Re: Debian Squeeze: No Sound

Postby anarchyinc666 » 2009-07-27 21:02

Funny, Debian Wiki linked to this thread for the solution but no one has figured it out yet....

# edit

I forgot that I was also testing out new kernels, ran alsactl init under one.... then booted into another. Everything is working again under the 2.6.30 kernel.
-----BEGIN GEEK CODE BLOCK-----
Version: 3.12
GIT d- s: a- C++++ UL++++ P+ L+++ E-- W+++ N- o-- K- w++
O- M-- V-- PS+++ PE+++ Y PGP+++ t-- 5-- X+++ R* tv+++ b DI++++ D
G e+ h---- r+++ y++++
------END GEEK CODE BLOCK------

Debian-SID Xfce
User avatar
anarchyinc666
 
Posts: 303
Joined: 2008-10-22 13:44

Re: Debian Squeeze: No Sound

Postby rplantz » 2009-07-30 15:14

The sound in my Debian sid is also broken. I have discovered that if I do:
Code: Select all
bob@debian:~$ speaker-test -Dplug:surround51 -c6 -twave

both my stereo speakers are working correctly. I take this to mean that my sound driver is loaded and working.

Next, when I do:
Code: Select all
  bob@debian:~$aplay -D front:CARD=CK8S,DEV=0 ring.wav

it works fine. (aplay -L will give you the data for the argument to -D.)

But if I don't explicitly specify the card I get an error:
Code: Select all
  bob@debian:~$ aplay ring.wav
  ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect:
  Connection refused

  aplay: main:608: audio open error: Connection refused

When I become root:
Code: Select all
debian:/home/bob# aplay ring.wav
Playing WAVE 'ring.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

aplay works fine.

There must be a file someplace that has incorrect permissions.

Also, I wonder if my dist-upgrade from lenny to sid left a file behind that conflicts with the newer changes to alsa. In particular, I wonder about the change from alsaconf to alsactl init.
Given how each of us started life, our similarities are much more remarkable than our differences.
rplantz
 
Posts: 36
Joined: 2006-11-29 05:26

Next

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 23 guests

fashionable