Auto-mute speakers when headphones are plugged in

Everything about X, Gnome, KDE, ... and everything running on it

Auto-mute speakers when headphones are plugged in

Postby eric1959 » 2010-11-26 20:23

Debian squeeze 64 bit, gnome. Can't find a solution...
Debian Bits And Snips
Squeeze, Gnome, amd64, Intel Core i3-530, Geforce GT330
eric1959
 
Posts: 1299
Joined: 2008-12-15 13:17
Location: Amsterdam

Re: Auto-mute speakers when headphones are plugged in

Postby Cope57 » 2010-11-27 02:22

Is this a laptop, desktop, and what are the PC specifications?

What is the problem?
( o< -Penguins rule!
/ /\
V_/_
Computers do not have problems, they have users. ~Cope57
User avatar
Cope57
 
Posts: 206
Joined: 2006-12-29 17:22
Location: /home

Re: Auto-mute speakers when headphones are plugged in

Postby eric1959 » 2010-11-27 07:28

It's a desktop, see my signature : Medion Akoya E4360 D desktop PC << Intel i3-530, GeForce GT330, 4 GB RAM, harddisk 1 Terabyte >>
http://www.pcworld.idg.com.au/review/desktop_pcs/medion/akoya_e4360_d/339292/specs#info_bottom
Is it possible to have the speakers auto muted when I plug in a headphone ( in the front ) ?
Image

Code: Select all
lspci | grep -i audio

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
Debian Bits And Snips
Squeeze, Gnome, amd64, Intel Core i3-530, Geforce GT330
eric1959
 
Posts: 1299
Joined: 2008-12-15 13:17
Location: Amsterdam

Re: Auto-mute speakers when headphones are plugged in

Postby Revenger » 2010-11-27 09:35

There is an option "Headphone Jack Sense" in every volume control.
Simplest one is "alsamixer" from alsa-utils package (curses interface). You still have Volume Control in Desktop Environment, but that option is hidden (at least in Gnome, have not tried other desktops) and you have to make it visible through preferences.
Next time someone says 'Go to hell' to me, I come right here.

Do you need bad help?
Revenger
 
Posts: 383
Joined: 2010-11-16 11:47

Re: Auto-mute speakers when headphones are plugged in

Postby eric1959 » 2010-11-27 09:39

No "Headphone Jack Sense" , only "headphone"....
Debian Bits And Snips
Squeeze, Gnome, amd64, Intel Core i3-530, Geforce GT330
eric1959
 
Posts: 1299
Joined: 2008-12-15 13:17
Location: Amsterdam

Re: Auto-mute speakers when headphones are plugged in

Postby Revenger » 2010-11-27 10:00

eric1959 wrote:No "Headphone Jack Sense" , only "headphone"....


It is a bit different in alsamixer, my mistake.

Here you got some screenshots:

Gnome Volume Control
alsamixer
Next time someone says 'Go to hell' to me, I come right here.

Do you need bad help?
Revenger
 
Posts: 383
Joined: 2010-11-16 11:47

Re: Auto-mute speakers when headphones are plugged in

Postby eric1959 » 2010-11-27 10:13

Image

No "Headphone Jack Sense" , only "headphone"....
Debian Bits And Snips
Squeeze, Gnome, amd64, Intel Core i3-530, Geforce GT330
eric1959
 
Posts: 1299
Joined: 2008-12-15 13:17
Location: Amsterdam

Re: Auto-mute speakers when headphones are plugged in

Postby Revenger » 2010-11-27 10:29

eric1959 wrote:Image


It seems that your audio card does not have that option. Sorry, but I am out of ideas.
Next time someone says 'Go to hell' to me, I come right here.

Do you need bad help?
Revenger
 
Posts: 383
Joined: 2010-11-16 11:47

Re: Auto-mute speakers when headphones are plugged in

Postby dtl131 » 2011-10-05 15:23

I saw you complain of this issue in another thread. It's usually fixable with the right model keyword in /etc/modprobe.d/alsa-base.conf . What kind of system is this?
dtl131
 
Posts: 449
Joined: 2011-07-11 19:56

Re: Auto-mute speakers when headphones are plugged in

Postby salome » 2011-10-05 15:33

Do you have vlc installed? I had this issue before which was suddenly resolved when I installed vlc. It's gotta be one of the dependency packages pulled by vlc--but not sure which one. Worth a try.
Debian Wheezy + Xfce
# aptitude purge windows
salome
 
Posts: 43
Joined: 2011-08-10 07:04
Location: Manila, Philippines

Re: Auto-mute speakers when headphones are plugged in

Postby alecs1 » 2011-10-05 21:49

Hi,

For this to work correctly you also need kernel support, from what I know. For me, this problem has disappeared about 2 months ago after having it for long. It was solved with some kernel or ALSA update as far as I know. My card uses the ALC1200 driver, maybe you can spot changes in ALSA using this information. I'll try to come back with more when I have the time.

Alex
Enjoy!
alecs1
 
Posts: 74
Joined: 2006-03-05 09:10


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable