how to install gnome3 in debian

Everything about X, Gnome, KDE, ... and everything running on it

Re: how to install gnome3 in debian

Postby jclark5093 » 2011-03-17 00:12

The GNOME-shell was fantastic, I thought (I tried it with the Fedora 15 alpha that just came out). Reminded me of my android phone a bit... And much more elegant (like when Opera was the only browser with mouse gestures) I don't need a task bar when I can flip the mouse to temp-tile my windows (or expose, or whatever they're calling it)

I felt like I bought a new computer!

I might have to use fedora (blech!) until it makes it's way to the right repositories!!

I guess all the KDE people who always say GNOME is drab are in for some flame wars in the not-so-distant future!
Straight roads are for fast cars.
Curvy roads are for fast drivers.
jclark5093
 
Posts: 7
Joined: 2011-03-16 06:49
Location: Philadelphia Area

Re: how to install gnome3 in debian

Postby bugsbunny » 2011-03-17 08:17

jclark5093 wrote:I just installed squeeze (after a brief stint with fedora just to see Gnome 3, laziness. et cetera. was using #!squeeze before that) and I can't even seem to get my repos accessed - buggy... can't access imap in evolution either... might reinstall - anyway, these are what I have when I tried the working mzilikazi method:

Code: Select all
root@squeeze:/home/jamie# apt-get install -t experimental gnome3-session gnome-themes-standard gnome-control-center gnome-keyring gnome-media libdconf0 dconf-tools gtk3-engines gsettings-desktop-schemas
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package gnome3-session
E: Unable to locate package gnome-themes-standard
E: Unable to locate package libdconf0
E: Unable to locate package dconf-tools
E: Unable to locate package gtk3-engines
E: Unable to locate package gsettings-desktop-schemas
root@squeeze:/home/jamie#


My /etc/app/sources.list looks like this (hodge podge no comments, it's a rough draft)

Code: Select all
jamie@squeeze:/etc/apt$ cat sources.list
#

# deb cdrom:[Debian GNU/Linux 6.0.0 _Squeeze_ - Official Snapshot amd64 LIVE/INSTALL Binary 20110206-06:35]/ squeeze main

# deb cdrom:[Debian GNU/Linux 6.0.0 _Squeeze_ - Official Snapshot amd64 LIVE/INSTALL Binary 20110206-06:35]/ squeeze main

deb http://ftp.us.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.us.debian.org/debian/ squeeze main contrib non-free

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

deb http://ftp.us.debian.org/debian/ squeeze-updates main
deb-src http://ftp.us.debian.org/debian/ squeeze-updates main

deb http://www.debian-multimedia.org wheezy main non-free

deb http://www.debain-multimedia.org sid main non-free

#######################################################
deb http://ftp.debian.org/debian experimental main
deb http://ftp.debian.org/debian/ unstable main #contrib non-free
deb-src http://ftp.debian.org/debian/ unstable main #contrib non-free
#######################################################


And for my first post, I think I deserve a "you're incompitent" since this is my first time on the infamous debain forums :twisted: I can't wait for flames.

But honestly, thank you in advance for any advice, it's been a long stint away from linux as I've been spending a lot of time recording music in my studio (I'll be learning Ardour soon enough, pass on those flames! Reaper is not bad! Be honest!!)


1) If you want to mess around with gnome3 etc I very strongly suggest you upgrade to wheezy rather than running squeeze.
2) You need to add experimental to your repositories.
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: how to install gnome3 in debian

Postby malayo » 2011-03-27 00:56

now it seems that those packages (gnome3-session gnome-themes-standard gnome-control-center gnome-keyring gnome-media libdconf0 dconf-tools gtk3-engines gsettings-desktop-schemas) aren't in experimental as of today

Image
malayo
 
Posts: 38
Joined: 2011-01-21 12:32

Re: how to install gnome3 in debian

Postby bugsbunny » 2011-03-27 04:21

Here's a start on tracking down what you need:
Code: Select all
[bugsbunny]~$aptitude show gnome3-session
No current or candidate version found for gnome3-session
Package: gnome3-session
State: not a real package
Provided by: gnome-session
[bugsbunny]~$apt-show-versions -a gnome-session
Not installed
gnome-session 2.30.2-3  testing      mirrors.kernel.org
gnome-session 2.30.2-3  unstable     mirrors.kernel.org
gnome-session 2.91.93-1 experimental mirrors.kernel.org
gnome-session not installed
[bugsbunny]~$aptitude show gnome-session/experimental
Package: gnome-session                   
State: not installed
Version: 2.91.93-1
Priority: optional
Section: gnome
Maintainer: Josselin Mouette <joss@debian.org>
Uncompressed Size: 2,081 k
Depends: gnome-settings-daemon, gnome-shell, nautilus (>= 2.26),
         policykit-1-gnome, gnome-panel (>= 2.26), metacity,
         notification-daemon, gsettings-desktop-schemas, gnome-session-bin (>=
         2.91.93-1), gnome-session-bin (< 2.92)
Recommends: gnome-session-fallback, gnome-power-manager (>= 2.28)
Suggests: gnome-user-guide, desktop-base, gnome-keyring
Conflicts: gnome-splashscreen-manager, gnome3-session
Breaks: bug-buddy (< 2.20), gnome-power-manager (< 2.28), gnome-session-common
        (< 2.91.91.3-1), xserver-xorg (< 1:7.4)
Replaces: gnome-session-common (< 2.91.91.3-1), gnome3-session
Provides: gnome3-session, x-session-manager
Description: The GNOME Session Manager - GNOME 3 session
 This package contains a session that can be started from a display manager
 such as GDM. It will load all necessary applications for a full-featured user
 session.
 
 The session manager also features the ability to save a running session an
 restore it later.

Tags: interface::daemon, interface::x11, network::server, role::program,
      suite::gnome, uitoolkit::gtk


Code: Select all
$aptitude install -t experimental gnome3-session -s
Note: selecting "gnome-session" instead of the
      virtual package "gnome3-session"
The following NEW packages will be installed:
  accountsservice{a} [0.6.6-2] <+270 kB> (D: gnome-control-center) 
  apg{a} [2.2.3.dfsg.1-2] <+205 kB> (D: gnome-control-center) 
(and a whole bunch more packages). So try again.
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: how to install gnome3 in debian

Postby malayo » 2011-03-27 04:58

when i tried
# aptitude -t experimental install gnome3-session -s

apt tried to remove most of current gnome related packages on testing. There's something else that i need to configure? apt pinning maybe?
malayo
 
Posts: 38
Joined: 2011-01-21 12:32

Re: how to install gnome3 in debian

Postby malayo » 2011-04-04 11:26

apt-get output
Code: Select all
# apt-get install -t experimental gnome-shell
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-shell : Depends: gir1.2-atk-1.0 (>= 1.32) but it is not installable
               Depends: gir1.2-clutter-1.0 (>= 1.4) but it is not installable
               Depends: gir1.2-freedesktop (>= 0.9) but it is not installable
               Depends: gir1.2-gdkpixbuf-2.0 but it is not going to be installed
               Depends: gir1.2-glib-2.0 (>= 0.9) but it is not installable
               Depends: gir1.2-gtk-3.0 but it is not going to be installed
               Depends: gir1.2-json-glib-1.0 but it is not installable
               Depends: gir1.2-mutter-2.91 (>= 2.91.92) but it is not going to be installed
               Depends: gir1.2-pango-1.0 but it is not installable
               Depends: gir1.2-telepathyglib-0.12 but it is not going to be installed
               Depends: gir1.2-telepathylogger-0.2 but it is not going to be installed
               Depends: gjs but it is not going to be installed
               Depends: libclutter-1.0-0 (>= 1.6.0) but 1.2.12-3 is to be installed
               Depends: libgirepository-1.0-1 (>= 0.9.2) but it is not installable
               Depends: libgjs0b (>= 0.7.11) but it is not going to be installed
               Depends: libgnome-desktop-3-0 (>= 2.91.5) but it is not going to be installed
               Depends: libgtk-3-0 (>= 3.0.0) but it is not going to be installed
               Depends: libmutter0 (>= 2.91.92) but it is not going to be installed
               Depends: gnome-settings-daemon (>= 2.91.5.1) but 2.30.2-2 is to be installed
               Depends: gsettings-desktop-schemas (>= 0.1.7) but it is not installable
               Depends: gir1.2-gconf-2.0 but it is not going to be installed
               Depends: gir1.2-gkbd-3.0 but it is not going to be installed
               Depends: gir1.2-polkit-1.0 but it is not installable
               Depends: gir1.2-upowerglib-1.0 but it is not installable
E: Broken packages


aptitude output
Code: Select all
# aptitude install -t experimental gnome-shell
The following NEW packages will be installed:
  gir1.2-gconf-2.0{ab} gir1.2-gdkpixbuf-2.0{ab} gir1.2-gkbd-3.0{ab}
  gir1.2-gtk-3.0{ab} gir1.2-mutter-2.91{ab} gir1.2-telepathyglib-0.12{ab}
  gir1.2-telepathylogger-0.2{ab} gjs{a} gnome-audio{a}
  gnome-desktop3-data{a} gnome-shell{b} gstreamer0.10-pulseaudio{a}
  libasound2-plugins{a} libcairo-gobject2{a} libcanberra-gtk3-0{a}
  libcanberra-gtk3-module{a} libdconf0{a} libgjs0b{ab}
  libgnome-desktop-3-0{ab} libgnomekbd7{a} libgtk-3-0{ab} libgtk-3-bin{a}
  libgtk-3-common{a} libmozjs4d{a} libmutter0{ab} libnotify4{a}
  libpulse-browse0{a} libsamplerate0{a} libtelepathy-logger2{a}
  mutter-common{a} pulseaudio{a} pulseaudio-esound-compat{a}
  pulseaudio-module-x11{a} pulseaudio-utils{a}
The following packages will be upgraded:
  gconf2-common gnome-settings-daemon{b} libgconf2-4 libgdk-pixbuf2.0-0
  libgnomekbd-common libpulse0 libtelepathy-glib0 libxfixes3 libxklavier16
  nautilus-data
10 packages upgraded, 34 newly installed, 0 to remove and 183 not upgraded.
Need to get 34.5 MB of archives. After unpacking 60.1 MB will be used.
The following packages have unmet dependencies:
  gnome-shell: Depends: gir1.2-atk-1.0 (>= 1.32) which is a virtual package.
               Depends: gir1.2-clutter-1.0 (>= 1.4) which is a virtual package.
               Depends: gir1.2-freedesktop (>= 0.9) which is a virtual package.
               Depends: gir1.2-glib-2.0 (>= 0.9) which is a virtual package.
               Depends: gir1.2-json-glib-1.0 which is a virtual package.
               Depends: gir1.2-pango-1.0 which is a virtual package.
               Depends: libclutter-1.0-0 (>= 1.6.0) but 1.2.12-3 is installed.
               Depends: libgirepository-1.0-1 (>= 0.9.2) which is a virtual package.
               Depends: gsettings-desktop-schemas (>= 0.1.7) which is a virtual package.
               Depends: gir1.2-polkit-1.0 which is a virtual package.
               Depends: gir1.2-upowerglib-1.0 which is a virtual package.
  nautilus: Depends: nautilus-data (< 2.31) but 2.91.94-1 is to be installed.
  libgnome-desktop-3-0: Depends: gsettings-desktop-schemas (>= 2.91.92) which is a virtual package.
  gir1.2-mutter-2.91: Depends: gir1.2-atk-1.0 which is a virtual package.
                      Depends: gir1.2-clutter-1.0 (>= 1.4.0) which is a virtual package.
                      Depends: gir1.2-freedesktop which is a virtual package.
                      Depends: gir1.2-glib-2.0 which is a virtual package.
                      Depends: gir1.2-json-glib-1.0 (>= 0.12.0-1~) which is a virtual package.
                      Depends: gir1.2-pango-1.0 which is a virtual package.
  gir1.2-telepathyglib-0.12: Depends: gir1.2-glib-2.0 which is a virtual package.
  gnome-settings-daemon: Depends: gsettings-desktop-schemas which is a virtual package.
  gconf2: Depends: gconf2-common (< 2.29) but 2.32.1-2 is to be installed.
  gir1.2-gtk-3.0: Depends: gir1.2-atk-1.0 which is a virtual package.
                  Depends: gir1.2-freedesktop which is a virtual package.
                  Depends: gir1.2-glib-2.0 which is a virtual package.
                  Depends: gir1.2-pango-1.0 which is a virtual package.
  gir1.2-gkbd-3.0: Depends: gir1.2-atk-1.0 (>= 1.32.0) which is a virtual package.
                   Depends: gir1.2-freedesktop which is a virtual package.
                   Depends: gir1.2-glib-2.0 which is a virtual package.
                   Depends: gir1.2-pango-1.0 which is a virtual package.
  libmutter0: Depends: libclutter-1.0-0 (>= 1.6.0) but 1.2.12-3 is installed.
              Depends: libgirepository-1.0-1 (>= 0.9.2) which is a virtual package.
  gir1.2-telepathylogger-0.2: Depends: gir1.2-glib-2.0 which is a virtual package.
  gir1.2-gconf-2.0: Depends: gir1.2-glib-2.0 which is a virtual package.
  libgtk-3-0: Depends: libpango1.0-0 (>= 1.28.3-2) but 1.28.3-1+squeeze2 is installed.
  gconf-defaults-service: Depends: gconf2-common (< 2.29) but 2.32.1-2 is to be installed.
  libpulse-mainloop-glib0: Depends: libpulse0 (= 0.9.21-4) but 0.9.22-1 is to be installed.
  gir1.2-gdkpixbuf-2.0: Depends: gir1.2-glib-2.0 which is a virtual package.
  libgjs0b: Depends: libgirepository-1.0-1 (>= 0.10.0) which is a virtual package.
The following actions will resolve these dependencies:

       Remove the following packages:                                     
1)       at-spi                                                           
2)       baobab                                                           
3)       brasero                                                           
4)       brasero-common                                                   
5)       capplets-data                                                     
6)       cheese                                                           
7)       cheese-common                                                     
8)       dasher                                                           
9)       dasher-data                                                       
10)      deskbar-applet                                                   
11)      ekiga                                                             
12)      empathy                                                           
13)      eog                                                               
14)      epiphany-browser                                                 
15)      epiphany-browser-data                                             
16)      epiphany-extensions                                               
17)      evince                                                           
18)      evolution                                                         
19)      evolution-data-server                                             
20)      evolution-exchange                                               
21)      evolution-webcal                                                 
22)      file-roller                                                       
23)      gcalctool                                                         
24)      gconf-defaults-service                                           
25)      gconf-editor                                                     
26)      gconf2                                                           
27)      gdebi                                                             
28)      gdm3                                                             
29)      gedit                                                             
30)      gedit-plugins                                                     
31)      gksu                                                             
32)      gnome                                                             
33)      gnome-about                                                       
34)      gnome-accessibility                                               
35)      gnome-applets                                                     
36)      gnome-applets-data                                               
37)      gnome-bluetooth                                                   
38)      gnome-codec-install                                               
39)      gnome-control-center                                             
40)      gnome-core                                                       
41)      gnome-desktop-environment                                         
42)      gnome-dictionary                                                 
43)      gnome-games                                                       
44)      gnome-games-data                                                 
45)      gnome-keyring                                                     
46)      gnome-mag                                                         
47)      gnome-media                                                       
48)      gnome-media-common                                               
49)      gnome-netstatus-applet                                           
50)      gnome-orca                                                       
51)      gnome-panel                                                       
52)      gnome-panel-data                                                 
53)      gnome-power-manager                                               
54)      gnome-screensaver                                                 
55)      gnome-screenshot                                                 
56)      gnome-search-tool                                                 
57)      gnome-session                                                     
58)      gnome-session-bin                                                 
59)      gnome-settings-daemon                                             
60)      gnome-system-log                                                 
61)      gnome-system-monitor                                             
62)      gnome-system-tools                                               
63)      gnome-terminal                                                   
64)      gnome-terminal-data                                               
65)      gnome-user-guide                                                 
66)      gnome-user-share                                                 
67)      gok                                                               
68)      gstreamer0.10-plugins-good                                       
69)      gucharmap                                                         
70)      hamster-applet                                                   
71)      inkscape                                                         
72)      libbonoboui2-0                                                   
73)      libbrasero-media0                                                 
74)      libgail-gnome-module                                             
75)      libgksu2-0                                                       
76)      libgnome-media0                                                   
77)      libgnome-vfs2.0-cil                                               
78)      libgnome2-0                                                       
79)      libgnome2-common                                                 
80)      libgnome2-perl                                                   
81)      libgnome2-vfs-perl                                               
82)      libgnome2.24-cil                                                 
83)      libgnomepanel2.24-cil                                             
84)      libgnomeui-0                                                     
85)      libgnomevfs2-0                                                   
86)      libgnomevfs2-common                                               
87)      libgnomevfs2-extra                                               
88)      libgstfarsight0.10-0                                             
89)      libgweather-common                                               
90)      libgweather1                                                     
91)      libmetacity-private0                                             
92)      libpanel-applet2-0                                               
93)      libpulse-mainloop-glib0                                           
94)      libreoffice-gnome                                                 
95)      libtelepathy-farsight0                                           
96)      liferea                                                           
97)      metacity                                                         
98)      metacity-common                                                   
99)      mousetweaks                                                       
100)     nautilus                                                         
101)     nautilus-data                                                     
102)     nautilus-sendto                                                   
103)     nautilus-sendto-empathy                                           
104)     network-manager-gnome                                             
105)     notification-daemon                                               
106)     openoffice.org-gnome                                             
107)     python-gnome2                                                     
108)     python-gnomeapplet                                               
109)     python-pyatspi                                                   
110)     rhythmbox                                                         
111)     rhythmbox-plugin-cdrecorder                                       
112)     rhythmbox-plugins                                                 
113)     seahorse                                                         
114)     seahorse-plugins                                                 
115)     simple-scan                                                       
116)     software-properties-gtk                                           
117)     sound-juicer                                                     
118)     system-config-printer                                             
119)     tomboy                                                           
120)     totem                                                             
121)     totem-coherence                                                   
122)     totem-common                                                     
123)     totem-mozilla                                                     
124)     totem-plugins                                                     
125)     update-manager-gnome                                             
126)     update-notifier                                                   
127)     vino                                                             
128)     yelp                                                             

       Keep the following packages at their current version:               
129)     gir1.2-gconf-2.0 [Not Installed]                                 
130)     gir1.2-gdkpixbuf-2.0 [Not Installed]                             
131)     gir1.2-gkbd-3.0 [Not Installed]                                   
132)     gir1.2-gtk-3.0 [Not Installed]                                   
133)     gir1.2-mutter-2.91 [Not Installed]                               
134)     gir1.2-telepathyglib-0.12 [Not Installed]                         
135)     gir1.2-telepathylogger-0.2 [Not Installed]                       
136)     gjs [Not Installed]                                               
137)     gnome-shell [Not Installed]                                       
138)     libcanberra-gtk3-0 [Not Installed]                               
139)     libcanberra-gtk3-module [Not Installed]                           
140)     libgjs0b [Not Installed]                                         
141)     libgnome-desktop-3-0 [Not Installed]                             
142)     libgnomekbd7 [Not Installed]                                     
143)     libgtk-3-0 [Not Installed]                                       
144)     libgtk-3-bin [Not Installed]                                     
145)     libmutter0 [Not Installed]                                       
146)     mutter-common [Not Installed]                                     

       Leave the following dependencies unresolved:                       
147)     alacarte recommends gnome-panel                                   
148)     libbrasero-media0 recommends gstreamer0.10-plugins-good           
149)     capplets-data recommends gnome-control-center (>= 1:2.30.1-3)     
150)     empathy-common recommends yelp                                   
151)     epiphany-browser recommends yelp                                 
152)     epiphany-browser recommends evince                               
153)     evolution-common recommends evolution                             
154)     evolution-plugins recommends notification-daemon                 
155)     evolution recommends evolution-webcal                             
156)     evolution recommends yelp                                         
157)     gcalctool recommends yelp                                         
158)     gdm3 recommends at-spi                                           
159)     gdm3 recommends gnome-settings-daemon                             
160)     gedit-common recommends gedit                                     
161)     gnome-applets recommends gnome-system-monitor                     
162)     gnome-applets recommends gnome-netstatus-applet                   
163)     gnome-applets recommends deskbar-applet                           
164)     gnome-applets recommends python-gnome2                           
165)     gnome-applets recommends python-gnomeapplet                       
166)     gnome-games-extra-data recommends gnome-games-data               
167)     libpam-gnome-keyring recommends gnome-keyring                     
168)     gnome-orca recommends gnome-mag (>= 0.12.5)                       
169)     gnome-panel recommends gnome-applets (>= 2.12.1-1)               
170)     gnome-panel recommends gnome-session (>= 2.26)                   
171)     gnome-panel recommends gnome-control-center                       
172)     gnome-screensaver recommends gnome-power-manager                 
173)     gnome-system-tools recommends gnome-control-center (>= 1:2.10.1-1)
174)     gnome-terminal recommends yelp                                   
175)     gucharmap recommends yelp                                         
176)     gvfs-backends recommends gnome-keyring                           
177)     libgnome2-vfs-perl recommends libgnomevfs2-extra                 
178)     libnotify1 recommends notification-daemon                         
179)     gnome-desktop-environment recommends gnome-accessibility         
180)     metacity recommends gnome-session | x-session-manager             
181)     mousetweaks recommends gnome-control-center                       
182)     nautilus recommends brasero (>= 2.26)                             
183)     rhythmbox-plugins recommends nautilus-sendto                     
184)     rhythmbox recommends yelp                                         
185)     rhythmbox recommends notification-daemon                         
186)     rhythmbox recommends rhythmbox-plugins                           
187)     software-center recommends update-notifier                       
188)     software-center recommends software-properties-gtk               
189)     synaptic recommends gksu | kdebase-bin                           
190)     synaptic recommends software-properties-gtk                       
191)     totem-plugins recommends gnome-settings-daemon                   
192)     totem-plugins recommends totem-coherence                         
193)     update-manager-core recommends update-manager-gnome (= 0.200.5-1)
194)     libgtk-3-common recommends libgtk-3-0                             
195)     libnotify4 recommends notification-daemon                         
196)     acpi-support recommends xscreensaver | gnome-screensaver         


Accept this solution? [Y/n/q/?]
The following NEW packages will be installed:
  gstreamer0.10-pulseaudio{a}
The following packages will be REMOVED:
  apache2.2-bin{u} aptdaemon{u} at-spi{a} baobab{a} bogofilter{u}
  bogofilter-bdb{u} bogofilter-common{u} brasero{a} brasero-common{a}
  capplets-data{a} cheese{a} cheese-common{a} cli-common{u}
  cups-pk-helper{u} dasher{a} dasher-data{a} deskbar-applet{a}
  dmz-cursor-theme{u} dnsmasq-base{u} ekiga{a} empathy{a} empathy-common{u}
  eog{a} epiphany-browser{a} epiphany-browser-data{a}
  epiphany-extensions{a} espeak{u} espeak-data{u} evince{a} evolution{a}
  evolution-common{u} evolution-data-server{a} evolution-exchange{a}
  evolution-plugins{u} evolution-webcal{a} exiv2{u} file-roller{a}
  freedesktop-sound-theme{u} freeglut3{u} gcalctool{a}
  gconf-defaults-service{a} gconf-editor{a} gconf2{a} gdebi{a}
  gdebi-core{u} gdm3{a} gedit{a} gedit-common{u} gedit-plugins{a}
  geoclue{u} geoclue-hostip{u} geoclue-localnet{u} geoclue-manual{u}
  geoclue-yahoo{u} gksu{a} gnome{a} gnome-about{a} gnome-accessibility{a}
  gnome-accessibility-themes{u} gnome-applets{a} gnome-applets-data{a}
  gnome-backgrounds{u} gnome-bluetooth{a} gnome-cards-data{u}
  gnome-codec-install{a} gnome-control-center{a} gnome-core{a}
  gnome-desktop-environment{a} gnome-dictionary{a} gnome-disk-utility{u}
  gnome-games{a} gnome-games-data{a} gnome-games-extra-data{u}
  gnome-keyring{a} gnome-mag{a} gnome-media{a} gnome-media-common{a}
  gnome-netstatus-applet{a} gnome-nettool{u} gnome-orca{a} gnome-panel{a}
  gnome-panel-data{a} gnome-power-manager{a} gnome-screensaver{a}
  gnome-screenshot{a} gnome-search-tool{a} gnome-session{a}
  gnome-session-bin{a} gnome-session-canberra{u} gnome-settings-daemon{a}
  gnome-system-log{a} gnome-system-monitor{a} gnome-system-tools{a}
  gnome-terminal{a} gnome-terminal-data{a} gnome-themes{u}
  gnome-themes-extras{u} gnome-themes-more{u} gnome-user-guide{a}
  gnome-user-share{a} gnuchess{u} gnuchess-book{u} gok{a}
  gstreamer0.10-nice{u} gstreamer0.10-plugins-good{a}
  gstreamer0.10-tools{u} gtk2-engines{u} gtk2-engines-pixbuf{u}
  gtk2-engines-smooth{u} gucharmap{a} guile-1.8-libs{u} gvfs-bin{u}
  hamster-applet{a} imagemagick{u} inkscape{a} libapache2-mod-dnssd{u}
  libapr1{u} libaprutil1{u} libaprutil1-dbd-sqlite3{u} libaprutil1-ldap{u}
  libart2.0-cil{u} libatspi1.0-0{u} libavahi-ui0{u} libbonoboui2-0{a}
  libboost-python1.42.0{u} libbrasero-media0{a} libbrlapi0.5{u} libcdt4{u}
  libchamplain-0.4-0{u} libchamplain-gtk-0.4-0{u} libcheese-gtk18{u}
  libclutter-gtk-0.10-0{u} libcolorblind0{u} libcryptui0{u} libdiscid0{u}
  libelf1{u} libepc-1.0-2{u} libepc-common{u} libepc-ui-1.0-2{u}
  libespeak1{u} libevolution{u} libexiv2-9{u}
  libfreerdp-plugins-standard{u} libfreerdp0{u} libgail-common{u}
  libgail-gnome-module{a} libgalago3{u} libgconf2.0-cil{u} libgd2-noxpm{u}
  libgdata-google1.2-1{u} libgdata1.2-1{u} libgdu-gtk0{u} libgee2{u}
  libgeoclue0{u} libgexiv2-0{u} libgksu2-0{a} libglade2.0-cil{u}
  libglib2.0-cil{u} libgmime2.4-cil{u} libgnome-bluetooth7{u}
  libgnome-mag2{u} libgnome-media0{a} libgnome-speech7{u}
  libgnome-vfs2.0-cil{a} libgnome2-0{a} libgnome2-canvas-perl{u}
  libgnome2-common{a} libgnome2-perl{a} libgnome2-vfs-perl{a}
  libgnome2.24-cil{a} libgnomepanel2.24-cil{a} libgnomeui-0{a}
  libgnomevfs2-0{a} libgnomevfs2-common{a} libgnomevfs2-extra{a}
  libgomp1{u} libgpod-common{u} libgpod4{u} libgraph4{u} libgsl0ldbl{u}
  libgssdp-1.0-2{u} libgstfarsight0.10-0{a} libgtk2.0-cil{u}
  libgtkhtml-editor-3.14-0{u} libgtkhtml-editor-3.14-common{u}
  libgtkhtml3.14-19{u} libgtkimageview0{u} libgtksourceview2.0-0{u}
  libgtksourceview2.0-common{u} libgtkspell0{u} libgupnp-1.0-3{u}
  libgupnp-igd-1.0-3{u} libgvc5{u} libgweather-common{a} libgweather1{a}
  liblircclient0{u} liblouis-data{u} liblouis2{u} liblqr-1-0{u}
  liblua5.1-0{u} libmagick++3{u} libmagickcore3{u} libmagickcore3-extra{u}
  libmagickwand3{u} libmetacity-private0{a} libmono-addins-gui0.2-cil{u}
  libmono-addins0.2-cil{u} libmono-cairo2.0-cil{u} libmono-corlib2.0-cil{u}
  libmono-i18n-west2.0-cil{u} libmono-posix2.0-cil{u}
  libmono-security2.0-cil{u} libmono-sharpzip2.84-cil{u}
  libmono-system2.0-cil{u} libmtp8{u} libmusicbrainz3-6{u}
  libndesk-dbus-glib1.0-cil{u} libndesk-dbus1.0-cil{u} libneon27-gnutls{u}
  libnet1{u} libnetpbm10{u} libnice10{u} libnm-glib-vpn1{u} libnm-glib2{u}
  libnm-util1{u} libopal3.6.8{u} libopenobex1{u} libpanel-applet2-0{a}
  libpathplan4{u} libpcap0.8{u} libplot2c2{u} libpolkit-gtk-1-0{u}
  libportaudio2{u} libpstoedit0c2a{u} libpt2.6.7{u}
  libpulse-mainloop-glib0{a} libpython2.6{u} libreoffice-common{u}
  libreoffice-core{u} libreoffice-gnome{a} libreoffice-gtk{u}
  libreoffice-style-galaxy{u} libreoffice-style-tango{u} librpm1{u}
  librpmio1{u} libspeexdsp1{u} libsrtp0{u} libssh-4{u}
  libtelepathy-farsight0{a} libtelepathy-glib0{u} libtidy-0.99-0{u}
  libwmf-bin{u} libwpd-0.9-9{u} libwpg-0.2-2{u} libxdot4{u} liferea{a}
  liferea-data{u} media-player-info{u} metacity{a} metacity-common{a}
  mobile-broadband-provider-info{u} modemmanager{u} mono-2.0-gac{u}
  mono-gac{u} mono-runtime{u} mousetweaks{a} nautilus{a} nautilus-data{a}
  nautilus-sendto{a} nautilus-sendto-empathy{a} netpbm{u}
  network-manager{u} network-manager-gnome{a} notification-daemon{a}
  obex-data-server{u} obexd-client{u} openoffice.org-gnome{a} p7zip-full{u}
  perlmagick{u} pkg-config{u} ppp{u} pstoedit{u} python-aptdaemon{u}
  python-aptdaemon-gtk{u} python-axiom{u} python-beautifulsoup{u}
  python-brlapi{u} python-bugbuddy{u} python-clientform{u}
  python-coherence{u} python-configobj{u} python-crypto{u} python-cups{u}
  python-cupshelpers{u} python-epsilon{u} python-evolution{u}
  python-feedparser{u} python-gdata{u} python-gdbm{u} python-gnome2{a}
  python-gnomeapplet{a} python-gst0.10{u} python-gtkglext1{u}
  python-gtksourceview2{u} python-httplib2{u} python-louie{u}
  python-louis{u} python-mako{u} python-markupsafe{u} python-mechanize{u}
  python-nevow{u} python-notify{u} python-opengl{u} python-openssl{u}
  python-pam{u} python-pkg-resources{u} python-pyasn1{u} python-pyatspi{a}
  python-pysqlite2{u} python-rdflib{u} python-serial{u} python-tagpy{u}
  python-twisted-bin{u} python-twisted-conch{u} python-twisted-core{u}
  python-twisted-web{u} python-utidylib{u} python-vte{u} python-webkit{u}
  python-xdg{u} python-zope.interface{u} remmina{u} remmina-plugin-data{u}
  remmina-plugin-rdp{u} remmina-plugin-vnc{u} rhythmbox{a}
  rhythmbox-plugin-cdrecorder{a} rhythmbox-plugins{a} rpm-common{u}
  rpm2cpio{u} seahorse{a} seahorse-plugins{a} shotwell{u} simple-scan{a}
  software-center{u} software-properties-gtk{a} sound-juicer{a}
  system-config-printer{a} system-config-printer-udev{u} tcl8.4{u}
  tcptraceroute{u} telepathy-gabble{u} telepathy-mission-control-5{u}
  telepathy-salut{u} tomboy{a} totem{a} totem-coherence{a} totem-common{a}
  totem-mozilla{a} totem-plugins{a} transmission-common{u}
  transmission-gtk{u} ufraw-batch{u} update-manager-core{u}
  update-manager-gnome{a} update-notifier{a} update-notifier-common{u}
  usb-modeswitch{u} usb-modeswitch-data{u} vino{a} xdg-user-dirs{u}
  xdg-user-dirs-gtk{u} xserver-xephyr{u} yelp{a}
The following packages will be upgraded:
  gconf2-common libgconf2-4 libgdk-pixbuf2.0-0 libgnomekbd-common libpulse0
  libxfixes3 libxklavier16
7 packages upgraded, 1 newly installed, 374 to remove and 110 not upgraded.
Need to get 3,833 kB of archives. After unpacking 1,282 MB will be freed.
Do you want to continue? [Y/n/?] q
Invalid response.  Please enter a valid command or '?' for help.
Do you want to continue? [Y/n/?] n
Abort.

any suggestion?
malayo
 
Posts: 38
Joined: 2011-01-21 12:32

Re: how to install gnome3 in debian

Postby ChrisBaines » 2011-04-04 14:25

I use gnome shell in experimental and love it! Firstly make sure you have the repositories for sid (unstable) and experimental. It looks like from your package versions that this is not the case, if in doubt post the contents of your apt sources list ( /etc/apt/sources.list ).

A good method I have found for using gnome-shell is to add the packages it depends on to the /etc/apt/preferences file, mine currently looks like this:
Code: Select all

Package: gnome-shell mutter gir1.2-mutter-2.91 mutter-common evolution iceweasel gir1.2-gtk-3.0 libgail-3-0 libgtk-3-0 gir1.2-atk-1.0 gir1.2 clutter-1.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0 gir1.2-gtk-3.0 gir1.2-json-glib-1.0 gir1.2-mutter-2.91 gir1.2-pango-1.0 gir1.2 telepathyglib-0.12 gir1.2-telepathylogger-0.2 gjs libatk1.0-0 libc6 libcairo-gobject2 libcairo2 libcamel1.2-19 libcamel1.2-19 libcanberra0 libclutter-1.0-0 libcroco3 libdbus-1-3 libdbus-glib-1-2 libdrm2 libebook1.2-10 libecal1.2-8 libedataserver1.2-14 libedataserverui1.2-11 libffi5 libfontconfig1 libfreetype6 libgconf2-4 libgdk-pixbuf2.0-0 libgirepository-1.0-1 libgjs0b libgl1-mesa-glx libgl1 libglib2.0-0 libgnome-desktop-3-0 libgnome-menu2 libgstreamer0.10-0 libgtk-3-0 libgtk2.0-0 libical0 libjson-glib-1.0-0 libmozjs4d libmutter0 libnspr4-0d libnss3-1d libpango1.0-0 libpolkit-agent-1-0 libpolkit-gobject-1-0 libpulse-mainloop-glib0 libpulse0 libsoup2.4-1 libsqlite3-0 libstartup-notification0 libtelepathy-glib0 libtelepathy-logger2 libx11-6 libxcomposite1 libxdamage1 libxext6 libxfixes3 libxi6 libxml2 gconf2 libdconf0 gsettings-backend gnome-settings-daemon gnome-control-center gsettings-desktop-schemas gir1.2-gconf-2.0 gir1.2-gkbd-3.0 gir1.2-polkit-1.0 gir1.2-upowerglib-1.0 python pkg-config mesa-utils nautilus
Pin: release a=experimental
Pin-Priority: 900

This appears to help keep gnome-shell usable as mine kept breaking when it updated due to incorrect versions of other packages. It will be interesting to see what happens to the Debian packages when gnome 3 is officially released.

Chris
ChrisBaines
 
Posts: 105
Joined: 2010-06-16 22:31
Location: UK

Re: how to install gnome3 in debian

Postby malayo » 2011-04-06 11:28

it seems that i'm still having the same problem. Here's my sources.list

Code: Select all
deb http://ftp.us.debian.org/debian testing main
deb-src http://ftp.us.debian.org/debian testing main

deb http://ftp.us.debian.org/debian unstable main
deb-src http://ftp.us.debian.org/debian unstable main

deb http://ftp.us.debian.org/debian experimental main
deb-src http://ftp.us.debian.org/debian experimental main


my preferences

Code: Select all
Package: gnome-shell mutter gir1.2-mutter-2.91 mutter-common evolution iceweasel gir1.2-gtk-3.0 libgail-3-0 libgtk-3-0 gir1.2-atk-1.0 gir1.2 clutter-1.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0 gir1.2-gtk-3.0 gir1.2-json-glib-1.0 gir1.2-mutter-2.91 gir1.2-pango-1.0 gir1.2 telepathyglib-0.12 gir1.2-telepathylogger-0.2 gjs libatk1.0-0 libc6 libcairo-gobject2 libcairo2 libcamel1.2-19 libcamel1.2-19 libcanberra0 libclutter-1.0-0 libcroco3 libdbus-1-3 libdbus-glib-1-2 libdrm2 libebook1.2-10 libecal1.2-8 libedataserver1.2-14 libedataserverui1.2-11 libffi5 libfontconfig1 libfreetype6 libgconf2-4 libgdk-pixbuf2.0-0 libgirepository-1.0-1 libgjs0b libgl1-mesa-glx libgl1 libglib2.0-0 libgnome-desktop-3-0 libgnome-menu2 libgstreamer0.10-0 libgtk-3-0 libgtk2.0-0 libical0 libjson-glib-1.0-0 libmozjs4d libmutter0 libnspr4-0d libnss3-1d libpango1.0-0 libpolkit-agent-1-0 libpolkit-gobject-1-0 libpulse-mainloop-glib0 libpulse0 libsoup2.4-1 libsqlite3-0 libstartup-notification0 libtelepathy-glib0 libtelepathy-logger2 libx11-6 libxcomposite1 libxdamage1 libxext6 libxfixes3 libxi6 libxml2 gconf2 libdconf0 gsettings-backend gnome-settings-daemon gnome-control-center gsettings-desktop-schemas gir1.2-gconf-2.0 gir1.2-gkbd-3.0 gir1.2-polkit-1.0 gir1.2-upowerglib-1.0 python pkg-config mesa-utils nautilus
Pin: release a=experimental
Pin-Priority: 900
malayo
 
Posts: 38
Joined: 2011-01-21 12:32

Re: how to install gnome3 in debian

Postby kumarldh » 2011-04-06 16:48

OK, I have installed Gnome-3 but I have lost my gnome 2.x, can't I have both gnome3 and gnome2.x side by side or in worst case remove gnome 3 and reinstall gnome 2.x :(
-
To err is human, to blame it to a computer is more human.
http://www.kumarchetan.com
User avatar
kumarldh
 
Posts: 21
Joined: 2011-02-15 09:42
Location: Bangalore, KA, IN

Re: how to install gnome3 in debian

Postby alr11389 » 2011-04-07 10:36

I installed gnome3 just now and I run this:

# apt-get install -t experimental gnome3-session

This installed me a lot of packages but removes 7. One of these 7 was gnome-session-common I think. The other 6 seems not be important for my problem.

Now, I'm on GNome3 but it is very very ugly.I have activities and more but windows are ugliest and I cant open, for example, system configuration or volume control...

Any suggestions?

Image

Uploaded with ImageShack.us
alr11389
 
Posts: 8
Joined: 2011-04-07 10:33

Re: how to install gnome3 in debian

Postby hellfire[bg] » 2011-04-07 11:21

I had this problem too. My advice would be to just downgrade back to unstable and wait until GNOME 3 comes to the unstable repository. I tried the Fedora 15 live cd with GNOME 3 and i am very impressed :D
...to boldly go where no one has gone before...
User avatar
hellfire[bg]
 
Posts: 499
Joined: 2006-06-21 19:15
Location: Sliven, Bulgaria

Re: how to install gnome3 in debian

Postby alr11389 » 2011-04-07 12:47

hellfire[bg] wrote:I had this problem too. My advice would be to just downgrade back to unstable and wait until GNOME 3 comes to the unstable repository. I tried the Fedora 15 live cd with GNOME 3 and i am very impressed :D


How did you downgrade?

EDIT: auto-answer-me:

# apt-get install gnome-session/stable
alr11389
 
Posts: 8
Joined: 2011-04-07 10:33

Re: how to install gnome3 in debian

Postby phenest » 2011-04-07 22:42

I tried the Suse Live CD in a virtual machine. Due to lack of hardware acceleration, the fall-back is similar to Gnome 2. I'm now installing using sid and experimental repos on a squeeze install (again, in a vm).

EDIT: It works, but only just. It has a little trouble rendering windows but there is a desktop. Virtualbox doesn't have good video accelelation, if at all.
ASRock H77 Pro4-M i7 3770K - 32GB RAM - Pioneer BDR-209D
User avatar
phenest
 
Posts: 1704
Joined: 2010-03-09 09:38
Location: The Matrix

Re: how to install gnome3 in debian

Postby mzilikazi » 2011-04-08 03:05

kumarldh wrote:OK, I have installed Gnome-3 but I have lost my gnome 2.x, can't I have both gnome3 and gnome2.x side by side or in worst case remove gnome 3 and reinstall gnome 2.x :(

Try:
Applications > System Settings > System Info > Graphics > Forced Fallback
Debian Sid Laptops:
AMD Athlon(tm) 64 X2 Dual-Core Processor TK-55 / 1.5G
Intel(R) Pentium(R) Dual CPU T2390 @ 1.86GHz / 3G
User avatar
mzilikazi
Forum Ninja
 
Posts: 3321
Joined: 2004-09-16 02:14
Location: Colorado Springs, CO

Re: how to install gnome3 in debian

Postby bugsbunny » 2011-04-08 06:24

mzilikazi wrote:
kumarldh wrote:OK, I have installed Gnome-3 but I have lost my gnome 2.x, can't I have both gnome3 and gnome2.x side by side or in worst case remove gnome 3 and reinstall gnome 2.x :(

Try:
Applications > System Settings > System Info > Graphics > Forced Fallback


From what I've read this isn't gnome2.x but is actually an alternate interface within gnome3. Just for the record. GNOME 3 and Its Fallback Desktop - Linux Magazine Online
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

PreviousNext

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable