Squeeze: USB audio - not working

Everything about X, Gnome, KDE, ... and everything running on it

Squeeze: USB audio - not working

Postby Mads Holscher » 2011-02-28 17:39

Hi I have a Dac Magic usb sound card based on C-Media 108'.
I'm running a headless server and I want to configure MPD, but I can't get the sound to work.
The card is known to work on linux and I have no problems with it on windwows (it's not defective :) )
Thanks in advance
now
code spam
Code: Select all
root@Server1:~# alsactl init
Unknown hardware: "USB-Audio" "USB Mixer" "USB0d8c:000c" "" ""
Hardware is initialized using a guess method

Code: Select all
root@Server1:~# lsusb |grep -i audio
Bus 003 Device 002: ID 0d8c:000c C-Media Electronics, Inc. Audio Adapter

Code: Select all
root@Server1:~# cat /proc/asound/cards
 1 [default        ]: USB-Audio - C-Media USB Headphone Set
                      C-Media USB Headphone Set   at usb-0000:00:1d.1-1, full speed

Code: Select all
root@Server1:~# alsamixer > alsamixer
cannot open mixer: No such file or directory

Code: Select all
root@Server1:~# speaker-test

speaker-test 1.0.23

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4170:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4170:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4170:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4649:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2190:(snd_pcm_open_noupdate) Unknown PCM default
Playback open error: -2,No such file or directory
Mads Holscher
 
Posts: 3
Joined: 2011-02-23 11:56

Re: Squeeze: USB audio - not working

Postby Mads Holscher » 2011-02-28 17:49

nevermind figured it out myself..

I edited /etc/modprobe.d/alsa-base.conf and changed a -2 into a 0
Code: Select all
options snd-usb-audio index=0


this is a wierd standard config
Mads Holscher
 
Posts: 3
Joined: 2011-02-23 11:56


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable