i386 and amd64 proper deb packages of UMPlayer

Everything about X, Gnome, KDE, ... and everything running on it

i386 and amd64 proper deb packages of UMPlayer

Postby stevepusser » 2011-04-03 03:28

The mcr85+1 packages were built using QT 4.6.3, so will be Squeeze-compatible. UMPlayer is a fork of the abandoned SMPlayer project which adds skinning, Shoutcast stream, and Minitube-like Youtube search, playback, and download capability to the program.

Website: http://www.umplayer.com/

I did a pull and build from the svn repo, since that is newer than the 0.92 debs on the website and solves some Youtube issues. Debianized sources included so one can build the program on any architecture that supports QT 4 4.6 and mplayer...plus it's a good idea not to trust anybody's binaries off the web, so to be really safe, rebuild the program yourself if you don't know who the heck I am.

Update 20 April 2011: Link to svn 143 builds and sources: https://docs.google.com/leaf?id=0B3t2qH ... ZjUx&hl=en

Update: 25 June 2011: new pull from svn--fixes the returning control bar problem with skins and KDE 4 kwin desktop effects enabled:

https://docs.google.com/leaf?id=0B3t2qH ... z&hl=en_US



Squeeze users should use the mcr85 packages, the mcr110 ones need QT 4.7. Sources included as usual.

It looks like it would be a nice addition to the Debian repo...
Last edited by stevepusser on 2011-06-26 04:30, edited 4 times in total.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.3.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8337
Joined: 2009-10-06 05:53

Re: i386 and amd64 proper deb packages of UMPlayer

Postby eric1959 » 2011-04-03 09:26

the abandoned SMPlayer


Did not know that....Thanks for the link !

Installed it....

Image
Debian Bits And Snips
Squeeze, Gnome, amd64, Intel Core i3-530, Geforce GT330
eric1959
 
Posts: 1299
Joined: 2008-12-15 13:17
Location: Amsterdam

Re: i386 and amd64 proper deb packages of UMPlayer

Postby kedaha » 2011-04-03 13:23

I installed it on my 64 bit Squeeze; it looks good but am still trying to get it to work: It just buffers away and refuses to play a video.
User avatar
kedaha
 
Posts: 2596
Joined: 2008-05-24 12:26

Re: i386 and amd64 proper deb packages of UMPlayer

Postby eric1959 » 2011-04-03 14:18

kedaha wrote:I installed it on my 64 bit Squeeze; it looks good but am still trying to get it to work: It just buffers away and refuses to play a video.


Works with my Squeeze 64 bit.....

Image
Debian Bits And Snips
Squeeze, Gnome, amd64, Intel Core i3-530, Geforce GT330
eric1959
 
Posts: 1299
Joined: 2008-12-15 13:17
Location: Amsterdam

Re: i386 and amd64 proper deb packages of UMPlayer

Postby stevepusser » 2011-04-04 02:26

kedaha wrote:I installed it on my 64 bit Squeeze; it looks good but am still trying to get it to work: It just buffers away and refuses to play a video.


I guess from the buffering problem you mean the Youtube video? It may be the mplayer buffering configuration. Usually the system configuration for mplayer is in /etc/mplayer/mplayer.conf, or the user config in ~/.mplayer/mplayer.conf. There is a setting to start playback after a given percentage of the cache is filled. Can you download the Youtube video with the "Record" button?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.3.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8337
Joined: 2009-10-06 05:53

Re: i386 and amd64 proper deb packages of UMPlayer

Postby se7en11 » 2011-04-04 07:07

Thanks works great.
I hope there will be a version install able via apt soon.
se7en11
 
Posts: 14
Joined: 2011-04-04 07:03

Re: i386 and amd64 proper deb packages of UMPlayer

Postby kedaha » 2011-04-04 07:47

Thanks, stevepusser for the reply. It works fine now after reinstalling with gdebi although it notified an error reading the filelist,
Gdebi lists 18 dependencies:
Code: Select all
libaudio2
libfribidi0
libizo2-2
libmysqlclient
libopenal1
libqt4-dbus
libqt4-designer
libqt4-network
libqt4-qt3support
libqt4-script
libqt4-sql
libqt4-sql-mysql
libqt4-xml
libqtcore
libqegui4
mplayer
mysql-common
qt4-qtconfig


Code: Select all
$ apt-cache depends umplayer
umplayer
  Depends: libc6
  Depends: libgcc1
  Depends: libqt4-network
  Depends: libqt4-xml
  Depends: libqtcore4
  Depends: libqtgui4
  Depends: libstdc++6
  Depends: zlib1g
 |Depends: <mplayer-nogui>
  Depends: mplayer
  Recommends: umplayer-translations

So I installed that as well.
User avatar
kedaha
 
Posts: 2596
Joined: 2008-05-24 12:26

Re: i386 and amd64 proper deb packages of UMPlayer

Postby i M@N » 2011-04-09 11:57

Hello.

Many thnxX stevepusser for telling us ... i love SMPlayer and i love UMPlayer even more. Didn't know SMPlayer was abandonned.

Could you tell me how do you compil UMPlayer please? What are the qt and other dev packages needed?

There is a newer version and i'd like to compil it myself.
http://sourceforge.net/projects/umplaye ... ayer-0.92/

By the way how could we ask a developper to package it for Debian?

@+...
1 x Intel(R) Core i7 2600K CPU 3.4GHz Debian sid = roxX !
1 x MSi Wind U100 Debian sid = roxX !!
5 x Intel(R) Pentium(R) 3 CPU 0.80GHz Debian sid = roxX !!!
Read The F***in' Manual or die tryin' ! http://wiki.debian.org
User avatar
i M@N
 
Posts: 19
Joined: 2011-02-17 11:45
Location: Bordeaux, FRANCE / Dakar, SENEGAL

Re: i386 and amd64 proper deb packages of UMPlayer

Postby craigevil » 2011-04-09 12:33

Thanks for the .deb Steve, runs great. Smplayer has been my video player of choice for a while now, glad someone forked it and is keeping it alive.

$ umplayer
This is UMPlayer v. 0.95 running on Linux
Image
Debian Sid KDE Kernel 3.17 Thinkpad R40 Intel M 1.3 CPU 2GB RAM Radeon Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Debian upgrade script smxi | sysinfo script inxi
User avatar
craigevil
 
Posts: 5192
Joined: 2006-09-17 03:17
Location: Oz

Re: i386 and amd64 proper deb packages of UMPlayer

Postby i M@N » 2011-04-09 13:03

back again ...

OK i think i've got it ... wasn't so difficult!

Code: Select all
sudo aptitude install subversion libqt4-dev zlib1g-dev fakeroot build-essential devscripts debhelper g++
svn co https://umplayer.svn.sourceforge.net/svnroot/umplayer umplayer
cd umplayer/umplayer/trunk/
dpkg-buildpackage -rfakeroot -D -us -uc


@+...
1 x Intel(R) Core i7 2600K CPU 3.4GHz Debian sid = roxX !
1 x MSi Wind U100 Debian sid = roxX !!
5 x Intel(R) Pentium(R) 3 CPU 0.80GHz Debian sid = roxX !!!
Read The F***in' Manual or die tryin' ! http://wiki.debian.org
User avatar
i M@N
 
Posts: 19
Joined: 2011-02-17 11:45
Location: Bordeaux, FRANCE / Dakar, SENEGAL

Re: i386 and amd64 proper deb packages of UMPlayer

Postby stevepusser » 2011-04-09 23:50

You could just reuse my /debian directory from my source upload. Since I'm using the new quilt format, you could just extract the debian.tar.gz file and slap the new debian folder over the existing one, then update the changelog with "dch -i" and then build it with "debuild binary" or "debuild -uc -us" if you want new source packages. Hmmm---I thought the version would be higher than 1.0, based on a 1.0 release .deb they have on the umplayer site--guess I was fooled.

I also edited the svn source pull to remove all the .svn folders and the mac-build directory, which has a 18 MB Mac install .dmg file!

I guess I'll do a rebuild of the latest source. It seems that UMPlayer can't save file settings like SMPlayer can yet, that is currently broken.

To get it into Debian, someone needs to file a bug report about it missing from Debian--I think it's a "WTP" or something, or an uploader could look for a Debian maintainer as a mentor to sponsor the package. However, the source from svn is sort of a mess, and I think a real maintainer would have to go through and clean it up to meet Debian policy and clean up all the licenses.

Update: you'd file a bug against the wnpp pseudopackage about it needing packaging--however the packagers are overworked and somebody might never pick it up: http://www.debian.org/devel/wnpp/requested

This is an interesting read: http://www.lshift.net/blog/2009/12/01/g ... nto-debian

I am building the 0.95+svn138 build. I sneakily added the "1:" epoch number to the version to make this upgrade over my first 1.0+svn version.




1
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.3.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8337
Joined: 2009-10-06 05:53

Re: i386 and amd64 proper deb packages of UMPlayer

Postby stevepusser » 2011-04-10 03:09

I have the new versions uploaded, and will update the link in the first post. Note how I sneakily use lzma compression for the source file and the debs to get 4 different builds plus the source in under Google sites 11 MB limit. LZMA is not really kosher for true Debian packages for some reason, but they are working on making the very similar xz compression the default for dpkg.

While I was at it, also built Squeeze-safe (no debian-multimedia dependencies or upstream libs needed) packages of the multithreaded mplayer package from DMO upstream. Set umplayer or smplayer to use "mplayer-mt" and to use multiple threads in the performance settings Only of use for those with multicore/hyperthreaded CPUs and only good for h.264/AVC and mpeg2 encoded video.

https://docs.google.com/leaf?id=0B1UMhs ... ZTFm&hl=en

Edit: Arggh--this build has one dependency on a debian-multimedia library: libbs2b0. Will rebuild without that....OK, link to new package is fixed. About 13 MB for i386, amd64 debs and source files.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.3.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8337
Joined: 2009-10-06 05:53

Re: i386 and amd64 proper deb packages of UMPlayer

Postby se7en11 » 2011-04-15 09:04

again thanks works fine on 32/64 bit.
I hope we will be soon able to install it via apt.
Why is it that people in this forum can use the word "mplayer"?
se7en11
 
Posts: 14
Joined: 2011-04-04 07:03

Re: i386 and amd64 proper deb packages of UMPlayer

Postby eric1959 » 2011-04-15 09:59

Why is it that people in this forum can use the word "mplayer"?


What do you mean....
Debian Bits And Snips
Squeeze, Gnome, amd64, Intel Core i3-530, Geforce GT330
eric1959
 
Posts: 1299
Joined: 2008-12-15 13:17
Location: Amsterdam

Re: i386 and amd64 proper deb packages of UMPlayer

Postby se7en11 » 2011-04-15 13:12

I tried to inform the user in another forum about your package and that it works fine in sid.
But I found out that mplayer will be replaced with *removed*.
Even a link to this tread in this forum conflicts with legal issues and the thread got deleted. So I was wondering ...
se7en11
 
Posts: 14
Joined: 2011-04-04 07:03

Next

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable